summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-08-25 20:44:06 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-08-25 20:44:06 +0000
commitf8c6c95bf1f3b7208c524a03816256e6265222b8 (patch)
treef61c88c1424268541cfde4fe59da063381d78014 /www-client/midori/midori-9999.ebuild
parentVersion bump - Fluxbox Menu Editor 1.1.2 is released (diff)
downloadhistorical-f8c6c95bf1f3b7208c524a03816256e6265222b8.tar.gz
historical-f8c6c95bf1f3b7208c524a03816256e6265222b8.tar.bz2
historical-f8c6c95bf1f3b7208c524a03816256e6265222b8.zip
Take care of new upstream buildsystem wrt bug #235544 thanks to Dale Whittaker
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26-gentoo i686
Diffstat (limited to 'www-client/midori/midori-9999.ebuild')
-rw-r--r--www-client/midori/midori-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/www-client/midori/midori-9999.ebuild b/www-client/midori/midori-9999.ebuild
index d5a9c5ff8a9e..155a31c7b9ce 100644
--- a/www-client/midori/midori-9999.ebuild
+++ b/www-client/midori/midori-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-9999.ebuild,v 1.6 2008/08/22 14:17:53 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-9999.ebuild,v 1.7 2008/08/25 20:44:06 jokey Exp $
inherit git eutils
@@ -8,23 +8,27 @@ DESCRIPTION="A lightweight web browser"
HOMEPAGE="http://www.twotoasts.de/index.php?/pages/midori_summary.html"
EGIT_REPO_URI="git://git.xfce.org/kalikiana/midori"
EGIT_PROJECT="midori"
-EGIT_BOOTSTRAP="NOCONFIGURE=1 ./autogen.sh"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="gvfs sourceview"
DEPEND="x11-libs/gtk+
- x11-libs/libsexy
- net-libs/webkit-gtk"
+ net-libs/webkit-gtk
+ gvfs? ( gnome-base/gvfs )
+ sourceview? ( x11-libs/gtksourceview )"
pkg_setup() {
ewarn "Note: this software is not yet in a too mature status so expect some minor things to break"
}
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+src_compile() {
+ ./waf --prefix="/usr/" configure || die "waf configure failed."
+ ./waf build || die "waf build failed."
+}
+src_install() {
+ DESTDIR=${D} ./waf install || die "waf install failed."
dodoc AUTHORS ChangeLog INSTALL TODO
}