summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-04-01 14:08:38 +0000
committerAlin Năstac <mrness@gentoo.org>2005-04-01 14:08:38 +0000
commit73852de53eae7c72af9a6eddd114b8944431d01b (patch)
tree5439848820fcb97f179b74343d266e99c74deaf2 /www-proxy
parentstable on ia64 (diff)
downloadhistorical-73852de53eae7c72af9a6eddd114b8944431d01b.tar.gz
historical-73852de53eae7c72af9a6eddd114b8944431d01b.tar.bz2
historical-73852de53eae7c72af9a6eddd114b8944431d01b.zip
initial import (#87307)
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'www-proxy')
-rw-r--r--www-proxy/httpush/ChangeLog10
-rw-r--r--www-proxy/httpush/Manifest14
-rw-r--r--www-proxy/httpush/files/digest-httpush-0.9_beta111
-rw-r--r--www-proxy/httpush/httpush-0.9_beta11.ebuild60
-rw-r--r--www-proxy/httpush/metadata.xml6
5 files changed, 91 insertions, 0 deletions
diff --git a/www-proxy/httpush/ChangeLog b/www-proxy/httpush/ChangeLog
new file mode 100644
index 000000000000..743f2ee8cef8
--- /dev/null
+++ b/www-proxy/httpush/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-proxy/httpush
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-proxy/httpush/ChangeLog,v 1.1 2005/04/01 14:08:38 mrness Exp $
+
+*httpush-0.9_beta11 (01 Apr 2005)
+
+ 01 Apr 2005; Alin Nastac <mrness@gentoo.org> +metadata.xml,
+ +httpush-0.9_beta11.ebuild:
+ Initial import from bug #87307.
+
diff --git a/www-proxy/httpush/Manifest b/www-proxy/httpush/Manifest
new file mode 100644
index 000000000000..171a44a27921
--- /dev/null
+++ b/www-proxy/httpush/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 5d6738eb89a93379cf55d6341be67333 httpush-0.9_beta11.ebuild 1407
+MD5 70e003d652ff8faa1a4a1e28fa84174a metadata.xml 415
+MD5 f1a820f6983c659ea883f03597864876 ChangeLog 369
+MD5 c9beb4a47643787632f3a8010dba451f files/digest-httpush-0.9_beta11 65
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCTVX9jiC39V7gKu0RAvkxAKDC/epoYs1exV9ted51Akixh6zTFQCfXmZq
+E2KpzScP9/WTO2wIA1CCP9I=
+=ecjo
+-----END PGP SIGNATURE-----
diff --git a/www-proxy/httpush/files/digest-httpush-0.9_beta11 b/www-proxy/httpush/files/digest-httpush-0.9_beta11
new file mode 100644
index 000000000000..a11bcc3deab8
--- /dev/null
+++ b/www-proxy/httpush/files/digest-httpush-0.9_beta11
@@ -0,0 +1 @@
+MD5 bad2220807a6b2345887ce25953d6ae4 httpush-0.9b11.tar.gz 39342
diff --git a/www-proxy/httpush/httpush-0.9_beta11.ebuild b/www-proxy/httpush/httpush-0.9_beta11.ebuild
new file mode 100644
index 000000000000..68fee40f5092
--- /dev/null
+++ b/www-proxy/httpush/httpush-0.9_beta11.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-proxy/httpush/httpush-0.9_beta11.ebuild,v 1.1 2005/04/01 14:08:38 mrness Exp $
+
+inherit eutils
+
+MY_P="${P/_beta/b}"
+
+DESCRIPTION="Httpush is an intercepting proxy, allowing user to modify HTTP requests on-the-fly"
+HOMEPAGE="http://httpush.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="xml2"
+
+RDEPEND="dev-perl/URI
+ dev-perl/MIME-Base64
+ dev-perl/libwww-perl
+ dev-perl/Net-SSLeay
+ dev-perl/Crypt-SSLeay
+ dev-perl/HTML-Parser
+ xml2? ( dev-perl/XML-Twig )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! useq xml2 ; then
+ echo
+ einfo "If you'd like to use httpush's learning mode, please CTRL-C now"
+ einfo "and enable the xml2 USE flag."
+ epause 3
+ echo
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's:^\(require httpush;\)$:push @INC, "/usr/lib/httpush";\n\1:' \
+ httpush.pl || die "sed INC failed"
+ sed -i 's:^\(.*DATADIR="\)data\(.*\)$:\1/var/lib/httpush\2:' *.pl \
+ lib/plugin/broker.pm || die "sed DATADIR= failed"
+}
+
+src_install() {
+ keepdir /var/lib/httpush
+
+ insinto /usr/lib/httpush
+ doins -r httpush.{dtd,lck,pem,pm} lib
+
+ insinto /usr/share/httpush/plugins
+ doins plugins/*
+
+ newbin httpush.pl httpush
+ newbin reindex.pl reindex
+
+ dodoc README ChangeLog LICENSE doc/*
+}
diff --git a/www-proxy/httpush/metadata.xml b/www-proxy/httpush/metadata.xml
new file mode 100644
index 000000000000..5d4d3e252c9a
--- /dev/null
+++ b/www-proxy/httpush/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>www-proxy</herd>
+<longdescription>HTTPush aims at providing an easy way to audit HTTP and HTTPS application/server security. It supports on-the-fly request modification, automated decision making and vulnerability detection through the use of plugins.</longdescription>
+</pkgmetadata>