summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-07-17 07:34:29 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-07-17 07:34:29 +0000
commit656b0c8cc4d7011aafb12fe164047bc2d1f4da9b (patch)
treef9248278e91ade0ca4aa7ea0da4e748462ee98ea /www-servers/cherokee/files
parentsci-biology/abyss: Moved to autotools-utils.eclass (diff)
downloadhistorical-656b0c8cc4d7011aafb12fe164047bc2d1f4da9b.tar.gz
historical-656b0c8cc4d7011aafb12fe164047bc2d1f4da9b.tar.bz2
historical-656b0c8cc4d7011aafb12fe164047bc2d1f4da9b.zip
Version bump
Package-Manager: portage-2.1.12.2/cvs/Linux x86_64 Manifest-Sign-Key: 0xF52D4BBA
Diffstat (limited to 'www-servers/cherokee/files')
-rw-r--r--www-servers/cherokee/files/cherokee-1.2.103-fix-Makefile-CTK.patch11
-rw-r--r--www-servers/cherokee/files/cherokee-1.2.103-fix-configure.ac.patch16
-rw-r--r--www-servers/cherokee/files/cherokee-1.2.103-linux3.patch36
3 files changed, 63 insertions, 0 deletions
diff --git a/www-servers/cherokee/files/cherokee-1.2.103-fix-Makefile-CTK.patch b/www-servers/cherokee/files/cherokee-1.2.103-fix-Makefile-CTK.patch
new file mode 100644
index 000000000000..98b31823e4dc
--- /dev/null
+++ b/www-servers/cherokee/files/cherokee-1.2.103-fix-Makefile-CTK.patch
@@ -0,0 +1,11 @@
+diff -Naur webserver-1.2.103.orig/admin/Makefile.am webserver-1.2.103/admin/Makefile.am
+--- webserver-1.2.103.orig/admin/Makefile.am 2013-01-26 17:52:44.000000000 -0500
++++ webserver-1.2.103/admin/Makefile.am 2013-07-17 03:28:32.000000000 -0400
+@@ -1,6 +1,6 @@
+ ## Cherokee: Makefile.am -*- makefile -*-
+
+-SUBDIRS = plugins wizards CTK icons
++SUBDIRS = plugins wizards icons
+
+ if INSTALL_ADMIN
+ SUBDIRS += static
diff --git a/www-servers/cherokee/files/cherokee-1.2.103-fix-configure.ac.patch b/www-servers/cherokee/files/cherokee-1.2.103-fix-configure.ac.patch
new file mode 100644
index 000000000000..3292c1bd7a37
--- /dev/null
+++ b/www-servers/cherokee/files/cherokee-1.2.103-fix-configure.ac.patch
@@ -0,0 +1,16 @@
+diff -Naur webserver-1.2.103.orig/configure.ac webserver-1.2.103/configure.ac
+--- webserver-1.2.103.orig/configure.ac 2013-01-26 17:52:44.000000000 -0500
++++ webserver-1.2.103/configure.ac 2013-07-15 08:36:01.000000000 -0400
+@@ -1597,12 +1597,6 @@
+ admin/static/images/flags/Makefile
+ admin/static/images/wizards/Makefile
+ admin/static/images/other/Makefile
+-admin/CTK/Makefile
+-admin/CTK/CTK/Makefile
+-admin/CTK/static/css/Makefile
+-admin/CTK/static/images/Makefile
+-admin/CTK/static/js/Makefile
+-admin/CTK/static/Makefile
+ po/Makefile
+ ])
+
diff --git a/www-servers/cherokee/files/cherokee-1.2.103-linux3.patch b/www-servers/cherokee/files/cherokee-1.2.103-linux3.patch
new file mode 100644
index 000000000000..7f96f68ab97e
--- /dev/null
+++ b/www-servers/cherokee/files/cherokee-1.2.103-linux3.patch
@@ -0,0 +1,36 @@
+diff -Naur webserver-1.2.103.orig/admin/SystemStats.py webserver-1.2.103/admin/SystemStats.py
+--- webserver-1.2.103.orig/admin/SystemStats.py 2013-01-26 17:52:44.000000000 -0500
++++ webserver-1.2.103/admin/SystemStats.py 2013-07-15 07:27:11.000000000 -0400
+@@ -39,7 +39,7 @@
+ global _stats
+
+ if not _stats:
+- if sys.platform == 'linux2':
++ if sys.platform == 'linux2' or sys.platform == 'linux3':
+ _stats = System_stats__Linux()
+ elif sys.platform == 'darwin':
+ _stats = System_stats__Darwin()
+diff -Naur webserver-1.2.103.orig/admin/util.py webserver-1.2.103/admin/util.py
+--- webserver-1.2.103.orig/admin/util.py 2013-01-26 17:52:44.000000000 -0500
++++ webserver-1.2.103/admin/util.py 2013-07-15 07:29:12.000000000 -0400
+@@ -341,7 +341,7 @@
+ def os_get_document_root():
+ if sys.platform == 'darwin':
+ return "/Library/WebServer/Documents"
+- elif sys.platform == 'linux2':
++ elif sys.platform == 'linux2' or sys.platform == 'linux3':
+ if os.path.exists ("/etc/redhat-release"):
+ return '/var/www'
+ elif os.path.exists ("/etc/fedora-release"):
+diff -Naur webserver-1.2.103.orig/admin/wizards/php.py webserver-1.2.103/admin/wizards/php.py
+--- webserver-1.2.103.orig/admin/wizards/php.py 2013-01-26 17:52:44.000000000 -0500
++++ webserver-1.2.103/admin/wizards/php.py 2013-07-15 07:29:47.000000000 -0400
+@@ -607,7 +607,7 @@
+ first_group = str(root_group)
+
+ # Systems
+- if sys.platform == 'linux2':
++ if sys.platform == 'linux2' or sys.platform == 'linux3':
+ if os.getuid() == 0:
+ return root_group
+ return first_group