summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-08-18 12:50:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-08-18 12:50:28 +0000
commit910c583c746790e150e154d2f331ab5d61d802ce (patch)
tree09ab4533a38a0bb877d3ae0e9069662b612b5ef0 /www-servers/gatling/gatling-0.11-r1.ebuild
parentMove net-libs/xyssl -> polarssl (diff)
downloadhistorical-910c583c746790e150e154d2f331ab5d61d802ce.tar.gz
historical-910c583c746790e150e154d2f331ab5d61d802ce.tar.bz2
historical-910c583c746790e150e154d2f331ab5d61d802ce.zip
Adding init script support, fixes #272564. Thanks to Fernando V.
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64
Diffstat (limited to 'www-servers/gatling/gatling-0.11-r1.ebuild')
-rw-r--r--www-servers/gatling/gatling-0.11-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/www-servers/gatling/gatling-0.11-r1.ebuild b/www-servers/gatling/gatling-0.11-r1.ebuild
new file mode 100644
index 000000000000..0d405d26def5
--- /dev/null
+++ b/www-servers/gatling/gatling-0.11-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gatling/gatling-0.11-r1.ebuild,v 1.1 2009/08/18 12:50:27 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="High performance web server"
+HOMEPAGE="http://www.fefe.de/gatling/"
+SRC_URI="http://dl.fefe.de/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# We still have compile issues with USE=ssl, so it's commented out for now
+#IUSE="ssl"
+IUSE=""
+
+DEPEND="dev-libs/libowfat
+ dev-libs/dietlibc"
+ #ssl? ( dev-libs/openssl )
+ #"
+RDEPEND=""
+
+src_unpack() {
+ unpack $A
+ cd "${S}"
+
+ epatch "${FILESDIR}/gentoo-vars.patch"
+}
+
+src_compile() {
+ # FIX ME
+ #if use ssl; then
+ # emake tlsgatling || die "emake tlsgatling failed"
+ #fi
+ emake gatling || die "emake gatling failed"
+}
+
+src_install() {
+ dobin gatling || die "installing gatling binary failed"
+ doman gatling.1 || die "installing manpage failed"
+ # FIX ME
+ #dobin tlsgatling || die "installing tlsgatling binary failed"
+
+ newconfd "${FILESDIR}/gatling.confd gatling"
+ newinitd "${FILESDIR}/gatling.initd gatling"
+ dodoc README.{ftp,http} || die "installing docs failed"
+}
+
+pkg_setup() {
+ ebegin "Creating gatling user and group"
+ enewgroup gatling
+ enewuser ${PN} -1 -1 /var/www/localhost ${PN}
+}