summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-04-14 12:05:03 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-04-14 12:05:03 +0000
commitf66d3b928981217c504d3392cfde470b364ca627 (patch)
tree98230299f101bef32248dcbfc2e9c575aa84440a /www-servers/monkeyd
parentStable on alpha, bug 87517. (diff)
downloadhistorical-f66d3b928981217c504d3392cfde470b364ca627.tar.gz
historical-f66d3b928981217c504d3392cfde470b364ca627.tar.bz2
historical-f66d3b928981217c504d3392cfde470b364ca627.zip
New upstream release that fixes a remote execution vuln and a DoS (sec bug #87916). Props to our audit team for finding these issues.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'www-servers/monkeyd')
-rw-r--r--www-servers/monkeyd/ChangeLog8
-rw-r--r--www-servers/monkeyd/Manifest18
-rw-r--r--www-servers/monkeyd/files/digest-monkeyd-0.9.11
-rw-r--r--www-servers/monkeyd/monkeyd-0.9.1.ebuild73
4 files changed, 96 insertions, 4 deletions
diff --git a/www-servers/monkeyd/ChangeLog b/www-servers/monkeyd/ChangeLog
index ecb494e3078a..1a3224e7f64c 100644
--- a/www-servers/monkeyd/ChangeLog
+++ b/www-servers/monkeyd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/monkeyd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.6 2005/02/20 22:47:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.7 2005/04/14 12:05:03 ka0ttic Exp $
+
+*monkeyd-0.9.1 (14 Apr 2005)
+
+ 14 Apr 2005; Aaron Walker <ka0ttic@gentoo.org> +monkeyd-0.9.1.ebuild:
+ New upstream release that fixes a remote execution vuln and a DoS (sec bug
+ #87916). Props to our audit team for finding these issues.
*monkeyd-0.9.0-r1 (20 Feb 2005)
diff --git a/www-servers/monkeyd/Manifest b/www-servers/monkeyd/Manifest
index fbb782bbb6a8..6d5752d3dd46 100644
--- a/www-servers/monkeyd/Manifest
+++ b/www-servers/monkeyd/Manifest
@@ -1,6 +1,18 @@
-MD5 a8b912a4f7a44a5caf89f78b518aeeb7 ChangeLog 2521
-MD5 291658390dada237b2e8533a44409448 metadata.xml 164
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 1b406a89dcd194302ffe13c0dafcb81e monkeyd-0.9.0-r1.ebuild 2047
-MD5 b4069bcda46c5e3e1d3811511b4d9594 files/digest-monkeyd-0.9.0-r1 63
+MD5 c4c8265b049198a7fb604a8917e7694c monkeyd-0.9.1.ebuild 2072
+MD5 c3eafafc23bca2f5f2cbeac4c5df5874 ChangeLog 2763
+MD5 291658390dada237b2e8533a44409448 metadata.xml 164
+MD5 810e268a8cb64ca8f70e205ab8e1d5e2 files/digest-monkeyd-0.9.1 63
MD5 744c1e82caccabdc0a9a61e81dabef4c files/monkeyd.conf.d 278
MD5 69c4c944e7c908857c48df0e8b8a1eb4 files/monkeyd.init.d 484
+MD5 b4069bcda46c5e3e1d3811511b4d9594 files/digest-monkeyd-0.9.0-r1 63
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCXlyoEZCkKN40op4RAvEeAJ9x8b5ggTcLaoKgd0UcPtgefi+DTACgxLFx
+tdGRyL4CZAiObH9is7fU21U=
+=UuG6
+-----END PGP SIGNATURE-----
diff --git a/www-servers/monkeyd/files/digest-monkeyd-0.9.1 b/www-servers/monkeyd/files/digest-monkeyd-0.9.1
new file mode 100644
index 000000000000..4ade6423d3f1
--- /dev/null
+++ b/www-servers/monkeyd/files/digest-monkeyd-0.9.1
@@ -0,0 +1 @@
+MD5 e4febf180e9a708fa9eccc9286c02eab monkey-0.9.1.tar.gz 84389
diff --git a/www-servers/monkeyd/monkeyd-0.9.1.ebuild b/www-servers/monkeyd/monkeyd-0.9.1.ebuild
new file mode 100644
index 000000000000..4d3dde83d888
--- /dev/null
+++ b/www-servers/monkeyd/monkeyd-0.9.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-0.9.1.ebuild,v 1.1 2005/04/14 12:05:03 ka0ttic Exp $
+
+inherit toolchain-funcs
+
+WEBROOT=/var/www/localhost
+
+MY_P="${PN/d}-${PV}"
+DESCRIPTION="fast, efficient, (REALLY) small, and easy to configure web server"
+HOMEPAGE="http://monkeyd.sourceforge.net/"
+SRC_URI="http://monkeyd.sourceforge.net/versions/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE="php"
+
+DEPEND="virtual/libc
+ >=sys-apps/portage-2.0.51"
+RDEPEND="virtual/libc
+ php? ( dev-php/php-cgi )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i '/install -m 755 bin\/banana/d' configure || die "sed banana"
+}
+
+src_compile() {
+ # monkey has it's own funky script ... cant use econf
+ env STRIP=true \
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --cgibin=${WEBROOT}/cgi-bin \
+ --sysconfdir=/etc/${PN} \
+ --datadir=${WEBROOT}/htdocs \
+ --logdir=/var/log/${PN} \
+ --lang=en \
+ || die
+ # Don't install the banana script, it is broken as is anyway and the
+ # functionality is provided by the ${FILESDIR}/monkeyd.init.d script.
+ sed -i '/install -m 755 bin\/banana/d' Makefile
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ make \
+ PREFIX=${D}/usr \
+ BINDIR=${D}/usr/bin \
+ CGIBIN=${D}${WEBROOT}/cgi-bin \
+ SYSCONFDIR=${D}/etc/${PN} \
+ DATADIR=${D}${WEBROOT}/htdocs \
+ LOGDIR=${D}/var/log/${PN} \
+ install \
+ || die "make install failed"
+
+ if use php ; then
+ dosed '/^#AddScript application\/x-httpd-php/s:^#::' /etc/monkeyd/monkey.conf
+ dosed 's:/home/my_home/php/bin/php:/usr/bin/php-cgi:' /etc/monkeyd/monkey.conf
+ fi
+
+ [[ -e ${ROOT}/${WEBROOT}/htdocs/index.html ]] && \
+ mv ${D}${WEBROOT}/htdocs/{index,index-monkey}.html
+
+ dosed "s:/var/log/monkeyd/monkey.pid:/var/run/monkey.pid:" /etc/monkeyd/monkey.conf
+ newinitd ${FILESDIR}/monkeyd.init.d monkeyd
+ newconfd ${FILESDIR}/monkeyd.conf.d monkeyd
+ dodoc README MODULES *.txt
+}