summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-27 00:48:37 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-27 00:48:37 +0000
commitd19ad7a489a06428a1b638f02dfb3a6835dc6590 (patch)
tree7de7ad95ca04a196df7c296f28967a1e8d00c14d /x11-apps/fusion-icon
parentadded check/abort on no selected format via USE flags, solving bug #239954. (diff)
downloadhistorical-d19ad7a489a06428a1b638f02dfb3a6835dc6590.tar.gz
historical-d19ad7a489a06428a1b638f02dfb3a6835dc6590.tar.bz2
historical-d19ad7a489a06428a1b638f02dfb3a6835dc6590.zip
Initial import of fusion-icon to the tree.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64
Diffstat (limited to 'x11-apps/fusion-icon')
-rw-r--r--x11-apps/fusion-icon/ChangeLog10
-rw-r--r--x11-apps/fusion-icon/Manifest4
-rw-r--r--x11-apps/fusion-icon/fusion-icon-0.1.ebuild51
-rw-r--r--x11-apps/fusion-icon/metadata.xml9
4 files changed, 74 insertions, 0 deletions
diff --git a/x11-apps/fusion-icon/ChangeLog b/x11-apps/fusion-icon/ChangeLog
new file mode 100644
index 000000000000..58abd98e80c9
--- /dev/null
+++ b/x11-apps/fusion-icon/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-apps/fusion-icon
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/fusion-icon/ChangeLog,v 1.1 2008/10/27 00:48:37 jmbsvicetto Exp $
+
+*fusion-icon-0.1 (27 Oct 2008)
+
+ 27 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +metadata.xml, +fusion-icon-0.1.ebuild:
+ Initial import of fusion-icon to the tree.
+
diff --git a/x11-apps/fusion-icon/Manifest b/x11-apps/fusion-icon/Manifest
new file mode 100644
index 000000000000..d4d7b853d7fe
--- /dev/null
+++ b/x11-apps/fusion-icon/Manifest
@@ -0,0 +1,4 @@
+DIST fusion-icon-0.1.tar.gz 30508 RMD160 037db986658d112f9c1ed2030e21941dd6748fa4 SHA1 a59d770c9bd3ad28da40648f6a7bfaaf4a1d1a81 SHA256 2e6757fd4fb8ed7d1640fcabfbe10a39f36cf41504eda0dd13605db70273fe79
+EBUILD fusion-icon-0.1.ebuild 1385 RMD160 ae09202e028d641620247c04397ce377333641b4 SHA1 98caabd70be2cfe62081d68aa034fa49bb0ab2f6 SHA256 dbf0ce1c26f59d134fd40d65bf1b0e425ef479dd4b0c8eb301fe20ffe0202e4b
+MISC ChangeLog 405 RMD160 d86d17a789d3444de568f2bb3356c9606a02ccde SHA1 bc8b670112d82702bb6de9df0afc1835147afc69 SHA256 102bef938323417bfd5149861890e47d7d156376e5c6e73f9d7c6bd475956aa5
+MISC metadata.xml 309 RMD160 10e228427119e5e221189226a07c9d9f1e354910 SHA1 2914e79d7c0b37b05b5cf5e3d1eff776a2cad8e3 SHA256 4799edfc76f8c20fcb6176ad3be34e631ca683cd0e716001bf5a5ad1d8e2de37
diff --git a/x11-apps/fusion-icon/fusion-icon-0.1.ebuild b/x11-apps/fusion-icon/fusion-icon-0.1.ebuild
new file mode 100644
index 000000000000..fcf8fbbaadd0
--- /dev/null
+++ b/x11-apps/fusion-icon/fusion-icon-0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/fusion-icon/fusion-icon-0.1.ebuild,v 1.1 2008/10/27 00:48:37 jmbsvicetto Exp $
+
+inherit gnome2-utils python
+
+MINIMUM_COMPIZ_RELEASE=0.6.0
+
+DESCRIPTION="Compiz Fusion Tray Icon and Manager"
+HOMEPAGE="http://compiz-fusion.org"
+SRC_URI="http://dev.gentoo.org/~jmbsvicetto/distfiles/desktop-effects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk qt4"
+RESTRICT="mirror"
+
+RDEPEND="
+ >=dev-python/compizconfig-python-${MINIMUM_COMPIZ_RELEASE}
+ virtual/python
+ >=x11-wm/compiz-${MINIMUM_COMPIZ_RELEASE}
+ gtk? ( >=dev-python/pygtk-2.10 )
+ qt4? ( dev-python/PyQt4 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ x11-apps/xvinfo"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ use gtk && interfaces="${interfaces} gtk"
+ use qt4 && interfaces="${interfaces} qt4"
+ emake "interfaces=${interfaces}" DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize "${ROOT}usr/$(get_libdir)/python${PYVER}"/site-packages/FusionIcon
+
+ use gtk && gnome2_icon_cache_update
+
+ ewarn "DO NOT report bugs to Gentoo's bugzilla"
+ einfo "Please report all bugs to #gentoo-desktop-effects"
+ einfo "Thank you on behalf of the Gentoo Desktop-Effects team"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/x11-apps/fusion-icon/metadata.xml b/x11-apps/fusion-icon/metadata.xml
new file mode 100644
index 000000000000..cf8d75a0e5e9
--- /dev/null
+++ b/x11-apps/fusion-icon/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-effects</herd>
+<maintainer><email>hanno@gentoo.org</email></maintainer>
+<longdescription lang="en">Python bindings for libcompizconfig.
+</longdescription>
+</pkgmetadata>
+