summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-08-08 06:28:13 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-08-08 06:28:13 +0000
commit9320443950a24564d84da3dfc93e586fdfc657b1 (patch)
tree985eef46960083a3b1d79db48f04c8de8b4a1423 /x11-apps/xgc
parentversion bump (diff)
downloadhistorical-9320443950a24564d84da3dfc93e586fdfc657b1.tar.gz
historical-9320443950a24564d84da3dfc93e586fdfc657b1.tar.bz2
historical-9320443950a24564d84da3dfc93e586fdfc657b1.zip
Initial commit for modular X.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'x11-apps/xgc')
-rw-r--r--x11-apps/xgc/ChangeLog9
-rw-r--r--x11-apps/xgc/Manifest2
-rw-r--r--x11-apps/xgc/files/digest-xgc-0.99.01
-rw-r--r--x11-apps/xgc/xgc-0.99.0.ebuild22
4 files changed, 34 insertions, 0 deletions
diff --git a/x11-apps/xgc/ChangeLog b/x11-apps/xgc/ChangeLog
new file mode 100644
index 000000000000..6b5063ca0352
--- /dev/null
+++ b/x11-apps/xgc/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-apps/xgc
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xgc/ChangeLog,v 1.1 2005/08/08 06:28:11 spyderous Exp $
+
+*xgc-0.99.0 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; +xgc-0.99.0.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-apps/xgc/Manifest b/x11-apps/xgc/Manifest
new file mode 100644
index 000000000000..10f23911c35c
--- /dev/null
+++ b/x11-apps/xgc/Manifest
@@ -0,0 +1,2 @@
+MD5 03cf631c854a37e0800be04fa337c982 xgc-0.99.0.ebuild 490
+MD5 175a526d6f633801acb877c2bcbbae87 files/digest-xgc-0.99.0 63
diff --git a/x11-apps/xgc/files/digest-xgc-0.99.0 b/x11-apps/xgc/files/digest-xgc-0.99.0
new file mode 100644
index 000000000000..556f57c66515
--- /dev/null
+++ b/x11-apps/xgc/files/digest-xgc-0.99.0
@@ -0,0 +1 @@
+MD5 623999842bebe7b2768fa75cf56eb499 xgc-0.99.0.tar.bz2 104593
diff --git a/x11-apps/xgc/xgc-0.99.0.ebuild b/x11-apps/xgc/xgc-0.99.0.ebuild
new file mode 100644
index 000000000000..f50e81ac742f
--- /dev/null
+++ b/x11-apps/xgc/xgc-0.99.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xgc/xgc-0.99.0.ebuild,v 1.1 2005/08/08 06:28:11 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xgc application"
+KEYWORDS="~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}