summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-04-27 09:01:17 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-04-27 09:01:17 +0000
commitefd3615757327ee2ac8841c209ec40ae39405124 (patch)
tree43466f32cf105beb50957b175e1c727d18bfbb18 /x11-base
parentUpdated dependency to opengl-update-2.2.0 so we can use 'opengl-update --use-... (diff)
downloadhistorical-efd3615757327ee2ac8841c209ec40ae39405124.tar.gz
historical-efd3615757327ee2ac8841c209ec40ae39405124.tar.bz2
historical-efd3615757327ee2ac8841c209ec40ae39405124.zip
Added --version option.
Package-Manager: portage-2.0.51.20-r4
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/opengl-update/Manifest8
-rw-r--r--x11-base/opengl-update/files/opengl-update-2.2.07
2 files changed, 10 insertions, 5 deletions
diff --git a/x11-base/opengl-update/Manifest b/x11-base/opengl-update/Manifest
index 4eeab0ecb1d3..7bdd64af382c 100644
--- a/x11-base/opengl-update/Manifest
+++ b/x11-base/opengl-update/Manifest
@@ -6,14 +6,14 @@ MD5 69eeef9cee49974bcaae3cb9ddce8abd metadata.xml 366
MD5 1d0a088f9ab53e874cd541221d43cb92 opengl-update-2.2.0.ebuild 2851
MD5 7acbfac090d4bdc3b7ec492bc35b917d opengl-update-2.1.1-r1.ebuild 2420
MD5 219a292f64caeaa46b333eecde2197f2 files/digest-opengl-update-2.2.0 116
-MD5 3262618c6091d1b27657c1ed5bba193e files/opengl-update-2.2.0 9595
+MD5 71359f90cdf1fe0aad2dceddedba18a2 files/opengl-update-2.2.0 9652
MD5 91d9c17541be018d065a7838d7149c86 files/opengl-update-2.1.1 9110
MD5 bbec0e16e4f45a464cec5b4feeecaa9b files/digest-opengl-update-2.1.1-r1 116
MD5 ca73e0f8c9b114553216930eb0eb601a files/glxext.h-inttypes.patch 677
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCbwDAArHZZzCEUG0RAg/oAJ9n7lFLjXte9wID3RPB8H12O/6T1ACfYbKm
-gmTPX83Tz8DqBBNt2D1nC8M=
-=bubL
+iD8DBQFCb1TxArHZZzCEUG0RAt5oAKCEdZLRf+ERhuULQ6KVxiLeAIgRHQCeNFw7
+3yKIslAQp2MoQFTAnVz1yB8=
+=EO8e
-----END PGP SIGNATURE-----
diff --git a/x11-base/opengl-update/files/opengl-update-2.2.0 b/x11-base/opengl-update/files/opengl-update-2.2.0
index 896a310df113..4cb3a038a347 100644
--- a/x11-base/opengl-update/files/opengl-update-2.2.0
+++ b/x11-base/opengl-update/files/opengl-update-2.2.0
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-2.2.0,v 1.3 2005/04/26 20:22:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-2.2.0,v 1.4 2005/04/27 09:01:17 eradicator Exp $
# Author: Martin Schlemmer <azarah@gentoo.org>
# Further modifications by Donnie Berkholz <spyderous@gentoo.org>
# Further modifications based off submissions to bug #54984 <cyfred@gentoo.org>
@@ -80,6 +80,8 @@ print_usage() {
IMPLEM_PLURAL="s"
fi
+ print_version
+
cat << FOO
Usage: ${0##*/} [<options>] <GL implementation>
Set the opengl implementation.
@@ -147,6 +149,9 @@ parse_options() {
--help|-h|-?)
ACION="usage"
;;
+ --version)
+ ACTION="version"
+ ;;
*)
if hasq ${opt} ${AVAIL_IMPLEMS}; then
NEW_GL_IMPLEM="${opt}"