summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-19 16:54:12 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-19 16:54:12 +0000
commit6bbc97b119dc2362658b1145c4bfddc3f6cca6a0 (patch)
tree0810f594fb97e0a23e42e5f8620b3d35b61bb9ed /x11-drivers
parentPossibly broken manifest, be sure. (diff)
downloadhistorical-6bbc97b119dc2362658b1145c4bfddc3f6cca6a0.tar.gz
historical-6bbc97b119dc2362658b1145c4bfddc3f6cca6a0.tar.bz2
historical-6bbc97b119dc2362658b1145c4bfddc3f6cca6a0.zip
Bump, closes #293556
Package-Manager: portage-2.2_rc50/cvs/Linux x86_64
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-virtualbox/ChangeLog14
-rw-r--r--x11-drivers/xf86-input-virtualbox/files/xf86-input-virtualbox-3-localconfig30
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.12.ebuild97
-rw-r--r--x11-drivers/xf86-video-virtualbox/ChangeLog14
-rw-r--r--x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-3-localconfig30
-rw-r--r--x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.0.12.ebuild145
6 files changed, 328 insertions, 2 deletions
diff --git a/x11-drivers/xf86-input-virtualbox/ChangeLog b/x11-drivers/xf86-input-virtualbox/ChangeLog
index 8c3aa9b90ac0..09c86be8b936 100644
--- a/x11-drivers/xf86-input-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-input-virtualbox/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for x11-drivers/xf86-input-virtualbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.24 2009/11/10 01:52:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.25 2009/11/19 16:53:51 patrick Exp $
+
+ 19 Nov 2009; Patrick Lauer <patrick@gentoo.org>
+ +xf86-input-virtualbox-3.0.12.ebuild,
+ +files/xf86-input-virtualbox-3-localconfig:
+ Bump, closes #293556
+
+*xf86-input-virtualbox-3.0.12 (18 Nov 2009)
+
+ 18 Nov 2009; Patrick Lauer <patrick@gentoo.org>
+ +xf86-input-virtualbox-3.0.12.ebuild,
+ +files/xf86-input-virtualbox-3-localconfig:
+ Bump
10 Nov 2009; Patrick Lauer <patrick@gentoo.org>
-xf86-input-virtualbox-1.6.6.ebuild, -xf86-input-virtualbox-3.0.6.ebuild:
diff --git a/x11-drivers/xf86-input-virtualbox/files/xf86-input-virtualbox-3-localconfig b/x11-drivers/xf86-input-virtualbox/files/xf86-input-virtualbox-3-localconfig
new file mode 100644
index 000000000000..535c3f914adf
--- /dev/null
+++ b/x11-drivers/xf86-input-virtualbox/files/xf86-input-virtualbox-3-localconfig
@@ -0,0 +1,30 @@
+# -*- Makefile -*-
+#
+# Overwrite some default kBuild settings
+#
+
+#
+# Copyright (C) 2006-2008 Sun Microsystems, Inc.
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License as published by the Free Software Foundation,
+# in version 2 as it comes in the "COPYING" file of the VirtualBox OSE
+# distribution. VirtualBox OSE is distributed in the hope that it will
+# be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+# don't build testcases to save time, they are not needed for the package
+VBOX_WITH_TESTCASES :=
+VBOX_WITH_TESTSUITE :=
+
+KBUILD_MSG_STYLE := brief
+
+## paths, origin, hardening
+VBOX_WITH_HARDENING := 2
+VBOX_WITH_ORIGIN :=
+VBOX_ONLY_ADDITIONS := 1
+
+TEMPLATE_VBOXGUESTR3XF86MOD_LDFLAGS.release =
+TEMPLATE_VBOXGUESTR3XORGMOD_LDFLAGS = $(TEMPLATE_VBOXGUESTR3DLL_LDFLAGS)
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.12.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.12.ebuild
new file mode 100644
index 000000000000..3b213cbccc66
--- /dev/null
+++ b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.12.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.12.ebuild,v 1.1 2009/11/19 16:53:51 patrick Exp $
+
+EAPI=2
+
+inherit x-modular eutils multilib
+
+MY_P=VirtualBox-${PV}-OSE
+DESCRIPTION="VirtualBox input driver"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hal"
+
+RDEPEND="x11-base/xorg-server
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ >=dev-util/kbuild-0.1.5-r1
+ >=dev-lang/yasm-0.6.2
+ sys-devel/dev86
+ sys-power/iasl
+ x11-proto/inputproto
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P/-OSE/_OSE}
+
+src_prepare() {
+ # Remove shipped binaries (kBuild,yasm), see bug #232775
+ rm -rf kBuild/bin tools
+
+ # Disable things unused or splitted into separate ebuilds
+ cp "${FILESDIR}/${PN}-3-localconfig" LocalConfig.kmk
+}
+
+src_configure() {
+ # build the user-space tools, warnings are harmless
+ ./configure --nofatal \
+ --disable-xpcom \
+ --disable-sdl-ttf \
+ --disable-pulse \
+ --disable-alsa \
+ --build-headless || die "configure failed"
+ source ./env.sh
+}
+
+src_compile() {
+ for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
+ /src/VBox/Additions/x11/vboxmouse ; do
+ cd "${S}"${each}
+ MAKE="kmk" emake TOOL_YASM_AS=yasm \
+ KBUILD_PATH="${S}/kBuild" \
+ || die "kmk failed"
+ done
+}
+
+src_install() {
+ cd "${S}/out/linux.${ARCH}/release/bin/additions"
+ insinto /usr/$(get_libdir)/xorg/modules/input
+
+ # xorg-server-1.6.x
+ if has_version ">=x11-base/xorg-server-1.6" ; then
+ newins vboxmouse_drv_16.so vboxmouse_drv.so
+ # xorg-server-1.5.x
+ else
+ newins vboxmouse_drv_15.so vboxmouse_drv.so
+ fi
+
+ # install hal information file about the mouse driver
+ if use hal; then
+ cd "${S}/src/VBox/Additions/linux/installer"
+ insinto /usr/share/hal/fdi/information/20thirdparty
+ doins 90-vboxguest.fdi
+ fi
+}
+
+pkg_postinst() {
+ elog "You need to edit the file /etc/X11/xorg.conf and set:"
+ elog ""
+ elog " Driver \"vboxmouse\""
+ elog ""
+ elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
+ elog ""
+ if has_version ">=x11-base/xorg-server-1.5" ; then
+ elog "Starting with 1.5 version, X.Org Server can do mouse auto-detection"
+ elog "you may install the hal information file about the mouse driver:"
+ elog ""
+ elog "/usr/share/hal/fdi/information/20thirdparty/90-vboxguest.fdi"
+ elog ""
+ elog "dropping it into: /etc/hal/fdi/policy/"
+ elog ""
+ fi
+}
diff --git a/x11-drivers/xf86-video-virtualbox/ChangeLog b/x11-drivers/xf86-video-virtualbox/ChangeLog
index 0b58ff2866ae..78ef656d4b9d 100644
--- a/x11-drivers/xf86-video-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-video-virtualbox/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for x11-drivers/xf86-video-virtualbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/ChangeLog,v 1.24 2009/11/10 01:51:17 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/ChangeLog,v 1.25 2009/11/19 16:54:12 patrick Exp $
+
+ 19 Nov 2009; Patrick Lauer <patrick@gentoo.org>
+ +xf86-video-virtualbox-3.0.12.ebuild,
+ +files/xf86-video-virtualbox-3-localconfig:
+ Bump, closes #293556
+
+*xf86-video-virtualbox-3.0.12 (18 Nov 2009)
+
+ 18 Nov 2009; Patrick Lauer <patrick@gentoo.org>
+ +xf86-video-virtualbox-3.0.12.ebuild,
+ +files/xf86-video-virtualbox-3-localconfig:
+ Bump
10 Nov 2009; Patrick Lauer <patrick@gentoo.org>
-xf86-video-virtualbox-1.6.6.ebuild, -xf86-video-virtualbox-3.0.6.ebuild:
diff --git a/x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-3-localconfig b/x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-3-localconfig
new file mode 100644
index 000000000000..535c3f914adf
--- /dev/null
+++ b/x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-3-localconfig
@@ -0,0 +1,30 @@
+# -*- Makefile -*-
+#
+# Overwrite some default kBuild settings
+#
+
+#
+# Copyright (C) 2006-2008 Sun Microsystems, Inc.
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License as published by the Free Software Foundation,
+# in version 2 as it comes in the "COPYING" file of the VirtualBox OSE
+# distribution. VirtualBox OSE is distributed in the hope that it will
+# be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+# don't build testcases to save time, they are not needed for the package
+VBOX_WITH_TESTCASES :=
+VBOX_WITH_TESTSUITE :=
+
+KBUILD_MSG_STYLE := brief
+
+## paths, origin, hardening
+VBOX_WITH_HARDENING := 2
+VBOX_WITH_ORIGIN :=
+VBOX_ONLY_ADDITIONS := 1
+
+TEMPLATE_VBOXGUESTR3XF86MOD_LDFLAGS.release =
+TEMPLATE_VBOXGUESTR3XORGMOD_LDFLAGS = $(TEMPLATE_VBOXGUESTR3DLL_LDFLAGS)
diff --git a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.0.12.ebuild b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.0.12.ebuild
new file mode 100644
index 000000000000..9377a865314f
--- /dev/null
+++ b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.0.12.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.0.12.ebuild,v 1.1 2009/11/19 16:54:12 patrick Exp $
+
+EAPI=2
+
+inherit x-modular eutils linux-mod multilib
+
+MY_P=VirtualBox-${PV}-OSE
+DESCRIPTION="VirtualBox video driver"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dri"
+
+RDEPEND="x11-base/xorg-server"
+DEPEND="${RDEPEND}
+ >=dev-util/kbuild-0.1.5-r1
+ >=dev-lang/yasm-0.6.2
+ sys-devel/dev86
+ sys-power/iasl
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ x11-libs/libXdmcp
+ x11-libs/libXcomposite
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXext
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2.4.5 )"
+
+BUILD_TARGETS="all"
+BUILD_TARGET_ARCH="${ARCH}"
+MODULE_NAMES="vboxvideo(misc:${WORKDIR}/vboxvideo_drm:${WORKDIR}/vboxvideo_drm)"
+
+S=${WORKDIR}/${MY_P/-OSE/_OSE}
+
+QA_TEXTRELS_x86="usr/lib/VBoxOGL.so"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERN_DIR=${KV_DIR} KERNOUT=${KV_OUT_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Prepare the vboxvideo_drm sources and Makefile in ${WORKDIR}
+ cp -a "${MY_P/-OSE/_OSE}"/src/VBox/Additions/linux/drm \
+ "${WORKDIR}/vboxvideo_drm"
+ cp "${FILESDIR}/${PN}-3-vboxvideo_drm.makefile" \
+ "${WORKDIR}/vboxvideo_drm/Makefile"
+}
+
+src_prepare() {
+ # Remove shipped binaries (kBuild,yasm), see bug #232775
+ rm -rf kBuild/bin tools
+
+ # Disable things unused or splitted into separate ebuilds
+ cp "${FILESDIR}/${PN}-3-localconfig" LocalConfig.kmk
+
+ # Ugly hack to build the opengl part of the video driver
+ epatch "${FILESDIR}/${PN}-2.2.0-enable-opengl.patch"
+
+ # unset useless/problematic mesa checks in configure
+ epatch "${FILESDIR}/${PN}-3.0.0-mesa-check.patch"
+}
+
+src_configure() {
+ # build the user-space tools, warnings are harmless
+ ./configure --nofatal \
+ --disable-xpcom \
+ --disable-sdl-ttf \
+ --disable-pulse \
+ --disable-alsa \
+ --build-headless || die "configure failed"
+ source ./env.sh
+}
+
+src_compile() {
+ if use dri; then
+ linux-mod_src_compile
+ fi
+
+ for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
+ /src/VBox/{GuestHost/OpenGL,Additions/x11/x11stubs,Additions/common/crOpenGL} \
+ /src/VBox/Additions/x11/vboxvideo ; do
+ cd "${S}"${each}
+ MAKE="kmk" emake TOOL_YASM_AS=yasm \
+ KBUILD_PATH="${S}/kBuild" \
+ || die "kmk failed"
+ done
+}
+
+src_install() {
+ if use dri; then
+ linux-mod_src_install
+ fi
+
+ cd "${S}/out/linux.${ARCH}/release/bin/additions"
+ insinto /usr/$(get_libdir)/xorg/modules/drivers
+
+ # xorg-server-1.6.x
+ if has_version ">=x11-base/xorg-server-1.6" ; then
+ newins vboxvideo_drv_16.so vboxvideo_drv.so
+ # xorg-server-1.5.x
+ else
+ newins vboxvideo_drv_15.so vboxvideo_drv.so
+ fi
+
+ # Guest OpenGL driver
+ insinto /usr/$(get_libdir)
+ doins -r VBoxOGL* || die
+
+ if use dri ; then
+ dosym /usr/$(get_libdir)/VBoxOGL.so /usr/$(get_libdir)/dri/vboxvideo_dri.so
+ fi
+}
+
+pkg_postinst() {
+ elog "You need to edit the file /etc/X11/xorg.conf and set:"
+ elog ""
+ elog " Driver \"vboxvideo\""
+ elog ""
+ elog "in the Graphics device section (Section \"Device\")"
+ elog ""
+ if use dri; then
+ elog "To use the kernel drm video driver, please add:"
+ elog "\"vboxvideo\" to:"
+ if has_version sys-apps/openrc; then
+ elog "/etc/conf.d/modules"
+ else
+ elog "/etc/modules.autoload.d/kernel-${KV_MAJOR}.${KV_MINOR}"
+ fi
+ elog ""
+ fi
+}