summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-01-18 08:19:01 +0000
committerTod Neidt <tod@gentoo.org>2002-01-18 08:19:01 +0000
commit3e49782373a46706423fbe2c8db8ed5ca7d400d3 (patch)
tree7866bb51dd764b7e31db9ad4b42973cc27e1471a /x11-libs/gtk+extra
parentInitial commit, bonobo support disabled for now. (diff)
downloadhistorical-3e49782373a46706423fbe2c8db8ed5ca7d400d3.tar.gz
historical-3e49782373a46706423fbe2c8db8ed5ca7d400d3.tar.bz2
historical-3e49782373a46706423fbe2c8db8ed5ca7d400d3.zip
Initial commit. gtk widget lib needed by scigraphica.
Diffstat (limited to 'x11-libs/gtk+extra')
-rw-r--r--x11-libs/gtk+extra/files/digest-gtk+extra-0.99.171
-rw-r--r--x11-libs/gtk+extra/gtk+extra-0.99.17.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-libs/gtk+extra/files/digest-gtk+extra-0.99.17 b/x11-libs/gtk+extra/files/digest-gtk+extra-0.99.17
new file mode 100644
index 000000000000..63ae18877c0d
--- /dev/null
+++ b/x11-libs/gtk+extra/files/digest-gtk+extra-0.99.17
@@ -0,0 +1 @@
+MD5 390e622c12a5c7f7845ee144ae13ab93 gtk+extra-0.99.17.tar.gz 430080
diff --git a/x11-libs/gtk+extra/gtk+extra-0.99.17.ebuild b/x11-libs/gtk+extra/gtk+extra-0.99.17.ebuild
new file mode 100644
index 000000000000..ac2275e3347d
--- /dev/null
+++ b/x11-libs/gtk+extra/gtk+extra-0.99.17.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tod Neidt <tod@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+extra/gtk+extra-0.99.17.ebuild,v 1.1 2002/01/18 08:19:01 tod Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Useful set of widgets for creating GUI's for the Xwindows system using GTK+."
+
+SRC_URI="http://gtkextra.sourceforge.net/src/${P}.tar.gz"
+
+HOMEPAGE="http://gtkextra.sourceforge.net/"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4"
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die "Installation Failed"
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+
+}