summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:16:32 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:16:32 +0000
commit45ba6dc94d34f43a48e911b0874ad5a264f14aa2 (patch)
treed1b1bc806f2c3adbe1e9930ab5f0e70f5b776ab9 /x11-libs/qt-qt3support
parentForgot to add to IUSE. (diff)
downloadhistorical-45ba6dc94d34f43a48e911b0874ad5a264f14aa2.tar.gz
historical-45ba6dc94d34f43a48e911b0874ad5a264f14aa2.tar.bz2
historical-45ba6dc94d34f43a48e911b0874ad5a264f14aa2.zip
Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
`technical preview`, so this will appear as a downgrade if you installed that version. Thanks to David Leverton, Bo Andresen, Bernd Steinhauser & Arfrever Frehtes Taifersar Arahesis Fixes bugs: 206975, 212086, 172219, 212069, 206976 Package-Manager: portage-2.1.4.4
Diffstat (limited to 'x11-libs/qt-qt3support')
-rw-r--r--x11-libs/qt-qt3support/ChangeLog12
-rw-r--r--x11-libs/qt-qt3support/qt-qt3support-4.4.0_beta1.ebuild44
2 files changed, 54 insertions, 2 deletions
diff --git a/x11-libs/qt-qt3support/ChangeLog b/x11-libs/qt-qt3support/ChangeLog
index 8bfa826aa758..370b08e6d466 100644
--- a/x11-libs/qt-qt3support/ChangeLog
+++ b/x11-libs/qt-qt3support/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-qt3support
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/ChangeLog,v 1.1 2007/12/20 13:01:44 caleb Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/ChangeLog,v 1.2 2008/03/05 23:10:41 ingmar Exp $
+
+*qt-qt3support-4.4.0_beta1 (05 Mar 2008)
+
+ 05 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +qt-qt3support-4.4.0_beta1.ebuild:
+ Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
+ `technical preview`, so this will appear as a downgrade if you installed
+ that version.
*qt-qt3support-4.4.0_rc1 (20 Dec 2007)
diff --git a/x11-libs/qt-qt3support/qt-qt3support-4.4.0_beta1.ebuild b/x11-libs/qt-qt3support/qt-qt3support-4.4.0_beta1.ebuild
new file mode 100644
index 000000000000..c0ad13965a10
--- /dev/null
+++ b/x11-libs/qt-qt3support/qt-qt3support-4.4.0_beta1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/qt-qt3support-4.4.0_beta1.ebuild,v 1.1 2008/03/05 23:10:41 ingmar Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The Qt3 support module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="+accessibility"
+
+DEPEND="~x11-libs/qt-gui-${PV}
+ ~x11-libs/qt-sql-${PV}"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/qt3support
+src/tools/uic3
+tools/designer/src/plugins/widgets
+tools/qtconfig
+tools/porting"
+
+pkg_setup() {
+ QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-core-${PV} qt3support
+ ~x11-libs/qt-gui-${PV} qt3support
+ ~x11-libs/qt-sql-${PV} qt3support"
+ use accessibility && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-gui-${PV} accessibility"
+
+ qt4-build_pkg_setup
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -qt3support
+ $(qt_use accessibility)"
+
+ qt4-build_src_compile
+}