summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-15 15:19:06 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-15 15:19:06 +0000
commitd9b983c6765740686da6e418a3a25ca5df59f9f5 (patch)
tree2687ca6107a1bfcae292c33882b05b2c747c0692 /x11-misc/bbppp/bbppp-0.2.2-r2.ebuild
parentAllowed for virtual/blackbox so that bb apps can be installed with fluxbox as... (diff)
downloadhistorical-d9b983c6765740686da6e418a3a25ca5df59f9f5.tar.gz
historical-d9b983c6765740686da6e418a3a25ca5df59f9f5.tar.bz2
historical-d9b983c6765740686da6e418a3a25ca5df59f9f5.zip
Updated bb applications to use virtual/blackbox dependency
Diffstat (limited to 'x11-misc/bbppp/bbppp-0.2.2-r2.ebuild')
-rw-r--r--x11-misc/bbppp/bbppp-0.2.2-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/bbppp/bbppp-0.2.2-r2.ebuild b/x11-misc/bbppp/bbppp-0.2.2-r2.ebuild
new file mode 100644
index 000000000000..db68ed17bd8e
--- /dev/null
+++ b/x11-misc/bbppp/bbppp-0.2.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbppp/bbppp-0.2.2-r2.ebuild,v 1.1 2002/03/15 15:19:06 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox ppp frontend/monitor"
+SRC_URI="http://bbtools.thelinuxcommunity.org/sources/${P}.tar.gz"
+HOMEPAGE="http://bbtools.windsofstorm.net/available.phtml#bbppp"
+
+DEPEND="virtual/blackbox"
+
+src_compile() {
+ ./configure --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc README COPYING AUTHORS BUGS INSTALL ChangeLog NEWS TODO data/README.bbppp
+}
+
+pkg_postinst() {
+ cd ${ROOT}usr/X11R6/bin/wm
+ if [ ! "`grep bbppp blackbox`" ] ; then
+ sed -e "s/.*blackbox/exec \/usr\/bin\/bbppp \&\n&/" blackbox | cat > blackbox
+ fi
+}