summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-07-30 21:49:13 +0000
committerMichael Weber <xmw@gentoo.org>2014-07-30 21:49:13 +0000
commita184c1ead0453616f5343f59d52604d151c972f1 (patch)
treef68d2241edfae0c9eae94c69fdb5d3fb79e91949 /x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild
parentWhitespace (diff)
downloadhistorical-a184c1ead0453616f5343f59d52604d151c972f1.tar.gz
historical-a184c1ead0453616f5343f59d52604d151c972f1.tar.bz2
historical-a184c1ead0453616f5343f59d52604d151c972f1.zip
Version bump (euscan).
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0x62EEF090
Diffstat (limited to 'x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild')
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild
new file mode 100644
index 000000000000..a9b39b0cecbe
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild,v 1.1 2014/07/30 21:49:08 xmw Exp $
+
+EAPI=4
+
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="trayer fork with multi monitor support, cleaned up codebase and other fancy stuff"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/tarball/${P/-srg/} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ emake DEVEL=1 TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc CHANGELOG CREDITS README TODO
+}