summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-11-03 17:33:38 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-11-03 17:33:38 +0000
commit8dfc06d8d896ed124045cf7d89e112deae2ae6bf (patch)
treeed373780b1f8e01dcf8cec3450189458a6d4fe65 /x11-misc/treeline/treeline-0.13.1.ebuild
parentWe aren't compatible with wv-1.2.0 yet, so depend on 1.0.3-r1 for now (will b... (diff)
downloadhistorical-8dfc06d8d896ed124045cf7d89e112deae2ae6bf.tar.gz
historical-8dfc06d8d896ed124045cf7d89e112deae2ae6bf.tar.bz2
historical-8dfc06d8d896ed124045cf7d89e112deae2ae6bf.zip
bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'x11-misc/treeline/treeline-0.13.1.ebuild')
-rw-r--r--x11-misc/treeline/treeline-0.13.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/treeline/treeline-0.13.1.ebuild b/x11-misc/treeline/treeline-0.13.1.ebuild
new file mode 100644
index 000000000000..e1279f7026e9
--- /dev/null
+++ b/x11-misc/treeline/treeline-0.13.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-0.13.1.ebuild,v 1.1 2005/11/03 17:33:38 taviso Exp $
+
+inherit python
+
+DESCRIPTION="TreeLine is a structured information storage program."
+HOMEPAGE="http://www.bellz.org/treeline/"
+
+SRC_URI="http://www.bellz.org/treeline/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~ppc ~x86"
+IUSE="spell"
+
+DEPEND="spell? ( || ( app-text/aspell app-text/ispell ) )
+ || ( dev-python/pyxml dev-libs/expat )
+ virtual/python dev-python/PyQt
+ =x11-libs/qt-3*"
+
+S=${WORKDIR}/TreeLine
+
+src_compile() {
+ printf '#!/bin/sh\n\nexec python %s/treeline.py $*\n' \
+ /usr/lib/treeline > ${T}/treeline
+ sed -i -e "s#\(helpFilePath = \)None#\1'/usr/lib/treeline'#g" \
+ -e "s#\(iconPath = \)None#\1'/usr/share/icons/treeline'#g" \
+ ${S}/source/treeline.py || die
+}
+
+src_install() {
+ dodir /usr/lib/treeline /usr/share/icons
+
+ insinto /usr/lib/treeline
+ doins ${S}/source/*.py ${S}/doc/README.html
+
+ insinto /usr/share/icons/treeline
+ doins ${S}/icons/*.png
+
+ dodoc ${S}/doc/LICENSE ${S}/doc/*.trl
+ dohtml ${S}/doc/README.html
+
+ dobin ${T}/treeline
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/lib/treeline
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib/treeline
+}