summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-06-25 18:37:32 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-06-25 18:37:32 +0000
commit3ad2cf6c11916ff634e5cae66a0dbc2df89c4299 (patch)
tree49a6e81cf35002a4702ac267bacf7736be8db133 /x11-misc/xfdesktop
parentFixed dependency issue. (diff)
downloadhistorical-3ad2cf6c11916ff634e5cae66a0dbc2df89c4299.tar.gz
historical-3ad2cf6c11916ff634e5cae66a0dbc2df89c4299.tar.bz2
historical-3ad2cf6c11916ff634e5cae66a0dbc2df89c4299.zip
tweak config
Diffstat (limited to 'x11-misc/xfdesktop')
-rw-r--r--x11-misc/xfdesktop/Manifest2
-rw-r--r--x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild14
2 files changed, 13 insertions, 3 deletions
diff --git a/x11-misc/xfdesktop/Manifest b/x11-misc/xfdesktop/Manifest
index 4f5962f7d407..170d46441c90 100644
--- a/x11-misc/xfdesktop/Manifest
+++ b/x11-misc/xfdesktop/Manifest
@@ -1,4 +1,4 @@
-MD5 eac27aaadeef44d7c1b95d36ffb86e74 xfdesktop-3.91.0.ebuild 913
+MD5 a563447e970a2e34dc42dbc5eed9df50 xfdesktop-3.91.0.ebuild 1038
MD5 5ecbbac606b2c4fb0b0c7031ebcd103f ChangeLog 462
MD5 5831fefd1e1c1625022e71fcc21a69de xfdesktop-3.90.0.ebuild 913
MD5 c6cf7c00bac72188466ef97425c12a3f files/digest-xfdesktop-3.90.0 69
diff --git a/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild b/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild
index 0e1516e8e846..7b220de649c5 100644
--- a/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild
+++ b/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild,v 1.1 2003/06/25 06:06:08 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfdesktop/xfdesktop-3.91.0.ebuild,v 1.2 2003/06/25 18:37:12 bcowan Exp $
-IUSE=""
+IUSE="X"
S=${WORKDIR}/${P}
DESCRIPTION="Xfce4 desktop"
@@ -21,6 +21,16 @@ DEPEND=">=x11-libs/gtk+-2.0.6
=x11-libs/libxfce4mcs-3.91.0
=x11-misc/xfce-mcs-manager-3.91.0"
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+
+ econf ${myconf} || die
+ emake || die
+}
+
src_install() {
make DESTDIR=${D} install || die