summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-02-13 02:05:42 +0000
committerJeroen Roovers <jer@gentoo.org>2013-02-13 02:05:42 +0000
commit2fb64f6f149c09dc2fd6d8667e6df41bec66ab0d (patch)
tree8b0b5d60e1ffa688b39c2f4c37ef934f41b3874e /x11-misc/xfe/xfe-1.34.ebuild
parentOld. (diff)
downloadhistorical-2fb64f6f149c09dc2fd6d8667e6df41bec66ab0d.tar.gz
historical-2fb64f6f149c09dc2fd6d8667e6df41bec66ab0d.tar.bz2
historical-2fb64f6f149c09dc2fd6d8667e6df41bec66ab0d.zip
Version bump (bug #457030 by teidakankan). Do not install useless NEWS.
Package-Manager: portage-2.2.0_alpha162/cvs/Linux x86_64 Manifest-Sign-Key: 0xA792A613
Diffstat (limited to 'x11-misc/xfe/xfe-1.34.ebuild')
-rw-r--r--x11-misc/xfe/xfe-1.34.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/x11-misc/xfe/xfe-1.34.ebuild b/x11-misc/xfe/xfe-1.34.ebuild
new file mode 100644
index 000000000000..59024350c453
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.34.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.34.ebuild,v 1.1 2013/02/13 02:05:40 jer Exp $
+
+EAPI=5
+
+PLOCALES="
+ bs ca cs da de el es_AR es fr hu it ja nl no pl pt_BR pt_PT ru sv tr zh_CN
+ zh_TW
+"
+inherit autotools base l10n
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="
+ media-libs/libpng:0
+ x11-libs/fox:1.6[truetype,png]
+ x11-libs/libX11
+ x11-libs/libXft
+ startup-notification? ( x11-libs/startup-notification )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.32.2-missing_Xlib_h.patch
+)
+
+src_prepare() {
+ base_src_prepare
+ cat >po/POTFILES.skip <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+
+ # malformed LINGUAS file
+ # recent intltool expects newline for every linguas
+ sed -i \
+ -e '/^#/!s:\s\s*:\n:g' \
+ po/LINGUAS || die
+
+ # remove not selected locales
+ rm_locale() { sed -i -e "/${1}/d" po/LINGUAS || die ;}
+ l10n_for_each_disabled_locale_do rm_locale
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-minimalflags \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ $(use_enable debug)
+}