summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-06 15:47:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-06 15:47:08 +0000
commit2f2e2cfa1a47c6805cd46ac467cec7aaf62cb59b (patch)
tree8245f7e8d2fef149a4343af64a406b2bc27da4dd /x11-misc/xkbd
parentRemove old (diff)
downloadhistorical-2f2e2cfa1a47c6805cd46ac467cec7aaf62cb59b.tar.gz
historical-2f2e2cfa1a47c6805cd46ac467cec7aaf62cb59b.tar.bz2
historical-2f2e2cfa1a47c6805cd46ac467cec7aaf62cb59b.zip
Apply patch from bug #287075 to fix keysyms by Yarda.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'x11-misc/xkbd')
-rw-r--r--x11-misc/xkbd/ChangeLog10
-rw-r--r--x11-misc/xkbd/files/xkbd-0.8.15-fix-keysyms-search.patch13
-rw-r--r--x11-misc/xkbd/xkbd-0.8.15-r1.ebuild56
3 files changed, 77 insertions, 2 deletions
diff --git a/x11-misc/xkbd/ChangeLog b/x11-misc/xkbd/ChangeLog
index 6f0aad8aafb6..10149c3cb272 100644
--- a/x11-misc/xkbd/ChangeLog
+++ b/x11-misc/xkbd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xkbd
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkbd/ChangeLog,v 1.16 2009/02/11 21:42:08 nelchael Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkbd/ChangeLog,v 1.17 2010/06/06 15:47:06 ssuominen Exp $
+
+*xkbd-0.8.15-r1 (06 Jun 2010)
+
+ 06 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xkbd-0.8.15-r1.ebuild, +files/xkbd-0.8.15-fix-keysyms-search.patch:
+ Apply patch from bug #287075 to fix keysyms by Yarda.
*xkbd-0.8.15 (11 Feb 2009)
diff --git a/x11-misc/xkbd/files/xkbd-0.8.15-fix-keysyms-search.patch b/x11-misc/xkbd/files/xkbd-0.8.15-fix-keysyms-search.patch
new file mode 100644
index 000000000000..0d4d5c29cc9c
--- /dev/null
+++ b/x11-misc/xkbd/files/xkbd-0.8.15-fix-keysyms-search.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/287075
+
+--- src/libvirtkeys.c
++++ src/libvirtkeys.c
+@@ -341,7 +341,7 @@
+
+ for (keycode = 0; ((keycode < (maxKeycode - minKeycode + 1)) && !found); keycode++)
+ {
+- for (column = 0; ((column < keysymsPerKeycode) && !found); column++)
++ for (column = 0; ((column < (keysymsPerKeycode > 4 ? 4 : keysymsPerKeycode)) && !found); column++)
+ {
+ if (keymap[(keycode * keysymsPerKeycode + column)] == ks)
+ {
diff --git a/x11-misc/xkbd/xkbd-0.8.15-r1.ebuild b/x11-misc/xkbd/xkbd-0.8.15-r1.ebuild
new file mode 100644
index 000000000000..7b7079ebd7ef
--- /dev/null
+++ b/x11-misc/xkbd/xkbd-0.8.15-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkbd/xkbd-0.8.15-r1.ebuild,v 1.1 2010/06/06 15:47:06 ssuominen Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Xkbd - onscreen soft keyboard for X11"
+HOMEPAGE="http://handhelds.org/"
+SRC_URI="ftp://ftp.yzu.edu.tw/mirror/pub2/ftp.handhelds.org/distributions/familiar/source/v0.8.4-rc1/sources/${P}-CVS.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc debug"
+
+RDEPEND="x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXtst
+ x11-libs/libXpm
+ media-libs/freetype
+ dev-libs/expat
+ sys-libs/zlib
+ doc? ( app-text/docbook-sgml-utils )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_prepare() {
+ # 2008-03-23 gi1242: Fix handling of -geometry argument
+ epatch "${FILESDIR}"/${P}-fix-geometry.patch
+ # 2008-03-23 gi1242: Increase default repeat delay
+ epatch "${FILESDIR}"/${P}-increase-delay.patch
+ epatch "${FILESDIR}"/${P}-fix-keysyms-search.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug)
+}
+
+src_compile() {
+ emake || die
+ use doc && docbook2html README
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS NEWS README
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins *.html
+ fi
+}