summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2003-11-20 23:21:17 +0000
committerIan Leitch <port001@gentoo.org>2003-11-20 23:21:17 +0000
commitfea7a3b9e4a1d742e1e78c2c11db794a7f8aab26 (patch)
treec8dae5a04e570d605a2037487caa7b0d6be17c2d /x11-misc/xplore/xplore-1.1e.ebuild
parentMoved from app-misc to x11-misc, metadata.xml created (diff)
downloadhistorical-fea7a3b9e4a1d742e1e78c2c11db794a7f8aab26.tar.gz
historical-fea7a3b9e4a1d742e1e78c2c11db794a7f8aab26.tar.bz2
historical-fea7a3b9e4a1d742e1e78c2c11db794a7f8aab26.zip
Moved from app-misc to x11-misc, metadata.xml created
Diffstat (limited to 'x11-misc/xplore/xplore-1.1e.ebuild')
-rw-r--r--x11-misc/xplore/xplore-1.1e.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/xplore/xplore-1.1e.ebuild b/x11-misc/xplore/xplore-1.1e.ebuild
new file mode 100644
index 000000000000..d918be71d23a
--- /dev/null
+++ b/x11-misc/xplore/xplore-1.1e.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplore/xplore-1.1e.ebuild,v 1.1 2003/11/20 23:21:13 port001 Exp $
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="motif file manager for X."
+SRC_URI="http://www.musikwissenschaft.uni-mainz.de/~ag/xplore/${P}.tar.bz2"
+HOMEPAGE="http://www.musikwissenschaft.uni-mainz.de/~ag/xplore/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+# its webpage states the lesstif does not fully work with xplore
+DEPEND="virtual/x11
+ >=x11-libs/openmotif-2.2"
+
+src_compile() {
+ #Fix Xplore.tmpl so installation is to /usr instead of /usr/X11R6
+ #Note: LIBDIR is used to point to X11 tree.
+ cp Xplore.tmpl Xplore.tmpl.orig
+ sed -e "s:^\(XPLORELIBDIR = \).*:\1/usr/lib/xplore:" \
+ -e "s:^XCOMM \(BINDIR = /usr\)/local\(/bin\):\1\2:" \
+ -e "s:^XCOMM \(MANPATH = /usr\)/local\(/man\):\1/share\2:" \
+ Xplore.tmpl.orig > Xplore.tmpl
+
+ xmkmf -a || die "xmkmf Makefile creation failed"
+ # parallel make fails
+ make || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Installation failed"
+ dodoc COPYING ChangeLog INSTALL README TODO
+}