summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2009-07-15 15:02:46 +0000
committerChristian Birchinger <joker@gentoo.org>2009-07-15 15:02:46 +0000
commit4f4631237471a91b88dab1cc6521fe1f72183662 (patch)
treef92a5db98c7f1c6d2901568575c35c091df8701a /x11-misc
parentarm stable wrt #276432 (diff)
downloadhistorical-4f4631237471a91b88dab1cc6521fe1f72183662.tar.gz
historical-4f4631237471a91b88dab1cc6521fe1f72183662.tar.bz2
historical-4f4631237471a91b88dab1cc6521fe1f72183662.zip
Various adjustments to the ebuild to deal with bug #274661. No revision bump because the installed working binaries stay the same.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xdotool/ChangeLog7
-rw-r--r--x11-misc/xdotool/Manifest4
-rw-r--r--x11-misc/xdotool/xdotool-20090609.ebuild33
3 files changed, 33 insertions, 11 deletions
diff --git a/x11-misc/xdotool/ChangeLog b/x11-misc/xdotool/ChangeLog
index dda2e805d85a..5f90477160da 100644
--- a/x11-misc/xdotool/ChangeLog
+++ b/x11-misc/xdotool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xdotool
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.1 2009/06/15 17:13:41 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.2 2009/07/15 15:02:46 joker Exp $
+
+ 15 Jul 2009; Christian Birchinger <joker@gentoo.org>
+ xdotool-20090609.ebuild:
+ Various adjustments to the ebuild to deal with bug #274661. No revision bump
+ because the installed working binaries stay the same
*xdotool-20090609 (15 Jun 2009)
diff --git a/x11-misc/xdotool/Manifest b/x11-misc/xdotool/Manifest
index 17519e1f29e3..f970b4c89bcd 100644
--- a/x11-misc/xdotool/Manifest
+++ b/x11-misc/xdotool/Manifest
@@ -1,4 +1,4 @@
DIST xdotool-20090609.tar.gz 19061 RMD160 89b6bacb179a4b59db20a4664f7853274de39b4e SHA1 5aa8c218e6de1cc14835cf0fce6da8f985d7c63e SHA256 6a3283178ab72c9eef9ed846627e1d39ff3a9a2a9a77de5400a8f640fa42fa04
-EBUILD xdotool-20090609.ebuild 618 RMD160 396ae89ae0ab32c19b3e028fce60835a09f1823a SHA1 173bc219fed8c58bf1d794a7cc08066bfd7f2677 SHA256 eacb53894f6a595e4ef44be9b2c9df77254790bfad4819360249a1d1764cc663
-MISC ChangeLog 412 RMD160 d2de991cfd43109aed97de87300aa3214f8cd9ce SHA1 da034a30286c6400091375b7346f383865ad522b SHA256 5a976b29e0db9b76a9ec0fb56407c40f9dacebaf024ec2b2ccb8a2d4897134b2
+EBUILD xdotool-20090609.ebuild 1137 RMD160 feda1cdd23d17295a3a7ab7d887c7dbb145e7c50 SHA1 841d671114c19723c1e59f9a582841c4504b94ba SHA256 78f697666315177fd0f1bb3cf71f6cc45af8acbe460c48b2cdf1da6ec5edf563
+MISC ChangeLog 629 RMD160 ce10559af89d5dc615c6ae65cf110df94eccbf96 SHA1 512e2ae3dbecfe5ecebcd28ec08280a63d4dd1f5 SHA256 49ea485253f340917dcc1deb5bf6506b892b6efc17ca5ce729bee253de3f0276
MISC metadata.xml 481 RMD160 64e577586b777ec3cd0968be05354b2d6edf1790 SHA1 042b6b55dba90dff77d3fa9201d4d62abbb1e251 SHA256 5bfee97d019d9c664ec75a56401eb36710303bb81d82401b01e16a6c2997fbf4
diff --git a/x11-misc/xdotool/xdotool-20090609.ebuild b/x11-misc/xdotool/xdotool-20090609.ebuild
index e29618d35f6e..2eac8d0875c4 100644
--- a/x11-misc/xdotool/xdotool-20090609.ebuild
+++ b/x11-misc/xdotool/xdotool-20090609.ebuild
@@ -1,27 +1,44 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-20090609.ebuild,v 1.1 2009/06/15 17:13:41 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-20090609.ebuild,v 1.2 2009/07/15 15:02:46 joker Exp $
-inherit eutils
+EAPI=2
-DESCRIPTION="Fake keyboard/mouse input"
+inherit toolchain-funcs
+
+DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows."
HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
SRC_URI="http://semicomplete.googlecode.com/files/${P}.tar.gz"
LICENSE="as-is"
+
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE=""
+IUSE="examples"
DEPEND="x11-libs/libXtst
x11-libs/libX11"
RDEPEND="${DEPEND}"
-src_compile() {
- emake || die "emake failed"
+src_prepare() {
+ cd "${S}"
+ sed -i -e "s:^CFLAGS=.*:CFLAGS=-std=c99 ${CFLAGS}:" \
+ -e "s:^LIBS=.*:LIBS=$(pkg-config --libs x11 xtst):" \
+ -e "s:^INC=.*:INC=$(pkg-config --cflags x11 xtst):" \
+ -e "s:\$(CC):$(tc-getCC):" \
+ -e "s:\$(LDFLAGS): \$(LIBS) \$(LDFLAGS):" \
+ -e 's:LDFLAGS+=$(LIBS)::' \
+ -e "s:\$(CFLAGS):\$(INC) \$(CFLAGS):" \
+ Makefile \
+ || die "sed Makefile failed."
}
src_install() {
- dobin xdotool
- doman xdotool.1
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc CHANGELIST README
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
}