summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-09-14 10:09:45 +0000
committerMike Gardiner <obz@gentoo.org>2003-09-14 10:09:45 +0000
commit01cca50ce1f4fe0b08bc0a7650d36bede8fa7d68 (patch)
tree9ab03ff152f5579fed29b2cbcdc9aef209b9f00f /x11-plugins/desklet-clock/desklet-clock-0.32.ebuild
parentNew version (diff)
downloadhistorical-01cca50ce1f4fe0b08bc0a7650d36bede8fa7d68.tar.gz
historical-01cca50ce1f4fe0b08bc0a7650d36bede8fa7d68.tar.bz2
historical-01cca50ce1f4fe0b08bc0a7650d36bede8fa7d68.zip
New version
Diffstat (limited to 'x11-plugins/desklet-clock/desklet-clock-0.32.ebuild')
-rw-r--r--x11-plugins/desklet-clock/desklet-clock-0.32.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/desklet-clock/desklet-clock-0.32.ebuild b/x11-plugins/desklet-clock/desklet-clock-0.32.ebuild
new file mode 100644
index 000000000000..10171f97a4a1
--- /dev/null
+++ b/x11-plugins/desklet-clock/desklet-clock-0.32.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/desklet-clock/desklet-clock-0.32.ebuild,v 1.1 2003/09/14 10:09:28 obz Exp $
+
+DESKLET_NAME="Clock"
+
+MY_PN=${PN/desklet-/}-desklet
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="The clock sensors and displays for gdesklets"
+SRC_URI="http://gdesklets.gnomedesktop.org/files/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.pycage.de/"
+LICENSE="as-is"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+DEPEND=">=gnome-extra/gdesklets-core-0.20"
+
+DOCS="INSTALL README"
+
+src_install( ) {
+
+ SYS_PATH="/usr/share/gdesklets"
+ INSTALL_BIN="Install_${DESKLET_NAME}_Sensor.bin"
+ dodir ${SYS_PATH}/{Sensors,Displays}
+
+ # first we install the Sensor
+ python ${INSTALL_BIN} --nomsg ${D}${SYS_PATH}/Sensors
+
+ # and then the .displays
+ insinto ${SYS_PATH}/Displays/${DESKLET_NAME}
+ doins *.display
+
+ # and finally the graphics
+ cp -R gfx/ ${D}${SYS_PATH}/Displays/${DESKLET_NAME}
+
+ dodoc ${DOCS}
+
+}
+