summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2007-05-24 04:34:54 +0000
committerOlivier Crête <tester@gentoo.org>2007-05-24 04:34:54 +0000
commitffe67514f8831e99918a77c8042e1d340d35fe9e (patch)
treec1921318389d6e731633094be59c3629ed7d2074 /x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild
parentAdd networkmanager local use flag, bug #179525 (diff)
downloadhistorical-ffe67514f8831e99918a77c8042e1d340d35fe9e.tar.gz
historical-ffe67514f8831e99918a77c8042e1d340d35fe9e.tar.bz2
historical-ffe67514f8831e99918a77c8042e1d340d35fe9e.zip
Add pidgin-latex, which is the continuation of x11-plugins/gaim-latex
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild')
-rw-r--r--x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild b/x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild
new file mode 100644
index 000000000000..d51f9f45ea3d
--- /dev/null
+++ b/x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild
@@ -0,0 +1,34 @@
+
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild,v 1.1 2007/05/24 04:34:54 tester Exp $
+
+inherit flag-o-matic multilib
+
+DESCRIPTION="Pidgin plugin that renders latex formulae"
+HOMEPAGE="http://sourceforge.net/projects/pidgin-latex"
+SRC_URI="mirror://sourceforge/pidgin-latex/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="net-im/pidgin"
+RDEPEND="virtual/tetex
+ media-gfx/imagemagick"
+
+S=${WORKDIR}/${PN}
+
+src_compile()
+{
+ append-flags -fPIC
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ make LIB_INSTALL_DIR="${D}/usr/$(get_libdir)/pidgin" install PREFIX=${D}/usr \
+ || die "make install failed"
+ dodoc README CHANGELOG COPYING TODO
+}