summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-01-19 14:47:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-01-19 14:47:31 +0000
commiteda9773dc9ad6befbac9c19bfe0679cbe0a46055 (patch)
treeb27443e8596e957381a4c59d8b59642a33bde2ae /x11-plugins/wmblob/wmblob-1.0.3.ebuild
parentexport CXX to call the correct one and not g++ directly, thanks again to Pave... (diff)
downloadhistorical-eda9773dc9ad6befbac9c19bfe0679cbe0a46055.tar.gz
historical-eda9773dc9ad6befbac9c19bfe0679cbe0a46055.tar.bz2
historical-eda9773dc9ad6befbac9c19bfe0679cbe0a46055.zip
Version bump.
Package-Manager: portage-2.1.4
Diffstat (limited to 'x11-plugins/wmblob/wmblob-1.0.3.ebuild')
-rw-r--r--x11-plugins/wmblob/wmblob-1.0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/wmblob/wmblob-1.0.3.ebuild b/x11-plugins/wmblob/wmblob-1.0.3.ebuild
new file mode 100644
index 000000000000..706ed7bde5bf
--- /dev/null
+++ b/x11-plugins/wmblob/wmblob-1.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmblob/wmblob-1.0.3.ebuild,v 1.1 2008/01/19 14:47:31 drac Exp $
+
+DESCRIPTION="a fancy but useless dockapp with moving blobs."
+HOMEPAGE="http://freshmeat.net/projects/wmblob"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:-O2:${CFLAGS}:g" "${S}"/configure
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README doc/how_it_works
+}