summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-08-16 09:11:58 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-08-16 09:11:58 +0000
commit33786f695fb0aaa2cd7ab4ce2fbff751d4dfa7cc (patch)
tree34c3bcb8daba313fa34277c08a932790cfd2307d /x11-plugins
parentReadd scripts to gentoo tarball (#281591). (diff)
downloadhistorical-33786f695fb0aaa2cd7ab4ce2fbff751d4dfa7cc.tar.gz
historical-33786f695fb0aaa2cd7ab4ce2fbff751d4dfa7cc.tar.bz2
historical-33786f695fb0aaa2cd7ab4ce2fbff751d4dfa7cc.zip
Migrate to EAPI 2 in order to get rid of built_with_use.
Package-Manager: portage-2.2_rc38/cvs/Linux i686
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/guifications/ChangeLog6
-rw-r--r--x11-plugins/guifications/guifications-2.16.ebuild22
-rw-r--r--x11-plugins/pidgin-latex/ChangeLog8
-rw-r--r--x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild19
-rw-r--r--x11-plugins/pidgin-libnotify/ChangeLog6
-rw-r--r--x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild25
-rw-r--r--x11-plugins/wmauda/Manifest14
7 files changed, 51 insertions, 49 deletions
diff --git a/x11-plugins/guifications/ChangeLog b/x11-plugins/guifications/ChangeLog
index 84b83413361d..de92cdcb593d 100644
--- a/x11-plugins/guifications/ChangeLog
+++ b/x11-plugins/guifications/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/guifications
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/ChangeLog,v 1.60 2009/08/16 09:06:14 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/ChangeLog,v 1.61 2009/08/16 09:09:12 betelgeuse Exp $
+
+ 16 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
+ guifications-2.16.ebuild:
+ Migrate to EAPI 2 in order to get rid of built_with_use.
16 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
-guifications-2.14.ebuild:
diff --git a/x11-plugins/guifications/guifications-2.16.ebuild b/x11-plugins/guifications/guifications-2.16.ebuild
index ec0a6f988a00..4f48b071dc54 100644
--- a/x11-plugins/guifications/guifications-2.16.ebuild
+++ b/x11-plugins/guifications/guifications-2.16.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/guifications-2.16.ebuild,v 1.8 2008/02/21 20:25:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/guifications-2.16.ebuild,v 1.9 2009/08/16 09:09:12 betelgeuse Exp $
+
+EAPI="2"
inherit eutils
@@ -17,27 +19,19 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc sparc x86"
IUSE="debug nls"
-RDEPEND="net-im/pidgin
+RDEPEND="net-im/pidgin[gtk]
>=x11-libs/gtk+-2"
DEPEND="${DEPEND}
dev-util/pkgconfig"
-pkg_setup() {
- if ! built_with_use net-im/pidgin gtk; then
- eerror "You need to compile net-im/pidgin with USE=gtk"
- die "Missing gtk USE flag on net-im/pidgin"
- fi
-}
-
-src_compile() {
+src_configure() {
econf \
$(use_enable debug ) \
$(use_enable nls) || die "econf failure"
- emake || die "emake failure"
}
src_install() {
- make install DESTDIR="${D}" || die "make install failure"
- dodoc AUTHORS ChangeLog INSTALL NEWS README TODO VERSION
+ emake install DESTDIR="${D}" || die "make install failure"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO VERSION || die
}
diff --git a/x11-plugins/pidgin-latex/ChangeLog b/x11-plugins/pidgin-latex/ChangeLog
index 6d809182d95f..b1d7f45d257e 100644
--- a/x11-plugins/pidgin-latex/ChangeLog
+++ b/x11-plugins/pidgin-latex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/pidgin-latex
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/ChangeLog,v 1.8 2008/09/02 22:26:40 opfer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/ChangeLog,v 1.9 2009/08/16 09:10:44 betelgeuse Exp $
+
+ 16 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
+ pidgin-latex-1.2.1.ebuild:
+ Migrate to EAPI 2 in order to get rid of built_with_use.
02 Sep 2008; Christian Faulhammer <opfer@gentoo.org>
pidgin-latex-1.0.ebuild, pidgin-latex-1.2.1.ebuild:
diff --git a/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild b/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild
index b8e86f8d9f82..40bd8ded4009 100644
--- a/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild
+++ b/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild,v 1.2 2008/09/02 22:26:40 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild,v 1.3 2009/08/16 09:10:44 betelgeuse Exp $
+
+EAPI="2"
inherit flag-o-matic multilib eutils
@@ -13,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="net-im/pidgin
+DEPEND="net-im/pidgin[gtk]
>=x11-libs/gtk+-2"
RDEPEND="${DEPEND}
virtual/latex-base
@@ -21,13 +23,6 @@ RDEPEND="${DEPEND}
S=${WORKDIR}/${PN}
-pkg_setup() {
- if ! built_with_use net-im/pidgin gtk; then
- eerror "You need to compile net-im/pidgin with USE=gtk"
- die "Missing gtk USE flag on net-im/pidgin"
- fi
-}
-
src_compile()
{
append-flags -fPIC
@@ -36,7 +31,7 @@ src_compile()
src_install()
{
- make LIB_INSTALL_DIR="${D}/usr/$(get_libdir)/pidgin" install PREFIX="${D}/usr" \
+ emake LIB_INSTALL_DIR="${D}/usr/$(get_libdir)/pidgin" install PREFIX="${D}/usr" \
|| die "make install failed"
- dodoc README CHANGELOG TODO
+ dodoc README CHANGELOG TODO || die
}
diff --git a/x11-plugins/pidgin-libnotify/ChangeLog b/x11-plugins/pidgin-libnotify/ChangeLog
index d3919a0e2bd9..a925c2e666a7 100644
--- a/x11-plugins/pidgin-libnotify/ChangeLog
+++ b/x11-plugins/pidgin-libnotify/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/pidgin-libnotify
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/ChangeLog,v 1.15 2009/02/01 02:01:38 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/ChangeLog,v 1.16 2009/08/16 09:11:58 betelgeuse Exp $
+
+ 16 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
+ pidgin-libnotify-0.14.ebuild:
+ Migrate to EAPI 2 in order to get rid of built_with_use.
*pidgin-libnotify-0.14 (01 Feb 2009)
diff --git a/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild
index 352f68a8aebe..212d35c7cc80 100644
--- a/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild
+++ b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild,v 1.1 2009/02/01 02:01:38 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild,v 1.2 2009/08/16 09:11:58 betelgeuse Exp $
+
+EAPI="2"
inherit eutils
@@ -14,37 +16,26 @@ KEYWORDS="~amd64 ~hppa ~ppc ~x86"
IUSE="nls debug"
RDEPEND=">=x11-libs/libnotify-0.3.2
- net-im/pidgin
+ net-im/pidgin[gtk]
>=x11-libs/gtk+-2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-pkg_setup() {
- if ! built_with_use net-im/pidgin gtk; then
- eerror "You need to compile net-im/pidgin with USE=gtk"
- die "Missing gtk USE flag on net-im/pidgin"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/pidgin-libnotify-showbutton.patch
}
-src_compile() {
+src_configure() {
local myconf
myconf="$(use_enable debug) \
$(use_enable nls)"
econf ${myconf} || die "configure failed"
-
- emake || die "make failed"
}
src_install() {
- make install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog INSTALL NEWS README TODO VERSION
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO VERSION || die
}
diff --git a/x11-plugins/wmauda/Manifest b/x11-plugins/wmauda/Manifest
index 86045979b1a5..b61a8e714707 100644
--- a/x11-plugins/wmauda/Manifest
+++ b/x11-plugins/wmauda/Manifest
@@ -1,4 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
DIST wmauda-0.7.tar.gz 18328 RMD160 d326bc901d6f854c97bd0492713672f991888ae3 SHA1 3ef084dea0afae96002cbf8b8aa77b4458d99a14 SHA256 947855691ad144ef9776b687be6fc7f84bb9dedc85a5c005150e2f4dcfdbe5a1
-EBUILD wmauda-0.7.ebuild 927 RMD160 31db3d81f0bd564a61ee8a5acda6abb4e27bb8b2 SHA1 62ca6a27d767ff618d62afbc2f27333eeddcf918 SHA256 d97ee5cc4dccbeef1681cb342233e0e81e65a61692eb7d8873dddac32f12e5e1
-MISC ChangeLog 2044 RMD160 6098dee474813046e004c461bdcd7d71ef4f65a3 SHA1 b2ee79a7b9956bd6cfd5ae8b1f30143165eff63e SHA256 42acca0b7030f6772d16bf1a5a2df68ec1d52de36f3049c274d3d47a21ba54aa
+EBUILD wmauda-0.7.ebuild 801 RMD160 2cc7196ee399cd06afa0327683f490f9392cc36a SHA1 1fcd48c2a4532deca2d9ce2e7123aa14eb99f14a SHA256 7cc8b03a7028484fac1d257ac2042683f91fd324256ce9e4dce6cdbddd33b487
+MISC ChangeLog 2202 RMD160 03f9ee0397e0c30df87160d725e65a196ae36475 SHA1 5df50054c9a3a0c79c86ea64b644f1a9d776dfb3 SHA256 94d34a37f9458cbf85a024eb837d313e6bdede55791fc00743093926236b99ec
MISC metadata.xml 167 RMD160 407c7d2b252afa7f63c4743fedf94da43b716623 SHA1 f42c260c0a7ce58db5124a80e8f65e9d570294b2 SHA256 0b161d83e9e7cad5a69cc5c2a23a5ba0fcac0d20751516b605dc232d9a2e7284
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAkqHzioACgkQcxLzpIGCsLQZwgCePEuN44iKvyz+msY6shGvk81O
+lFgAnRBAP2G0kYT3MOdY7nrlgIDdm2iV
+=cewB
+-----END PGP SIGNATURE-----