summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-07-02 13:55:16 +0000
committerBen de Groot <yngwin@gentoo.org>2009-07-02 13:55:16 +0000
commit01b8ff7387ceaf7f79ea0620d6108fed15b8c4b0 (patch)
tree01e99330fc02059d4a114e09693e41e9c7f25cc6 /x11-themes/qtcurve-qt4/qtcurve-qt4-0.65.2.ebuild
parentstable x86, bug 259172 (diff)
downloadhistorical-01b8ff7387ceaf7f79ea0620d6108fed15b8c4b0.tar.gz
historical-01b8ff7387ceaf7f79ea0620d6108fed15b8c4b0.tar.bz2
historical-01b8ff7387ceaf7f79ea0620d6108fed15b8c4b0.zip
Version bump
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'x11-themes/qtcurve-qt4/qtcurve-qt4-0.65.2.ebuild')
-rw-r--r--x11-themes/qtcurve-qt4/qtcurve-qt4-0.65.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-themes/qtcurve-qt4/qtcurve-qt4-0.65.2.ebuild b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.65.2.ebuild
new file mode 100644
index 000000000000..5e72b96130bd
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.65.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-0.65.2.ebuild,v 1.1 2009/07/02 13:49:47 yngwin Exp $
+
+EAPI="2"
+KDE_REQUIRED="optional"
+inherit flag-o-matic cmake-utils kde4-base
+
+MY_P="${P/qtcurve-qt4/QtCurve-KDE4}"
+DESCRIPTION="A set of widget styles for Qt4 based apps, also available for KDE3 and GTK2"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ kde? ( >=kde-base/kwin-4.1.0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="ChangeLog README TODO"
+
+src_configure() {
+ if use kde ; then
+ kde4-base_src_configure
+ else
+ mycmakeargs="-DQTC_QT_ONLY=true"
+ cmake-utils_src_configure
+ fi
+}