summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-03-26 23:03:42 +0000
committerAlex Alexander <wired@gentoo.org>2011-03-26 23:03:42 +0000
commitc300ce535ef34c18bdc866e4aa214658dbb87f34 (patch)
tree83eed421ee6fa773601edc44444339eeb822a486 /x11-themes/qtcurve-qt4
parentUse PyPI mirrors. (diff)
downloadhistorical-c300ce535ef34c18bdc866e4aa214658dbb87f34.tar.gz
historical-c300ce535ef34c18bdc866e4aa214658dbb87f34.tar.bz2
historical-c300ce535ef34c18bdc866e4aa214658dbb87f34.zip
version bump
Package-Manager: portage-2.2.0_alpha28/cvs/Linux x86_64
Diffstat (limited to 'x11-themes/qtcurve-qt4')
-rw-r--r--x11-themes/qtcurve-qt4/ChangeLog7
-rw-r--r--x11-themes/qtcurve-qt4/qtcurve-qt4-1.8.6.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/x11-themes/qtcurve-qt4/ChangeLog b/x11-themes/qtcurve-qt4/ChangeLog
index 29e247571025..950a20b40c04 100644
--- a/x11-themes/qtcurve-qt4/ChangeLog
+++ b/x11-themes/qtcurve-qt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/qtcurve-qt4
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.125 2011/03/06 06:49:56 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.126 2011/03/26 23:02:55 wired Exp $
+
+*qtcurve-qt4-1.8.6 (26 Mar 2011)
+
+ 26 Mar 2011; Alex Alexander <wired@gentoo.org> +qtcurve-qt4-1.8.6.ebuild:
+ version bump
05 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org>
qtcurve-qt4-1.6.4-r1.ebuild:
diff --git a/x11-themes/qtcurve-qt4/qtcurve-qt4-1.8.6.ebuild b/x11-themes/qtcurve-qt4/qtcurve-qt4-1.8.6.ebuild
new file mode 100644
index 000000000000..07f643297327
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/qtcurve-qt4-1.8.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-1.8.6.ebuild,v 1.1 2011/03/26 23:02:55 wired Exp $
+
+EAPI=4
+KDE_REQUIRED="optional"
+inherit cmake-utils kde4-base
+
+MY_P="${P/qtcurve-qt4/QtCurve-KDE4}"
+DESCRIPTION="A set of widget styles for Qt4 based apps, also available for GTK2"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde windeco"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-svg:4
+ kde? (
+ $(add_kdebase_dep systemsettings)
+ windeco? ( $(add_kdebase_dep kwin) )
+ )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+PATCHES=( "${FILESDIR}/${PN}_kwin_automagic_fix.patch" )
+
+REQUIRED_USE="windeco? ( kde )"
+
+pkg_setup() {
+ use kde && kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs
+ if use kde; then
+ mycmakeargs=(
+ $(cmake-utils_use windeco QTC_KWIN)
+ )
+ kde4-base_src_configure
+ else
+ mycmakeargs=(
+ "-DQTC_QT_ONLY=true"
+ )
+ cmake-utils_src_configure
+ fi
+}