summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-11 10:33:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-11 10:33:57 +0000
commit21ac2f6d265f9b8b4efc45e9ee5d2e3cf1af5687 (patch)
tree10dd94f4d2e00a82bfb59cf5accfc990c7f28f74 /x11-themes
parentUse virtual/jpeg wrt #327487. cleanup (diff)
downloadhistorical-21ac2f6d265f9b8b4efc45e9ee5d2e3cf1af5687.tar.gz
historical-21ac2f6d265f9b8b4efc45e9ee5d2e3cf1af5687.tar.bz2
historical-21ac2f6d265f9b8b4efc45e9ee5d2e3cf1af5687.zip
Initial commit.
Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/yasis-icon-theme/ChangeLog10
-rw-r--r--x11-themes/yasis-icon-theme/Manifest4
-rw-r--r--x11-themes/yasis-icon-theme/metadata.xml9
-rw-r--r--x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2.ebuild33
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-themes/yasis-icon-theme/ChangeLog b/x11-themes/yasis-icon-theme/ChangeLog
new file mode 100644
index 000000000000..6be8d8a243dd
--- /dev/null
+++ b/x11-themes/yasis-icon-theme/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-themes/yasis-icon-theme
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/yasis-icon-theme/ChangeLog,v 1.1 2010/11/11 10:33:57 ssuominen Exp $
+
+*yasis-icon-theme-0.4.2 (11 Nov 2010)
+
+ 11 Nov 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +yasis-icon-theme-0.4.2.ebuild:
+ Initial commit.
+
diff --git a/x11-themes/yasis-icon-theme/Manifest b/x11-themes/yasis-icon-theme/Manifest
new file mode 100644
index 000000000000..eb8f574a1a28
--- /dev/null
+++ b/x11-themes/yasis-icon-theme/Manifest
@@ -0,0 +1,4 @@
+DIST yasis-0.4.2.tar.bz2 1008347 RMD160 e674a634d35be8c6abe7053d98274c8d4f8c03fd SHA1 16e0e8552a115122be1fdf6d0ee9d715decf786c SHA256 a798334e1336c98151441aa2169bd8bca5c0a53c9bebf7f319188e8979cc2f40
+EBUILD yasis-icon-theme-0.4.2.ebuild 903 RMD160 70cadd865ec6f6974a00fac1e21b82b634cb4633 SHA1 1f38d4d32dbe1a5c099003960bfe923dcdf41ed3 SHA256 4a92bb44518e14f464b2a18c7ee0831d5d429b92b0d5f3405f61758426fc2ce1
+MISC ChangeLog 376 RMD160 da1c42953c248dbb0dff64544984c4dbf886791d SHA1 c755a22a9ef186a2fc519037e834d55faf9838d4 SHA256 b7041a7be89f491224191c2d6bf83c924da8c20b1eeee8cff2f2efd2975d7b54
+MISC metadata.xml 271 RMD160 f5550f51d7c9f7bb15177eeb66d3de3f6511f45a SHA1 13cd5d11fbd7f0dfd5967b8757efd71d4d273e23 SHA256 b0ab8f8a76df2649ab818da3d391589e88d0befc9607eb6c3be7f1746b2d4392
diff --git a/x11-themes/yasis-icon-theme/metadata.xml b/x11-themes/yasis-icon-theme/metadata.xml
new file mode 100644
index 000000000000..f1d365960b36
--- /dev/null
+++ b/x11-themes/yasis-icon-theme/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2.ebuild b/x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2.ebuild
new file mode 100644
index 000000000000..c7976ea36737
--- /dev/null
+++ b/x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2.ebuild,v 1.1 2010/11/11 10:33:57 ssuominen Exp $
+
+inherit gnome2-utils
+
+DESCRIPTION="A scalable icon theme called Yasis"
+HOMEPAGE="http://www.silvestre.com.ar/"
+SRC_URI="http://www.silvestre.com.ar/icons/yasis-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="!minimal? ( || ( x11-themes/gnome-icon-theme x11-themes/nuovo-icon-theme ) )"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+S=${WORKDIR}
+
+src_install() {
+ dodoc yasis/{AUTHORS,README}
+ rm -f yasis/{AUTHORS,COPYING,DONATE,INSTALL,README}
+
+ insinto /usr/share/icons
+ doins -r yasis || die
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }