summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-05-03 20:53:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-05-03 20:53:45 +0000
commitf2d86fa611013127f0380fc3624eb9b6869ec906 (patch)
treebb437fa8d82ab0fc5d731d184c64c08cda429b7c /x11-wm/aewm++/aewm++-1.1.5.ebuild
parentVersion bump (diff)
downloadhistorical-f2d86fa611013127f0380fc3624eb9b6869ec906.tar.gz
historical-f2d86fa611013127f0380fc3624eb9b6869ec906.tar.bz2
historical-f2d86fa611013127f0380fc3624eb9b6869ec906.zip
Version bump with GCC 4.3 patch wrt #220156, thanks to Peter Alfredsen.
Package-Manager: portage-2.1.5_rc6
Diffstat (limited to 'x11-wm/aewm++/aewm++-1.1.5.ebuild')
-rw-r--r--x11-wm/aewm++/aewm++-1.1.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-wm/aewm++/aewm++-1.1.5.ebuild b/x11-wm/aewm++/aewm++-1.1.5.ebuild
new file mode 100644
index 000000000000..2dbc1b1bb182
--- /dev/null
+++ b/x11-wm/aewm++/aewm++-1.1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++/aewm++-1.1.5.ebuild,v 1.1 2008/05/03 20:53:44 drac Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A window manager with more modern features than aewm but with the same look and feel."
+HOMEPAGE="http://frankhale.org"
+SRC_URI="http://frankhale.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ sed -i -e "s:install -s:install:" Makefile \
+ || die "sed failed."
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" LDPATH="" \
+ ADDITIONAL_CFLAGS="" INCLUDES="" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog README
+}