summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-13 03:59:08 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-13 03:59:08 +0000
commit2b3910fb45fcbef63e38930b26ac40d52c9fd6c7 (patch)
treea5794998996ed7b8362363bac7b96fa406998366 /x11-wm
parentmasked mc builds (diff)
downloadhistorical-2b3910fb45fcbef63e38930b26ac40d52c9fd6c7.tar.gz
historical-2b3910fb45fcbef63e38930b26ac40d52c9fd6c7.tar.bz2
historical-2b3910fb45fcbef63e38930b26ac40d52c9fd6c7.zip
tweak fix
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/sawfish/ChangeLog10
-rw-r--r--x11-wm/sawfish/sawfish-1.2.ebuild21
2 files changed, 17 insertions, 14 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 89f85f086962..73cc855f79e9 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for x11-wm/sawfish
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.20 2002/12/09 04:42:03 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.21 2002/12/13 03:59:08 azarah Exp $
-\* Autoupdate keywords (12-6-02)
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
+ 13 Dec 2002; Martin Sclemmer <azarah@gentoo.org> sawfish-1.2.ebuild :
+ Tweak the fix for compile problems with both freetype-1.3.1 and xft-2.0
+ installed.
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org>:
+ Changed sparc ~sparc keywords
*sawfish-1.2 (17 Nov 2002)
diff --git a/x11-wm/sawfish/sawfish-1.2.ebuild b/x11-wm/sawfish/sawfish-1.2.ebuild
index ed5d17c52f68..aefb2b5eb5be 100644
--- a/x11-wm/sawfish/sawfish-1.2.ebuild
+++ b/x11-wm/sawfish/sawfish-1.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.2.ebuild,v 1.6 2002/12/04 14:16:27 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.2.ebuild,v 1.7 2002/12/13 03:59:08 azarah Exp $
-inherit base
+inherit base eutils
IUSE="readline esd nls"
@@ -28,15 +28,8 @@ DEPEND=">=dev-util/pkgconfig-0.12.0
src_unpack() {
base_src_unpack
- cd ${S}
- einfo "Applying fullscreen patch"
- patch -p0 < ${FILESDIR}/sawfish-1.2-fullscreen.patch
- # Fix Xft2.0 support not working with XFree86 compiled against system
- # freetype2 ...
- # <azarah@gentoo.org> (21 Nov 2002)
- [ -d /usr/include/freetype2/freetype ] \
- && ln -s /usr/include/freetype2/freetype ${S}/src/freetype
+ cd ${S}; epatch ${FILESDIR}/sawfish-1.2-fullscreen.patch
}
src_compile() {
@@ -49,7 +42,13 @@ src_compile() {
use readline || myconf="${myconf} --without-readline"
use nls || myconf="${myconf} --disable-linguas"
-
+
+ # Make sure we include freetype2 headers before freetype1 headers, else Xft2
+ # borks,
+ # <azarah@gentoo.org> (13 Dec 2002)
+ export C_INCLUDE_PATH="${C_INCLUDE_PATH}:/usr/include/freetype2"
+ export CPLUS_INCLUDE_PATH="${CPLUS_INCLUDE_PATH}:/usr/include/freetype2"
+
# The themer is currently broken (must have rep-gtk-0.15
# installed to get it compiled) - Azarah, 24 Jun 2002
./configure --host=${CHOST} \