summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-06-09 08:09:57 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-06-09 08:09:57 +0000
commit7c78d2afb38dfd78bbe3154d5fd5778fd4538d85 (patch)
tree2cd0458005f7113ca39321d686874e7a7a3ce483 /x11-wm
parentInitial import. Closes #21485. (diff)
downloadhistorical-7c78d2afb38dfd78bbe3154d5fd5778fd4538d85.tar.gz
historical-7c78d2afb38dfd78bbe3154d5fd5778fd4538d85.tar.bz2
historical-7c78d2afb38dfd78bbe3154d5fd5778fd4538d85.zip
Initial import. Closes #21485.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fluxspace/Manifest3
-rw-r--r--x11-wm/fluxspace/files/digest-fluxspace-0.0.31
-rw-r--r--x11-wm/fluxspace/fluxspace-0.0.3.ebuild53
3 files changed, 56 insertions, 1 deletions
diff --git a/x11-wm/fluxspace/Manifest b/x11-wm/fluxspace/Manifest
index 1fefb5467aba..6a8201cae948 100644
--- a/x11-wm/fluxspace/Manifest
+++ b/x11-wm/fluxspace/Manifest
@@ -1,2 +1,3 @@
-MD5 cfbe0d9b203e9795e0911c9abe16c9cd fluxspace-0.0.3.ebuild 1610
+MD5 973a2761fd7f7c208d9b9b9c0f15fda3 fluxspace-0.0.3.ebuild 1597
+MD5 2ccdf56f48ab1f12bb8372ffe5ff649b ChangeLog 406
MD5 037a99f96ab6ccd97aee2b65eb4cf46d files/digest-fluxspace-0.0.3 68
diff --git a/x11-wm/fluxspace/files/digest-fluxspace-0.0.3 b/x11-wm/fluxspace/files/digest-fluxspace-0.0.3
new file mode 100644
index 000000000000..ef8908c3d0c7
--- /dev/null
+++ b/x11-wm/fluxspace/files/digest-fluxspace-0.0.3
@@ -0,0 +1 @@
+MD5 0791efe124e98689be26c2ec290bbb59 fluxspace-0.0.3.tar.gz 2228714
diff --git a/x11-wm/fluxspace/fluxspace-0.0.3.ebuild b/x11-wm/fluxspace/fluxspace-0.0.3.ebuild
new file mode 100644
index 000000000000..f28534d59bfc
--- /dev/null
+++ b/x11-wm/fluxspace/fluxspace-0.0.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header $
+
+IUSE=""
+S=${WORKDIR}/${P}
+DESCRIPTION="Enhancements for workspace management within Fluxbox."
+SRC_URI="http://www.isomedia.com/homes/stevencooper/files/${P}.tar.gz"
+HOMEPAGE="http://www.isomedia.com/homes/stevencooper/"
+DEPEND="x11-wm/fluxbox
+ x11-misc/idesk
+ app-misc/rox
+ media-libs/imlib2
+ dev-lang/python
+ dev-python/PyXML
+ dev-lang/swig"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
+myconf="--prefix=/usr"
+
+src_compile() {
+ export LDFLAGS="-lstdc++"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+ dosym /usr/lib/python2.2/site-packages/fluxspace.py /usr/lib/python2.2/site-packages/fluxspace/__init__.py
+ dosym /usr/lib/libfluxspace.so /usr/lib/python2.2/site-packages/_fluxspace.so
+ dodoc README COPYING AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ # there is a typo in the xml file, so i'll fix it =)
+
+ sed -e "s/no\"\\\/no\"\//g" /usr/share/fluxspace/examples/fluxspace.xml > /tmp/fluxspace.xml
+ cp -f /tmp/fluxspace.xml /usr/share/fluxspace/examples/fluxspace.xml
+ rm -f /tmp/fluxspace.xml
+
+ einfo " "
+ einfo " Copy /usr/share/fluxspace/examples/fluxspace.xml to your"
+ einfo " ~/.fluxbox and edit it!"
+ einfo " (just to make it work change all the \"no\" to \"yes\")"
+ einfo " "
+ einfo " In your ~/.fluxbox/init change:"
+ einfo " session.screen0.rootCommand:"
+ einfo " to:"
+ einfo " session.screen0.rootCommand: fluxspace"
+ einfo " "
+}