summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-11-13 00:25:40 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-11-13 00:25:40 +0000
commit6ead713e4997794e46ade97b601000a944348c2a (patch)
treed9e9cfb5d369cd2b04e91b90076c87062f2841be /xfce-base/xfce-utils
parentbugfix release of xfce4. (diff)
downloadhistorical-6ead713e4997794e46ade97b601000a944348c2a.tar.gz
historical-6ead713e4997794e46ade97b601000a944348c2a.tar.bz2
historical-6ead713e4997794e46ade97b601000a944348c2a.zip
bugfix release of xfce4.
Diffstat (limited to 'xfce-base/xfce-utils')
-rw-r--r--xfce-base/xfce-utils/Manifest4
-rw-r--r--xfce-base/xfce-utils/files/digest-xfce-utils-4.0.11
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.0.1.ebuild39
3 files changed, 42 insertions, 2 deletions
diff --git a/xfce-base/xfce-utils/Manifest b/xfce-base/xfce-utils/Manifest
index 3a621a0a313b..71cab1e9f575 100644
--- a/xfce-base/xfce-utils/Manifest
+++ b/xfce-base/xfce-utils/Manifest
@@ -1,6 +1,6 @@
MD5 35114121df7f9d7fe1864b7cec91c76a xfce-utils-4.0.0.ebuild 1003
-MD5 3bef0b7c49203ca741caa7810100a125 xfce-utils-4.0.1.ebuild 1006
-MD5 745cd70541ef5cb261b7af9672924695 ChangeLog 1010
+MD5 28190db7e7ce5ac3c6d9ae04b6536f17 xfce-utils-4.0.1.ebuild 1006
+MD5 94944f47457f1958c79e3934692e6ff0 ChangeLog 1142
MD5 c390804e060ffd11a5bbb143434b2b2d metadata.xml 157
MD5 0d0da435564c4c1341f113a04290657f files/digest-xfce-utils-4.0.0 68
MD5 0ee425e44814de8f6f39d1cd2ffe54c4 files/digest-xfce-utils-4.0.1 68
diff --git a/xfce-base/xfce-utils/files/digest-xfce-utils-4.0.1 b/xfce-base/xfce-utils/files/digest-xfce-utils-4.0.1
new file mode 100644
index 000000000000..f96665159dbe
--- /dev/null
+++ b/xfce-base/xfce-utils/files/digest-xfce-utils-4.0.1
@@ -0,0 +1 @@
+MD5 d6d9df76cc10b99096df1754405ad46b xfce-utils-4.0.1.tar.gz 933683
diff --git a/xfce-base/xfce-utils/xfce-utils-4.0.1.ebuild b/xfce-base/xfce-utils/xfce-utils-4.0.1.ebuild
new file mode 100644
index 000000000000..51cd4f0e41ae
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.0.1.ebuild,v 1.1 2003/11/13 00:24:32 bcowan Exp $
+
+IUSE="X gtkhtml gnome"
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Xfce4 utilities"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce-${PV}/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ia64 ~x86 ~ppc ~alpha ~sparc ~amd64"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ dev-util/pkgconfig
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}
+ =xfce-base/libxfcegui4-${PV}
+ =xfce-base/libxfce4mcs-${PV}
+ =xfce-base/xfce-mcs-manager-${PV}"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+ use gtkhtml && myconf="${myconf} --enable-gtkhtml"
+ use gnome && myconf="${myconf} --enable-gdm"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS INSTALL NEWS COPYING README ChangeLog TODO
+}