summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-22 16:58:00 +0000
committerChristoph Mende <angelos@gentoo.org>2010-05-22 16:58:00 +0000
commit64eac4b9135d15dd30ebc2150c69141bc10ef889 (patch)
treeeedf4d83c9d3c0ad1f34c2549974a6f46ec15dfc /xfce-base/xfce4-panel/xfce4-panel-4.6.4.ebuild
parentAdd ~sh (diff)
downloadhistorical-64eac4b9135d15dd30ebc2150c69141bc10ef889.tar.gz
historical-64eac4b9135d15dd30ebc2150c69141bc10ef889.tar.bz2
historical-64eac4b9135d15dd30ebc2150c69141bc10ef889.zip
Version bump
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'xfce-base/xfce4-panel/xfce4-panel-4.6.4.ebuild')
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.6.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.6.4.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.6.4.ebuild
new file mode 100644
index 000000000000..1c03f6161931
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.6.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.6.4.ebuild,v 1.1 2010/05/22 16:58:00 angelos Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Panel for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-panel/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.6/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug startup-notification"
+
+RDEPEND=">=dev-libs/glib-2.20:2
+ x11-libs/cairo
+ x11-libs/libX11
+ x11-libs/libSM
+ >=x11-libs/gtk+-2.12:2
+ >=x11-libs/libwnck-2.12
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/exo-0.3.100
+ startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable startup-notification)
+ $(use_enable debug)"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+}