summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-05-19 16:48:30 +0000
committerJason Zaman <perfinion@gentoo.org>2015-05-19 16:48:30 +0000
commit17361bb737ce01e46a82730a57386b24831d9b2d (patch)
tree2b4f8769117f383bd570d332ffb22c234afb635f /xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild
parentOld. (diff)
downloadhistorical-17361bb737ce01e46a82730a57386b24831d9b2d.tar.gz
historical-17361bb737ce01e46a82730a57386b24831d9b2d.tar.bz2
historical-17361bb737ce01e46a82730a57386b24831d9b2d.zip
fix fileroller and engrampa. PR https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/104 thanks to brakarov
Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0x7EF137EC935B0EAF
Diffstat (limited to 'xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild')
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..16685f6d1619
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild,v 1.1 2015/05/19 16:48:22 perfinion Exp $
+
+EAPI=5
+
+EAUTORECONF="yes"
+inherit xfconf
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/thunar-1.2:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/0.3.1-add-engrampa-support.patch "${FILESDIR}"/0.3.1-fix-file-roller.patch )
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}