summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/manedit/ChangeLog10
-rw-r--r--app-text/manedit/files/digest-manedit-0.5.61
-rw-r--r--app-text/manedit/manedit-0.5.6.ebuild39
3 files changed, 50 insertions, 0 deletions
diff --git a/app-text/manedit/ChangeLog b/app-text/manedit/ChangeLog
new file mode 100644
index 000000000000..7120450223d2
--- /dev/null
+++ b/app-text/manedit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/manedit
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-text/manedit/ChangeLog,v 1.1 2002/05/02 23:38:06 agenkin Exp $
+
+*manedit-0.5.6 (2 May, 2002)
+
+ 2 May 2002; Arcady Genkin <agenkin@thpoon.com> manedit-0.5.6.ebuild :
+
+ Initial version of the ebuild, submitted by Nicholas Jones
+ <carpaski@twobit.net>. \ No newline at end of file
diff --git a/app-text/manedit/files/digest-manedit-0.5.6 b/app-text/manedit/files/digest-manedit-0.5.6
new file mode 100644
index 000000000000..e6644da95a2b
--- /dev/null
+++ b/app-text/manedit/files/digest-manedit-0.5.6
@@ -0,0 +1 @@
+MD5 8039d8167c0338f8b8666ae9a516e0a0 manedit-0.5.6.tar.bz2 425714
diff --git a/app-text/manedit/manedit-0.5.6.ebuild b/app-text/manedit/manedit-0.5.6.ebuild
new file mode 100644
index 000000000000..6e75e34cd39f
--- /dev/null
+++ b/app-text/manedit/manedit-0.5.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Nicholas Jones <carpaski@twobit.net>
+# $Header: /var/cvsroot/gentoo-x86/app-text/manedit/manedit-0.5.6.ebuild,v 1.1 2002/05/02 23:38:06 agenkin Exp $
+
+DESCRIPTION="Man page editor using XML tags"
+HOMEPAGE="http://wolfpack.twu.net/ManEdit"
+
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+
+
+DEPEND="virtual/glibc
+ virtual/x11
+ x11-libs/gtk+
+ sys-libs/zlib
+ sys-apps/bzip2"
+
+
+src_compile() {
+
+ # It autodetects x86 processors and adds the -march option itself
+ # but we don't actually want that.
+ env CFLAGS="${CFLAGS}" ./configure Linux \
+ --prefix=/usr \
+ --enable=bzip2 \
+ --enable=zlib \
+ --disable="arch-i486" \
+ --disable="arch-i586" \
+ --disable="arch-i686" \
+ --disable="arch-pentiumpro" || die "Bad Configure"
+
+ emake || die "Compile Error"
+}
+
+src_install() {
+ make PREFIX=${D} install || die "make install failed."
+ dodoc AUTHORS LICENSE README
+}