summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/fastercsv/ChangeLog9
-rw-r--r--dev-ruby/fastercsv/fastercsv-1.5.4.ebuild32
-rw-r--r--dev-ruby/mini_magick/ChangeLog7
-rw-r--r--dev-ruby/mini_magick/mini_magick-3.2.ebuild43
4 files changed, 88 insertions, 3 deletions
diff --git a/dev-ruby/fastercsv/ChangeLog b/dev-ruby/fastercsv/ChangeLog
index 59b77cb82a61..92d197b23554 100644
--- a/dev-ruby/fastercsv/ChangeLog
+++ b/dev-ruby/fastercsv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fastercsv
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fastercsv/ChangeLog,v 1.12 2010/11/03 21:44:58 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fastercsv/ChangeLog,v 1.13 2011/01/14 07:37:52 graaff Exp $
+
+*fastercsv-1.5.4 (14 Jan 2011)
+
+ 14 Jan 2011; Hans de Graaff <graaff@gentoo.org> +fastercsv-1.5.4.ebuild:
+ Version bump.
03 Nov 2010; Markus Meier <maekke@gentoo.org> fastercsv-1.5.3.ebuild:
x86 stable, bug #342233
diff --git a/dev-ruby/fastercsv/fastercsv-1.5.4.ebuild b/dev-ruby/fastercsv/fastercsv-1.5.4.ebuild
new file mode 100644
index 000000000000..f98477176e64
--- /dev/null
+++ b/dev-ruby/fastercsv/fastercsv-1.5.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fastercsv/fastercsv-1.5.4.ebuild,v 1.1 2011/01/14 07:37:52 graaff Exp $
+
+EAPI=2
+
+# ruby19 → not needed, it's bundled as part of the main package
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc/html"
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGELOG README TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="FasterCSV is a replacement for the standard CSV library"
+HOMEPAGE="http://fastercsv.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}
diff --git a/dev-ruby/mini_magick/ChangeLog b/dev-ruby/mini_magick/ChangeLog
index ea9e2f88966e..a5e17a581ae0 100644
--- a/dev-ruby/mini_magick/ChangeLog
+++ b/dev-ruby/mini_magick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mini_magick
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/ChangeLog,v 1.7 2011/01/02 13:04:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/ChangeLog,v 1.8 2011/01/14 07:41:19 graaff Exp $
+
+*mini_magick-3.2 (14 Jan 2011)
+
+ 14 Jan 2011; Hans de Graaff <graaff@gentoo.org> +mini_magick-3.2.ebuild:
+ Version bump.
*mini_magick-3.1 (02 Jan 2011)
diff --git a/dev-ruby/mini_magick/mini_magick-3.2.ebuild b/dev-ruby/mini_magick/mini_magick-3.2.ebuild
new file mode 100644
index 000000000000..3e6f575f9450
--- /dev/null
+++ b/dev-ruby/mini_magick/mini_magick-3.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/mini_magick-3.2.ebuild,v 1.1 2011/01/14 07:41:19 graaff Exp $
+
+EAPI=2
+
+# jruby → test_tempfile_at_path_after_format fails with jruby 1.3.1,
+# sounds like a bug in JRuby itself, or the code not being compatible.
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Manipulate images with minimal use of memory."
+HOMEPAGE="http://github.com/probablycorey/mini_magick"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It's only used at runtime in this case because this extension only
+# _calls_ the commands. But when we run tests we're going to need tiff
+# and jpeg support at a minimum.
+RDEPEND="media-gfx/imagemagick"
+DEPEND="test? ( media-gfx/imagemagick[tiff,jpeg] )"
+
+# tests are known to fail under imagemagick 6.5 at least, reported upstream:
+# http://github.com/probablycorey/mini_magick/issues/#issue/2
+# update: still fails with imagemagick 6.6.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+ruby_add_rdepend ">=dev-ruby/subexec-0.0.4"
+
+all_ruby_prepare() {
+ # remove executable bit from all files
+ find "${S}" -type f -exec chmod -x {} +
+
+ # Remove spec definition part because the gemspec file is not included
+ sed -i -e '/gemspec/,$ d' Rakefile || die
+}