summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/sed/sed-3.02.80-r3.ebuild53
-rw-r--r--sys-devel/binutils/binutils-2.11.90.0.7-r1.ebuild84
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.11.90.0.7-r12
3 files changed, 108 insertions, 31 deletions
diff --git a/sys-apps/sed/sed-3.02.80-r3.ebuild b/sys-apps/sed/sed-3.02.80-r3.ebuild
index c35d128af82a..92691360217f 100644
--- a/sys-apps/sed/sed-3.02.80-r3.ebuild
+++ b/sys-apps/sed/sed-3.02.80-r3.ebuild
@@ -1,50 +1,41 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-3.02.80-r3.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-3.02.80-r3.ebuild,v 1.2 2001/12/21 02:53:18 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Super-useful stream editor"
-SRC_URI="ftp://alpha.gnu.org/pub/gnu/sed/${A}"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/sed/${P}.tar.gz"
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- try ./configure --prefix=/usr --host=${CHOST} ${myconf}
- if [ -z "`use static`" ]
- then
- try make ${MAKEOPTS}
- else
- try make ${MAKEOPTS} LDFLAGS=-static
- fi
+ local myconf
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+ ./configure --prefix=/usr --host=${CHOST} ${myconf} || die
+ if [ -z "`use static`" ]
+ then
+ emake || die
+ else
+ emake LDFLAGS=-static || die
+ fi
}
src_install() {
-
- into /
+ into /
dobin sed/sed
dodir /usr/bin
dosym ../../bin/sed /usr/bin/sed
-
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
- then
- into /usr
- doinfo doc/sed.info
- doman doc/sed.1
- dodoc COPYING NEWS README* THANKS TODO AUTHORS BUGS ANNOUNCE
+ if [ -z "`use build`" ]
+ then
+ into /usr
+ doinfo doc/sed.info
+ doman doc/sed.1
+ dodoc COPYING NEWS README* THANKS TODO AUTHORS BUGS ANNOUNCE
else
rm -rf ${D}/usr/share
- fi
-
+ fi
}
diff --git a/sys-devel/binutils/binutils-2.11.90.0.7-r1.ebuild b/sys-devel/binutils/binutils-2.11.90.0.7-r1.ebuild
new file mode 100644
index 000000000000..1662b53d4414
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.11.90.0.7-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.90.0.7-r1.ebuild,v 1.1 2001/12/21 02:53:18 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.gz http://www.ibiblio.org/${PN}-manpages-${PV}.tar.bz2"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ #man pages are tarred up seperately because building them depends on perl, which isn't installed at
+ #Gentoo Linux bootstrap time.
+ mkdir man; cd man
+ tar xjf ${DISTDIR}/${PN}-manpages-${PV}.tar.bz2
+}
+
+src_compile() {
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} --without-included-gettext || die
+ if [ "`use static`" ]
+ then
+ emake -e LDFLAGS=-all-static || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+ #c++filt is included with gcc -- what are these GNU people thinking?
+ rm ${D}/usr/bin/c++filt ${D}/usr/share/man/man1/c++filt*
+
+ #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip; we should reverse
+ #it:
+
+ rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
+ #the strip symlink gets created in the loop below
+
+ #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
+ #size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
+ #and create the appropriate symlinks. Things are cleaner that way.
+ cd ${D}/usr/bin
+ local x
+ for x in * strip
+ do
+ if [ ! -e ../${CHOST}/bin/${x} ]
+ then
+ mv $x ../${CHOST}/bin/${x}
+ else
+ rm -f $x
+ fi
+ ln -s ../${CHOST}/bin/${x} ${x}
+ done
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING* README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
+ docinto ld
+ dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog*
+ rm -f ${D}/usr/share/man/man1/*
+ doman ${S}/man/*.1
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}
+
+
+
diff --git a/sys-devel/binutils/files/digest-binutils-2.11.90.0.7-r1 b/sys-devel/binutils/files/digest-binutils-2.11.90.0.7-r1
new file mode 100644
index 000000000000..216a36e6b6d0
--- /dev/null
+++ b/sys-devel/binutils/files/digest-binutils-2.11.90.0.7-r1
@@ -0,0 +1,2 @@
+MD5 d80bb57a83a38d77daf40d45379053ed binutils-2.11.90.0.7.tar.gz 9510912
+MD5 344b61b80b1568e73c071254d65c8e38 binutils-manpages-2.11.90.0.7.tar.bz2 49152