summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/modutils/ChangeLog10
-rw-r--r--sys-apps/modutils/files/alias.h.diff12
-rw-r--r--sys-apps/modutils/files/digest-modutils-2.4.241
-rw-r--r--sys-apps/modutils/modutils-2.4.24.ebuild53
4 files changed, 75 insertions, 1 deletions
diff --git a/sys-apps/modutils/ChangeLog b/sys-apps/modutils/ChangeLog
index 062af76be11a..3734f59c3866 100644
--- a/sys-apps/modutils/ChangeLog
+++ b/sys-apps/modutils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/modutils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/ChangeLog,v 1.17 2003/03/13 21:40:39 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/ChangeLog,v 1.18 2003/03/24 22:06:21 drobbins Exp $
+
+*modutils-2.4.24 (24 Mar 2003)
+
+ 24 Mar 2003; Daniel Robbins <drobbins@gentoo.org> modutils-2.4.24.ebuild:
+ New upstream version. New alias.h.diff to close bug #11886. New PROVIDE
+ "virtual/module-tools" to allow closing of bugg #16294, which will happen
+ in the x86 profile initially. This will be unmasked for x86 to allow
+ #11886 to be closed; experimental for everything else.
*modutils-2.4.23 (13 Mar 2003)
diff --git a/sys-apps/modutils/files/alias.h.diff b/sys-apps/modutils/files/alias.h.diff
new file mode 100644
index 000000000000..bb352e545248
--- /dev/null
+++ b/sys-apps/modutils/files/alias.h.diff
@@ -0,0 +1,12 @@
+--- alias.h.orig 2003-03-24 14:45:49.000000000 -0700
++++ alias.h 2003-03-24 14:49:12.000000000 -0700
+@@ -246,9 +246,6 @@
+ */
+ char *above[] =
+ {
+- "hid keybdev mousedev",
+- "usbmouse hid",
+- "wacom evdev",
+ NULL /* marks the end of the list! */
+ };
+
diff --git a/sys-apps/modutils/files/digest-modutils-2.4.24 b/sys-apps/modutils/files/digest-modutils-2.4.24
new file mode 100644
index 000000000000..36ab2d77db57
--- /dev/null
+++ b/sys-apps/modutils/files/digest-modutils-2.4.24
@@ -0,0 +1 @@
+MD5 16170af2981db98367c6f140a1534668 modutils-2.4.24.tar.bz2 220279
diff --git a/sys-apps/modutils/modutils-2.4.24.ebuild b/sys-apps/modutils/modutils-2.4.24.ebuild
new file mode 100644
index 000000000000..8d9d80f7e3ec
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.4.24.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.24.ebuild,v 1.1 2003/03/24 22:06:21 drobbins Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Standard kernel module utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/modutils/"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa ~arm"
+SLOT="0"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc"
+PROVIDE="virtual/module-tools"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/util
+ cat ${FILESDIR}/alias.h.diff | patch -p0 || die
+}
+
+src_compile() {
+ filter-flags -fPIC
+ myconf=""
+ # see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
+ #
+ # Final resolution ... dont make it link against zlib, as the static
+ # version do not want to autoload modules :(
+ myconf="${myconf} --disable-zlib"
+
+ econf \
+ --prefix=/ \
+ --disable-strip \
+ --enable-insmod-static \
+ ${myconf} || die "./configure failed"
+ if [ ${ARCH} = "hppa" ]
+ then
+ mymake="ARCH=hppa"
+ fi
+
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ if [ ${ARCH} = "hppa" ]
+ then
+ mymake="ARCH=hppa"
+ fi
+ einstall prefix="${D}" ${mymake} || die "make install failed"
+
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+}
+