summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/amule/Manifest2
-rw-r--r--net-p2p/amule/amule-1.2.6.ebuild12
2 files changed, 12 insertions, 2 deletions
diff --git a/net-p2p/amule/Manifest b/net-p2p/amule/Manifest
index 72a4b64e3056..7a321cb7ab18 100644
--- a/net-p2p/amule/Manifest
+++ b/net-p2p/amule/Manifest
@@ -1,7 +1,7 @@
MD5 45160167840b21a65a6b9c3c79ad3037 amule-1.1.2.ebuild 1140
MD5 2cee8c802b04286b3d5a6b2b12ae28b1 amule-1.2.5.ebuild 1040
MD5 48512f05faced9924ae23d3189b91f46 amule-1.2.4.ebuild 1040
-MD5 ccaaa0fd91ffc32bc3209bb20dfcebc8 amule-1.2.6.ebuild 701
+MD5 afff9170d288a4e3b49143828a05a399 amule-1.2.6.ebuild 1058
MD5 b36c3e558b37e0b34037af1e6cef5b4a amule-1.1.0.ebuild 1016
MD5 ab36a1770f5086ab46d33a8241688e28 ChangeLog 2364
MD5 48196f9086047dcf34861f420f193753 amule-1.2.3.ebuild 1066
diff --git a/net-p2p/amule/amule-1.2.6.ebuild b/net-p2p/amule/amule-1.2.6.ebuild
index 8863dd830e91..f3058dfb97ac 100644
--- a/net-p2p/amule/amule-1.2.6.ebuild
+++ b/net-p2p/amule/amule-1.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.2.6.ebuild,v 1.2 2004/03/01 06:18:54 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.2.6.ebuild,v 1.3 2004/03/01 06:20:04 eradicator Exp $
MY_P=${P/m/M}
S=${WORKDIR}/${MY_P}
@@ -19,6 +19,16 @@ DEPEND=">=x11-libs/wxGTK-2.4.2
>=net-ftp/curl-7.11.0
>=sys-libs/zlib-1.2.1"
+pkg_setup() {
+ if wx-config --cppflags | grep gtk2u >& /dev/null; then
+ einfo "${PN} will not build if wxGTK was compiled"
+ einfo "with unicode support. If you are using a version of"
+ einfo "wxGTK <= 2.4.2, you must set USE=-gtk2. In newer versions,"
+ einfo "you must set USE=-unicode."
+ die "wxGTK must be re-emerged without unicode suport"
+ fi
+}
+
src_compile() {
econf `use_enable nls` || die
emake -j1 || die