summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/actionmailer/ChangeLog8
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.1.0.ebuild16
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-2.1.0.ebuild16
-rw-r--r--dev-ruby/activerecord/activerecord-2.1.0.ebuild21
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-2.1.0.ebuild16
-rw-r--r--dev-ruby/activesupport/ChangeLog8
-rw-r--r--dev-ruby/activesupport/activesupport-2.1.0.ebuild16
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.1.0.ebuild48
11 files changed, 166 insertions, 5 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index c831dfef7ef2..8d206b4f4d0e 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.77 2008/05/16 17:34:52 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.78 2008/06/17 05:38:29 graaff Exp $
+
+*actionmailer-2.1.0 (17 Jun 2008)
+
+ 17 Jun 2008; Hans de Graaff <graaff@gentoo.org>
+ +actionmailer-2.1.0.ebuild:
+ Version bump for Rails 2.1.0
16 May 2008; nixnut <nixnut@gentoo.org> actionmailer-2.0.2.ebuild:
Stable on ppc wrt bug 221309
diff --git a/dev-ruby/actionmailer/actionmailer-2.1.0.ebuild b/dev-ruby/actionmailer/actionmailer-2.1.0.ebuild
new file mode 100644
index 000000000000..cb69095dedb5
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-2.1.0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.1.0.ebuild,v 1.1 2008/06/17 05:38:29 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="=dev-ruby/actionpack-2.1.0
+ >=dev-lang/ruby-1.8.5"
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 2960f14c339f..021a47119ae1 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.78 2008/05/16 17:33:23 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.79 2008/06/17 05:35:03 graaff Exp $
+
+*actionpack-2.1.0 (17 Jun 2008)
+
+ 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> +actionpack-2.1.0.ebuild:
+ Version bump for Rails 2.1.0
16 May 2008; nixnut <nixnut@gentoo.org> actionpack-2.0.2.ebuild:
Stable on ppc wrt bug 221309
diff --git a/dev-ruby/actionpack/actionpack-2.1.0.ebuild b/dev-ruby/actionpack/actionpack-2.1.0.ebuild
new file mode 100644
index 000000000000..5f9cc0ce538a
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-2.1.0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-2.1.0.ebuild,v 1.1 2008/06/17 05:35:03 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ =dev-ruby/activesupport-2.1.0"
diff --git a/dev-ruby/activerecord/activerecord-2.1.0.ebuild b/dev-ruby/activerecord/activerecord-2.1.0.ebuild
new file mode 100644
index 000000000000..e32bb08a0980
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.1.0.ebuild,v 1.1 2008/06/17 05:40:54 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ ~dev-ruby/activesupport-2.1.0
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 2003531d71e9..0cc144c2362a 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.10 2008/05/16 17:32:01 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.11 2008/06/17 05:32:38 graaff Exp $
+
+*activeresource-2.1.0 (17 Jun 2008)
+
+ 17 Jun 2008; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-2.1.0.ebuild:
+ Version bump for Rails 2.1.0
16 May 2008; nixnut <nixnut@gentoo.org> activeresource-2.0.2.ebuild:
Stable on ppc wrt bug 221309
diff --git a/dev-ruby/activeresource/activeresource-2.1.0.ebuild b/dev-ruby/activeresource/activeresource-2.1.0.ebuild
new file mode 100644
index 000000000000..1cef6c4508ed
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-2.1.0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-2.1.0.ebuild,v 1.1 2008/06/17 05:32:38 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ ~dev-ruby/activesupport-2.1.0"
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 3b5fe0e5ba1e..983c09d01166 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.61 2008/05/16 17:30:10 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.62 2008/06/17 05:30:21 graaff Exp $
+
+*activesupport-2.1.0 (17 Jun 2008)
+
+ 17 Jun 2008; Hans de Graaff <graaff@gentoo.org>
+ +activesupport-2.1.0.ebuild:
+ Version bump for Rails 2.1.0
16 May 2008; nixnut <nixnut@gentoo.org> activesupport-2.0.2.ebuild:
Stable on ppc wrt bug 221309
diff --git a/dev-ruby/activesupport/activesupport-2.1.0.ebuild b/dev-ruby/activesupport/activesupport-2.1.0.ebuild
new file mode 100644
index 000000000000..829d15d2ec54
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.1.0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.1.0.ebuild,v 1.1 2008/06/17 05:30:21 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ >=dev-ruby/rubygems-0.9.0"
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 32ccbefd835d..5dfbcfa0f4ce 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.106 2008/05/16 17:37:47 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.107 2008/06/17 05:44:06 graaff Exp $
+
+*rails-2.1.0 (17 Jun 2008)
+
+ 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.0.ebuild:
+ Version bump for Rails 2.1.0
16 May 2008; nixnut <nixnut@gentoo.org> rails-2.0.2.ebuild:
Stable on ppc wrt bug 221309
diff --git a/dev-ruby/rails/rails-2.1.0.ebuild b/dev-ruby/rails/rails-2.1.0.ebuild
new file mode 100644
index 000000000000..cc09865ed565
--- /dev/null
+++ b/dev-ruby/rails/rails-2.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.1.0.ebuild,v 1.1 2008/06/17 05:44:06 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="fastcgi"
+DEPEND=">=dev-lang/ruby-1.8.5
+ >=app-admin/eselect-rails-0.12
+ >=dev-ruby/rake-0.7.2
+ ~dev-ruby/activerecord-2.1.0
+ ~dev-ruby/activeresource-2.1.0
+ ~dev-ruby/activesupport-2.1.0
+ ~dev-ruby/actionmailer-2.1.0
+ ~dev-ruby/actionpack-2.1.0
+ !<dev-ruby/rails-1.1.6-r1"
+
+RDEPEND="${DEPEND}
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )"
+
+src_install() {
+ gems_src_install
+ # Rename slotted files that may clash so that eselect can handle
+ # them
+ mv "${D}/usr/bin/rails" "${D}/usr/bin/rails-${PV}"
+ mv "${D}/${GEMSDIR}/bin/rails" "${D}/${GEMSDIR}/bin/rails-${PV}"
+}
+
+pkg_postinst() {
+ einfo "To select between slots of rails, use:"
+ einfo "\teselect rails"
+ # Bring users to rails 2.1.x by default when updating
+ eselect rails update 2.1
+
+ ewarn "All database USE flags have been moved to dev-ruby/activerecord"
+}
+
+pkg_postrm() {
+ # Drop users back to rails 2.0.x when they remove 2.1.x
+ eselect rails update 2
+}