summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-zope/acquisition/ChangeLog8
-rw-r--r--net-zope/acquisition/acquisition-2.13.1.ebuild49
-rw-r--r--net-zope/extensionclass/ChangeLog8
-rw-r--r--net-zope/extensionclass/extensionclass-2.13.0.ebuild46
-rw-r--r--net-zope/persistence/ChangeLog8
-rw-r--r--net-zope/persistence/Manifest6
-rw-r--r--net-zope/persistence/persistence-2.13.0.ebuild47
7 files changed, 166 insertions, 6 deletions
diff --git a/net-zope/acquisition/ChangeLog b/net-zope/acquisition/ChangeLog
index b7094a56305b..279415c4b6eb 100644
--- a/net-zope/acquisition/ChangeLog
+++ b/net-zope/acquisition/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/acquisition
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/acquisition/ChangeLog,v 1.4 2010/02/14 19:16:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/acquisition/ChangeLog,v 1.5 2010/03/12 18:20:27 arfrever Exp $
+
+*acquisition-2.13.1 (12 Mar 2010)
+
+ 12 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -acquisition-2.12.4.ebuild, +acquisition-2.13.1.ebuild:
+ Version bump.
14 Feb 2010; Raúl Porcel <armin76@gentoo.org> acquisition-2.12.4.ebuild:
Add ~alpha/~sparc wrt #297734
diff --git a/net-zope/acquisition/acquisition-2.13.1.ebuild b/net-zope/acquisition/acquisition-2.13.1.ebuild
new file mode 100644
index 000000000000..57e2aa622199
--- /dev/null
+++ b/net-zope/acquisition/acquisition-2.13.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/acquisition/acquisition-2.13.1.ebuild,v 1.1 2010/03/12 18:20:27 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="Acquisition"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Acquisition is a mechanism that allows objects to obtain attributes from the containment hierarchy they're in."
+HOMEPAGE="http://pypi.python.org/pypi/Acquisition"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="net-zope/extensionclass
+ net-zope/zope-interface"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools
+ test? ( net-zope/zope-testing )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${MY_PN}"
+DOCS="CHANGES.txt src/Acquisition/README.txt"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in Acquisition; do
+ ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}/_${module}.so" "src/${module}/_${module}.so" || die "Symlinking ${module}/_${module}.so failed with Python ${PYTHON_ABI}"
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ # Don't install C sources.
+ find "${D}"usr/$(get_libdir)/python*/site-packages -name "*.c" -o -name "*.h" | xargs rm -f
+}
diff --git a/net-zope/extensionclass/ChangeLog b/net-zope/extensionclass/ChangeLog
index 93f9e36933f3..f34179ceff41 100644
--- a/net-zope/extensionclass/ChangeLog
+++ b/net-zope/extensionclass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/extensionclass
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/extensionclass/ChangeLog,v 1.6 2010/02/22 11:12:50 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/extensionclass/ChangeLog,v 1.7 2010/03/12 18:16:36 arfrever Exp $
+
+*extensionclass-2.13.0 (12 Mar 2010)
+
+ 12 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -extensionclass-2.12.0.ebuild, +extensionclass-2.13.0.ebuild:
+ Version bump.
*extensionclass-2.12.0 (22 Feb 2010)
diff --git a/net-zope/extensionclass/extensionclass-2.13.0.ebuild b/net-zope/extensionclass/extensionclass-2.13.0.ebuild
new file mode 100644
index 000000000000..eba2fbd20963
--- /dev/null
+++ b/net-zope/extensionclass/extensionclass-2.13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/extensionclass/extensionclass-2.13.0.ebuild,v 1.1 2010/03/12 18:16:36 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="ExtensionClass"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Metaclass for subclassable extension types"
+HOMEPAGE="http://pypi.python.org/pypi/ExtensionClass"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ test? ( net-zope/zope-testing )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="ComputedAttribute ExtensionClass MethodObject"
+DOCS="CHANGES.txt README.txt"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in ComputedAttribute ExtensionClass MethodObject; do
+ ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}/_${module}.so" "src/${module}/_${module}.so" || die "Symlinking ${module}/_${module}.so failed with Python ${PYTHON_ABI}"
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ # Don't install C sources.
+ find "${D}"usr/$(get_libdir)/python*/site-packages -name "*.c" -o -name "*.h" | xargs rm -f
+}
diff --git a/net-zope/persistence/ChangeLog b/net-zope/persistence/ChangeLog
index cec3668791a0..3e2eb64585a5 100644
--- a/net-zope/persistence/ChangeLog
+++ b/net-zope/persistence/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/persistence
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/persistence/ChangeLog,v 1.5 2010/02/14 19:17:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/persistence/ChangeLog,v 1.6 2010/03/12 18:25:26 arfrever Exp $
+
+*persistence-2.13.0 (12 Mar 2010)
+
+ 12 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -persistence-2.11.1.ebuild, +persistence-2.13.0.ebuild:
+ Version bump.
14 Feb 2010; Raúl Porcel <armin76@gentoo.org> persistence-2.11.1.ebuild:
Add ~alpha/~sparc wrt #297734
diff --git a/net-zope/persistence/Manifest b/net-zope/persistence/Manifest
index aadd6c362207..3cd3490f3e93 100644
--- a/net-zope/persistence/Manifest
+++ b/net-zope/persistence/Manifest
@@ -1,4 +1,4 @@
-DIST Persistence-2.11.1.tar.gz 68389 RMD160 8defc22102a88dccd5e2776b53476afda33b06d4 SHA1 63ed3142ffed076a85e6ceafee5c5fe24781259f SHA256 26634372f58bc896b4d4c4ba6385cfa27aef453566a13d84f544f68545710f46
-EBUILD persistence-2.11.1.ebuild 1303 RMD160 44c9a726d892ef331ee47b7e1a5f7445510c6bd8 SHA1 965dafad2a1268b04d274254cf46c0db2030926c SHA256 ab532b9dda0315c3f4ff54f41837cbf0890694f2eb15aa1860ca40f565170d3c
-MISC ChangeLog 903 RMD160 b4c9e257ec18267847bed11a41452cab8090b62f SHA1 9b7d8c634faa212218c617662804f17d8e3ee678 SHA256 1481a1956227cbe0fa8d55cd91cdc9faba914ab16a44d368a1a8fccd892cc5b3
+DIST Persistence-2.13.0.zip 95567 RMD160 752319907c617a8ddcd082464893de817d63aab6 SHA1 3717805afe4b74f504e14122a796bb5a36850835 SHA256 77e631dc3b12d1c52b00ab196c86825b60c554d5780ca9d525c9b52f60fbfd24
+EBUILD persistence-2.13.0.ebuild 1243 RMD160 7b2bcb4592449258fecf37d8b80d1d3a24accd20 SHA1 1fa95e47843a7419f9c5d22409d10582224fa909 SHA256 4f9c335e23f8707769bbedb40a6bad9760d1f03fbd3d715da2371fd257013804
+MISC ChangeLog 1087 RMD160 fb706ba9466400a0b5ef0d47dfaf2e6ecdfa9001 SHA1 d35d32dfc905418fc1e54a6c873a81a2463a5c5e SHA256 92851612f902959ba49569fd9fda5e519ea17dcba400c56fd635aa6130c2ae8f
MISC metadata.xml 183 RMD160 0e2d86898897ee70cc1f6e9ceb76d00388d3b2fa SHA1 19635a9dfa15036e341a7cbdd8cbd018db62be82 SHA256 f480763451083d2f7be8fc23d38e02952ccc383b4cc65e103a9901a0907ce50d
diff --git a/net-zope/persistence/persistence-2.13.0.ebuild b/net-zope/persistence/persistence-2.13.0.ebuild
new file mode 100644
index 000000000000..0dbefc7bcbe6
--- /dev/null
+++ b/net-zope/persistence/persistence-2.13.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/persistence/persistence-2.13.0.ebuild,v 1.1 2010/03/12 18:25:26 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="Persistence"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Persistent ExtensionClass"
+HOMEPAGE="http://pypi.python.org/pypi/Persistence"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="net-zope/extensionclass
+ net-zope/zodb"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ test? ( net-zope/zope-testing )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${MY_PN}"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in Persistence; do
+ ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}/_${module}.so" "src/${module}/_${module}.so" || die "Symlinking ${module}/_${module}.so failed with Python ${PYTHON_ABI}"
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ # Don't install C sources.
+ find "${D}"usr/$(get_libdir)/python*/site-packages -name "*.c" | xargs rm -f
+}