summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/schroot/ChangeLog7
-rw-r--r--dev-util/schroot/Manifest3
-rw-r--r--dev-util/schroot/schroot-1.2.3-r2.ebuild82
3 files changed, 90 insertions, 2 deletions
diff --git a/dev-util/schroot/ChangeLog b/dev-util/schroot/ChangeLog
index 201333d20cb7..175e68da0ea3 100644
--- a/dev-util/schroot/ChangeLog
+++ b/dev-util/schroot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/schroot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/schroot/ChangeLog,v 1.4 2009/09/14 08:35:25 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/schroot/ChangeLog,v 1.5 2009/10/02 02:52:08 abcd Exp $
+
+*schroot-1.2.3-r2 (02 Oct 2009)
+
+ 02 Oct 2009; Jonathan Callen <abcd@gentoo.org> +schroot-1.2.3-r2.ebuild:
+ Remove *.la files
14 Sep 2009; Jonathan Callen <abcd@gentoo.org> schroot-1.2.3-r1.ebuild:
Fix build error with FEATURES=-test (bug 284773). Thanks to Andy Kittner
diff --git a/dev-util/schroot/Manifest b/dev-util/schroot/Manifest
index 09e1019d5e5f..77b3d7424b8e 100644
--- a/dev-util/schroot/Manifest
+++ b/dev-util/schroot/Manifest
@@ -5,5 +5,6 @@ AUX schroot.confd 371 RMD160 d7efa36975f549304a1e8a942f6389720d1bff88 SHA1 3eaf6
AUX schroot.initd 844 RMD160 11eca8fd477b215d5b4964b582573ce14f116d25 SHA1 fe687d49e7d80342d46767f5e5fe63eed94a805d SHA256 f0f44c9fed06438f72f58825f67316c5069d58a6dfe3e1a33d0092b4fac1fb9f
DIST schroot_1.2.3.orig.tar.gz 25486414 RMD160 2c8c4bb92c870a6c0514df528d13f73b8f1b6d05 SHA1 1775aa19e3cb3237d8aa3cc36e3382d7e2c2919b SHA256 c3bca449abdf28b66f6aede8892ce61967b5c1d758ba567e8648ccfb0cf914ec
EBUILD schroot-1.2.3-r1.ebuild 2038 RMD160 3dec367766dcc83cbfe529ce5ce938e5de5ba832 SHA1 6daf14c0bbd58f6b67a64acfe830f38a928071a8 SHA256 b5a8c76381dd2fca54c353d1037b6c1df5e939434c31896baffc504bbd00d214
-MISC ChangeLog 1042 RMD160 5bb6acdf015045c3e8560d7031dbf00c29f6742f SHA1 2724996809dfcebf14c75f256c362082a2cd29e6 SHA256 a8c2a54119ae20e59402b60036159facec91511e6fd1e5063e67095f83914218
+EBUILD schroot-1.2.3-r2.ebuild 2138 RMD160 75447c6d3d58c524feac222e8b05ab3f1c4d161e SHA1 cc080f39defdb1e16db19274c29250f0d359e632 SHA256 301db5f7e06db12e044efe600524e79670a1432ac0d07367cadd472052b7334a
+MISC ChangeLog 1171 RMD160 70f09141c91acd2faf15a858e669e29dcd3a49f9 SHA1 a711daea4773103313954f2a3c679d8f711bd711 SHA256 7f5b2a19d31e119fa1d59cc9a14b3704743daa6ebed8ed433634dfeb0b47cbd8
MISC metadata.xml 384 RMD160 083cf5152883690484a973130318aef0d2c4f349 SHA1 d464ac6af08d92976517ae5715e1936c408c168d SHA256 58018798cc44ed856afd8c3c0e957aae8aabf548cc716e675604acc456fc20ef
diff --git a/dev-util/schroot/schroot-1.2.3-r2.ebuild b/dev-util/schroot/schroot-1.2.3-r2.ebuild
new file mode 100644
index 000000000000..543b3ea84318
--- /dev/null
+++ b/dev-util/schroot/schroot-1.2.3-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/schroot/schroot-1.2.3-r2.ebuild,v 1.1 2009/10/02 02:52:08 abcd Exp $
+
+EAPI="2"
+
+inherit autotools base
+
+DESCRIPTION="Utility to execute commands in a chroot environment"
+HOMEPAGE="http://packages.debian.org/source/sid/schroot"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dchroot debug doc nls test"
+
+COMMON_DEPEND="
+ >=dev-libs/boost-1.34.0
+ dev-libs/lockdev
+ sys-libs/pam
+"
+
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )
+ test? ( >=dev-util/cppunit-1.10.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/debianutils
+ dchroot? ( !dev-util/dchroot )
+ nls? ( virtual/libintl )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-autotools.patch"
+ "${FILESDIR}/${P}-pam.patch"
+ "${FILESDIR}/${P}-tests.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+
+ if use test; then
+ # Fix bug where aclocal doesn't find cppunit.m4 from the system...
+ ln -s /usr/share/aclocal/cppunit.m4 m4/
+ else
+ # Don't depend on cppunit unless we are testing
+ sed -i '/AM_PATH_CPPUNIT/s/^.*$/:/' configure.ac
+ fi
+
+ export AT_M4DIR=m4
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable dchroot) \
+ $(use_enable dchroot dchroot-dsa) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ --enable-shared \
+ --disable-static \
+ --localstatedir=/var
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/schroot.initd schroot || die "installation of init.d script failed"
+ newconfd "${FILESDIR}"/schroot.confd schroot || die "installation of conf.d file failed"
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "installation of docs failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/sbuild
+ doins doc/sbuild/html/* || die "installation of html docs failed"
+ insinto /usr/share/doc/${PF}/html/schroot
+ doins doc/schroot/html/* || die "installation of html docs failed"
+ fi
+
+ # Remove *.la files
+ find "${D}" -name "*.la" -exec rm {} + || die "removal of *.la files failed"
+}