summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/coverage/ChangeLog6
-rw-r--r--dev-python/coverage/coverage-3.3.1.ebuild33
-rw-r--r--dev-python/pywebkitgtk/ChangeLog6
-rw-r--r--dev-python/pywebkitgtk/pywebkitgtk-1.1.7.ebuild47
4 files changed, 10 insertions, 82 deletions
diff --git a/dev-python/coverage/ChangeLog b/dev-python/coverage/ChangeLog
index 5d09b0a7d377..789eb11c76e6 100644
--- a/dev-python/coverage/ChangeLog
+++ b/dev-python/coverage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/coverage
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/coverage/ChangeLog,v 1.39 2011/02/12 18:01:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/coverage/ChangeLog,v 1.40 2011/02/12 18:30:41 arfrever Exp $
+
+ 12 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -coverage-3.3.1.ebuild:
+ Delete.
12 Feb 2011; Raúl Porcel <armin76@gentoo.org> coverage-3.4.ebuild:
sparc stable wrt #341611
diff --git a/dev-python/coverage/coverage-3.3.1.ebuild b/dev-python/coverage/coverage-3.3.1.ebuild
deleted file mode 100644
index 7aa90095af9b..000000000000
--- a/dev-python/coverage/coverage-3.3.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/coverage/coverage-3.3.1.ebuild,v 1.7 2010/07/08 18:38:41 armin76 Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Measures code coverage during Python execution"
-HOMEPAGE="http://nedbatchelder.com/code/coverage/ http://pypi.python.org/pypi/coverage"
-SRC_URI="http://pypi.python.org/packages/source/c/coverage/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 hppa ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="test"
-
-RDEPEND="dev-python/setuptools"
-DEPEND="${RDEPEND}
- test? ( >=dev-python/nose-0.10.3 )"
-
-PYTHON_MODNAME="coverage"
-
-src_test() {
- testing() {
- # Future version of dev-python/nose will support Python 3.
- [[ "${PYTHON_ABI}" == 3.* ]] && return
-
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" nosetests
- }
- python_execute_function testing
-}
diff --git a/dev-python/pywebkitgtk/ChangeLog b/dev-python/pywebkitgtk/ChangeLog
index dbf12fdaea54..0c3f8976f5ab 100644
--- a/dev-python/pywebkitgtk/ChangeLog
+++ b/dev-python/pywebkitgtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pywebkitgtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/ChangeLog,v 1.23 2011/02/12 18:21:24 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/ChangeLog,v 1.24 2011/02/12 18:28:07 arfrever Exp $
+
+ 12 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pywebkitgtk-1.1.7.ebuild:
+ Delete.
12 Feb 2011; Raúl Porcel <armin76@gentoo.org> pywebkitgtk-1.1.8.ebuild:
sparc stable wrt #342489
diff --git a/dev-python/pywebkitgtk/pywebkitgtk-1.1.7.ebuild b/dev-python/pywebkitgtk/pywebkitgtk-1.1.7.ebuild
deleted file mode 100644
index 5c72ffcb9fea..000000000000
--- a/dev-python/pywebkitgtk/pywebkitgtk-1.1.7.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/pywebkitgtk-1.1.7.ebuild,v 1.11 2010/05/23 19:59:55 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python
-
-DESCRIPTION="Python bindings for the WebKit GTK+ port"
-HOMEPAGE="http://code.google.com/p/pywebkitgtk/"
-SRC_URI="http://pywebkitgtk.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE=""
-
-RDEPEND="dev-python/pygobject:2
- dev-python/pygtk:2
- dev-python/sexy-python
- x11-libs/libsexy
- dev-libs/libxslt
- >=net-libs/webkit-gtk-1.1.15"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-RESTRICT_PYTHON_ABIS="3.*"
-
-src_configure() {
- python_src_configure --disable-static
-}
-
-src_install() {
- python_src_install
- python_clean_installation_image
- dodoc AUTHORS MAINTAINERS NEWS README || die "dodoc failed"
-}
-
-pkg_postinst() {
- python_mod_optimize webkit
-}
-
-pkg_postrm() {
- python_mod_cleanup webkit
-}