summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tcltk/Tk_Theme/Tk_Theme-23.ebuild21
-rw-r--r--dev-tcltk/mysqltcl/mysqltcl-2.14.ebuild21
-rw-r--r--dev-tcltk/tclgpgme/tclgpgme-1.0.ebuild29
-rw-r--r--dev-tcltk/tcllib/tcllib-1.3.ebuild20
-rw-r--r--dev-tcltk/tclxml-expat/tclxml-expat-2.4.ebuild20
-rw-r--r--dev-tcltk/tclxml-expat/tclxml-expat-2.5.ebuild20
-rw-r--r--dev-tcltk/tclxml/tclxml-2.4.ebuild18
-rw-r--r--dev-tcltk/tclxml/tclxml-2.5.ebuild21
-rw-r--r--dev-tcltk/tix/tix-8.2.0.ebuild4
-rw-r--r--dev-tcltk/tkTheme/tkTheme-1.0.ebuild27
-rw-r--r--dev-tcltk/tkXwin/tkXwin-1.0.ebuild27
-rw-r--r--dev-tcltk/tls/tls-1.4.1.ebuild20
12 files changed, 93 insertions, 155 deletions
diff --git a/dev-tcltk/Tk_Theme/Tk_Theme-23.ebuild b/dev-tcltk/Tk_Theme/Tk_Theme-23.ebuild
index 2a5ebd7c87f9..65559bac1190 100644
--- a/dev-tcltk/Tk_Theme/Tk_Theme-23.ebuild
+++ b/dev-tcltk/Tk_Theme/Tk_Theme-23.ebuild
@@ -1,31 +1,25 @@
# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
-# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/Tk_Theme/Tk_Theme-23.ebuild,v 1.3 2003/07/12 13:10:41 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/Tk_Theme/Tk_Theme-23.ebuild,v 1.4 2003/08/07 03:19:11 vapier Exp $
DESCRIPTION="Theming library for TCL/TK."
HOMEPAGE="http://www.xmission.com/~georgeps/Tk_Theme/"
-IUSE=""
-
-DEPEND="dev-lang/tcl
- dev-lang/tk
- x11-base/xfree"
+SRC_URI="http://www.xmission.com/~georgeps/Tk_Theme/${P}.tgz"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="x86"
-SLOT="0"
-SRC_URI="http://www.xmission.com/~georgeps/Tk_Theme/${P}.tgz"
-S=${WORKDIR}/${P}
+DEPEND="dev-lang/tcl
+ dev-lang/tk
+ x11-base/xfree"
src_compile() {
-
tclsh configure || die
make || die
-
}
src_install() {
-
local libdir=/usr/lib/Tk_Theme
insinto ${libdir}
@@ -34,5 +28,4 @@ src_install() {
doexe theme.so
dodoc Changes LICENSE README TODO
-
}
diff --git a/dev-tcltk/mysqltcl/mysqltcl-2.14.ebuild b/dev-tcltk/mysqltcl/mysqltcl-2.14.ebuild
index ff9f53ce9798..a5bf934d6550 100644
--- a/dev-tcltk/mysqltcl/mysqltcl-2.14.ebuild
+++ b/dev-tcltk/mysqltcl/mysqltcl-2.14.ebuild
@@ -1,21 +1,18 @@
-# Copyright 2000-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/mysqltcl-2.14.ebuild,v 1.2 2003/07/12 13:10:41 aliz Exp $
+# Copyright 2000-2003 Gentoo Technologies, Inc
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/mysqltcl-2.14.ebuild,v 1.3 2003/08/07 03:27:13 vapier Exp $
DESCRIPTION="TCL MySQL Interface"
HOMEPAGE="http://www.xdobry.de/mysqltcl/"
+SRC_URI="http://www.xdobry.de/mysqltcl/${P}.tar.gz"
-DEPEND="
- >=dev-lang/tcl-8.1.0
- >=dev-lang/tk-8.1.0
- dev-db/mysql"
-RDEPEND="${DEPEND}"
-IUSE=""
LICENSE="as-is"
-KEYWORDS="x86"
SLOT="0"
-SRC_URI="http://www.xdobry.de/mysqltcl/${P}.tar.gz"
-S=${WORKDIR}/${P}
+KEYWORDS="x86"
+
+DEPEND=">=dev-lang/tcl-8.1.0
+ >=dev-lang/tk-8.1.0
+ dev-db/mysql"
src_compile() {
econf || die
diff --git a/dev-tcltk/tclgpgme/tclgpgme-1.0.ebuild b/dev-tcltk/tclgpgme/tclgpgme-1.0.ebuild
index ef3bcdcec682..24ce458c6dad 100644
--- a/dev-tcltk/tclgpgme/tclgpgme-1.0.ebuild
+++ b/dev-tcltk/tclgpgme/tclgpgme-1.0.ebuild
@@ -1,40 +1,33 @@
-# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
-# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclgpgme/tclgpgme-1.0.ebuild,v 1.3 2003/03/02 03:28:12 agenkin Exp $
+# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclgpgme/tclgpgme-1.0.ebuild,v 1.4 2003/08/07 03:19:55 vapier Exp $
+
+inherit eutils
DESCRIPTION="Tcl/Tk libraries to gpgme."
HOMEPAGE="http://beepcore-tcl.sourceforge.net/"
-
-DEPEND=">=dev-lang/tcl-8.3.3
- >=dev-lang/tk-8.3.3
- =app-crypt/gpgme-0.3*"
+SRC_URI="http://beepcore-tcl.sourceforge.net/${P}.tgz"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="x86"
-SLOT="0"
-SRC_URI="http://beepcore-tcl.sourceforge.net/${P}.tgz"
-S=${WORKDIR}/${P}
+DEPEND=">=dev-lang/tcl-8.3.3
+ >=dev-lang/tk-8.3.3
+ =app-crypt/gpgme-0.3*"
src_unpack() {
-
unpack ${A}
cd ${S}
-
- patch -p 0 < ${FILESDIR}/${PV}-Makefile.in.diff || die
-
+ epatch ${FILESDIR}/${PV}-Makefile.in.diff
}
src_compile() {
-
econf --with-tcl=/usr/lib --with-tk=/usr/lib || die
make || die
-
}
src_install() {
-
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog INSTALL LICENSE README TODO
-
}
diff --git a/dev-tcltk/tcllib/tcllib-1.3.ebuild b/dev-tcltk/tcllib/tcllib-1.3.ebuild
index eeafed09ea8a..4faa32174eda 100644
--- a/dev-tcltk/tcllib/tcllib-1.3.ebuild
+++ b/dev-tcltk/tcllib/tcllib-1.3.ebuild
@@ -1,32 +1,26 @@
-# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
-# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcllib/tcllib-1.3.ebuild,v 1.2 2003/03/02 03:28:36 agenkin Exp $
+# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcllib/tcllib-1.3.ebuild,v 1.3 2003/08/07 03:20:19 vapier Exp $
DESCRIPTION="Tcl Standard Library."
HOMEPAGE="http://www.tcl.tk/software/tcllib/"
-
-DEPEND=">=dev-lang/tcl-8.3.3
- >=dev-lang/tk-8.3.3"
+SRC_URI="mirror://sourceforge/tcllib/${P}.tar.gz"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="x86"
-SLOT="0"
-SRC_URI="mirror://sourceforge/tcllib/${P}.tar.gz"
-S=${WORKDIR}/${P}
+DEPEND=">=dev-lang/tcl-8.3.3
+ >=dev-lang/tk-8.3.3"
src_compile() {
-
econf || die
make || die
-
}
src_install() {
-
einstall || die
dodoc ChangeLog README license.terms
dohtml -r doc/html/*
-
}
diff --git a/dev-tcltk/tclxml-expat/tclxml-expat-2.4.ebuild b/dev-tcltk/tclxml-expat/tclxml-expat-2.4.ebuild
index 933dc0a65d97..8e20fceb1927 100644
--- a/dev-tcltk/tclxml-expat/tclxml-expat-2.4.ebuild
+++ b/dev-tcltk/tclxml-expat/tclxml-expat-2.4.ebuild
@@ -1,31 +1,27 @@
-# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
-# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml-expat/tclxml-expat-2.4.ebuild,v 1.4 2003/03/10 22:31:38 agriffis Exp $
+# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml-expat/tclxml-expat-2.4.ebuild,v 1.5 2003/08/07 03:22:19 vapier Exp $
DESCRIPTION="Tcl wrapper libraries for expat XML parser."
HOMEPAGE="http://tclxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tclxml/tclxml-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ~alpha"
DEPEND=">=dev-lang/tcl-8.3.3
>=dev-libs/expat-1.95.4
=dev-tcltk/tclxml-${PV}*"
-LICENSE="BSD"
-KEYWORDS="x86 ~alpha"
-
-SLOT="0"
-SRC_URI="mirror://sourceforge/tclxml/tclxml-${PV}.tar.gz"
S=${WORKDIR}/tclxml-${PV}/expat
src_compile() {
-
econf --with-tcl=/usr/lib --with-Tclxml=/usr/lib || die
make || die
-
}
src_install() {
-
einstall || die
dohtml expat.html
-
}
diff --git a/dev-tcltk/tclxml-expat/tclxml-expat-2.5.ebuild b/dev-tcltk/tclxml-expat/tclxml-expat-2.5.ebuild
index 21766e5827dc..b268929c3505 100644
--- a/dev-tcltk/tclxml-expat/tclxml-expat-2.5.ebuild
+++ b/dev-tcltk/tclxml-expat/tclxml-expat-2.5.ebuild
@@ -1,31 +1,27 @@
-# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
-# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml-expat/tclxml-expat-2.5.ebuild,v 1.1 2003/02/03 01:36:56 agenkin Exp $
+# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml-expat/tclxml-expat-2.5.ebuild,v 1.2 2003/08/07 03:22:19 vapier Exp $
DESCRIPTION="Tcl wrapper libraries for expat XML parser."
HOMEPAGE="http://tclxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tclxml/tclxml-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="-x86"
DEPEND=">=dev-lang/tcl-8.3.3
>=dev-libs/expat-1.95.4
=dev-tcltk/tclxml-${PV}*"
-LICENSE="BSD"
-KEYWORDS="-x86"
-
-SLOT="0"
-SRC_URI="mirror://sourceforge/tclxml/tclxml-${PV}.tar.gz"
S=${WORKDIR}/tclxml-${PV}/expat
src_compile() {
-
econf --with-tcl=/usr/lib --with-Tclxml=/usr/lib || die
make || die
-
}
src_install() {
-
einstall || die
dohtml expat.html
-
}
diff --git a/dev-tcltk/tclxml/tclxml-2.4.ebuild b/dev-tcltk/tclxml/tclxml-2.4.ebuild
index 7eaec1f3f123..cde90dc823a6 100644
--- a/dev-tcltk/tclxml/tclxml-2.4.ebuild
+++ b/dev-tcltk/tclxml/tclxml-2.4.ebuild
@@ -1,33 +1,27 @@
-# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
-# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.4.ebuild,v 1.3 2003/07/08 16:55:51 agenkin Exp $
+# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.4.ebuild,v 1.4 2003/08/07 03:21:11 vapier Exp $
DESCRIPTION="Pure Tcl implementation of an XML parser."
HOMEPAGE="http://tclxml.sourceforge.net/"
-
-DEPEND=">=dev-lang/tcl-8.3.3"
+SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="x86 ~alpha"
-SLOT="0"
-SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
-S=${WORKDIR}/${P}
+DEPEND=">=dev-lang/tcl-8.3.3"
src_compile() {
-
econf || die
make || die
# Need to hack the config script.
sed 's:NONE:/usr:' < TclxmlConfig.sh > TclxmlConfig.sh.hacked
mv TclxmlConfig.sh.hacked TclxmlConfig.sh
-
}
src_install() {
-
einstall || die
dodoc ChangeLog LICENSE README RELNOTES
-
}
diff --git a/dev-tcltk/tclxml/tclxml-2.5.ebuild b/dev-tcltk/tclxml/tclxml-2.5.ebuild
index b3181431323b..342ba4da98d4 100644
--- a/dev-tcltk/tclxml/tclxml-2.5.ebuild
+++ b/dev-tcltk/tclxml/tclxml-2.5.ebuild
@@ -1,36 +1,29 @@
-# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
-# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.5.ebuild,v 1.3 2003/02/03 01:20:50 agenkin Exp $
+# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.5.ebuild,v 1.4 2003/08/07 03:21:11 vapier Exp $
DESCRIPTION="Pure Tcl implementation of an XML parser."
HOMEPAGE="http://tclxml.sourceforge.net/"
-
-DEPEND=">=dev-lang/tcl-8.3.3"
+SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
LICENSE="BSD"
-
+SLOT="0"
+KEYWORDS="-x86"
# Setting to -x86 because can't compile the expat porsion (tclxml-expat).
# Use 2.4 for now.
-KEYWORDS="-x86"
-SLOT="0"
-SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
-S=${WORKDIR}/${P}
+DEPEND=">=dev-lang/tcl-8.3.3"
src_compile() {
-
econf || die
make || die
# Need to hack the config script.
sed 's:NONE:/usr:' < TclxmlConfig.sh > TclxmlConfig.sh.hacked
mv TclxmlConfig.sh.hacked TclxmlConfig.sh
-
}
src_install() {
-
einstall || die
dodoc ChangeLog LICENSE README RELNOTES
-
}
diff --git a/dev-tcltk/tix/tix-8.2.0.ebuild b/dev-tcltk/tix/tix-8.2.0.ebuild
index b8ea258a56e4..d2ae2f6a0d5f 100644
--- a/dev-tcltk/tix/tix-8.2.0.ebuild
+++ b/dev-tcltk/tix/tix-8.2.0.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/tix-8.2.0.ebuild,v 1.7 2003/05/10 19:58:11 utx Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/tix-8.2.0.ebuild,v 1.8 2003/08/07 03:22:39 vapier Exp $
MY_P=${P/-/}
S=${WORKDIR}/${MY_P}/unix
diff --git a/dev-tcltk/tkTheme/tkTheme-1.0.ebuild b/dev-tcltk/tkTheme/tkTheme-1.0.ebuild
index ffc8339bcc34..87ed72399f4d 100644
--- a/dev-tcltk/tkTheme/tkTheme-1.0.ebuild
+++ b/dev-tcltk/tkTheme/tkTheme-1.0.ebuild
@@ -1,39 +1,34 @@
-# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
-# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkTheme/tkTheme-1.0.ebuild,v 1.3 2003/03/02 03:31:34 agenkin Exp $
+# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkTheme/tkTheme-1.0.ebuild,v 1.4 2003/08/07 03:24:36 vapier Exp $
+
+inherit eutils
DESCRIPTION="Tcl/Tk Theming library."
HOMEPAGE="http://www.xmission.com/~georgeps/Tk_Theme/other/"
-
-DEPEND=">=dev-lang/tcl-8.3.3
- >=dev-lang/tk-8.3.3"
+SRC_URI="http://www.xmission.com/~georgeps/Tk_Theme/other/${PN}.tgz"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="x86"
-SLOT="0"
-SRC_URI="http://www.xmission.com/~georgeps/Tk_Theme/other/${PN}.tgz"
+DEPEND=">=dev-lang/tcl-8.3.3
+ >=dev-lang/tk-8.3.3"
+
S=${WORKDIR}/${PN}
src_unpack() {
-
unpack ${A}
cd ${S}
-
- patch -p 0 < ${FILESDIR}/${PV}-Makefile.in.diff || die
-
+ epatch ${FILESDIR}/${PV}-Makefile.in.diff
}
src_compile() {
-
econf --with-tcl=/usr/lib --with-tk=/usr/lib || die
make || die
-
}
src_install() {
-
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog INSTALL LICENSE README TODO
-
}
diff --git a/dev-tcltk/tkXwin/tkXwin-1.0.ebuild b/dev-tcltk/tkXwin/tkXwin-1.0.ebuild
index ba62d4295a71..8a7bc0bbba01 100644
--- a/dev-tcltk/tkXwin/tkXwin-1.0.ebuild
+++ b/dev-tcltk/tkXwin/tkXwin-1.0.ebuild
@@ -1,39 +1,32 @@
-# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
-# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkXwin/tkXwin-1.0.ebuild,v 1.3 2003/03/02 03:31:07 agenkin Exp $
+# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkXwin/tkXwin-1.0.ebuild,v 1.4 2003/08/07 03:26:29 vapier Exp $
+
+inherit eutils
DESCRIPTION="Tcl/Tk library to detect idle periods of an X session."
HOMEPAGE="http://beepcore-tcl.sourceforge.net/"
-
-DEPEND=">=dev-lang/tcl-8.3.3
- >=dev-lang/tk-8.3.3"
+SRC_URI="http://beepcore-tcl.sourceforge.net/${P}.tgz"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="x86"
-SLOT="0"
-SRC_URI="http://beepcore-tcl.sourceforge.net/${P}.tgz"
-S=${WORKDIR}/${P}
+DEPEND=">=dev-lang/tcl-8.3.3
+ >=dev-lang/tk-8.3.3"
src_unpack() {
-
unpack ${A}
cd ${S}
-
- patch -p 0 < ${FILESDIR}/${PV}-Makefile.in.diff || die
-
+ epatch ${FILESDIR}/${PV}-Makefile.in.diff
}
src_compile() {
-
econf --with-tcl=/usr/lib --with-tk=/usr/lib || die
make || die
-
}
src_install() {
-
make DESTDIR=${D} install || die
dodoc AUTHORS INSTALL README
-
}
diff --git a/dev-tcltk/tls/tls-1.4.1.ebuild b/dev-tcltk/tls/tls-1.4.1.ebuild
index 5a35f3a7f62c..3857ad8fa5dc 100644
--- a/dev-tcltk/tls/tls-1.4.1.ebuild
+++ b/dev-tcltk/tls/tls-1.4.1.ebuild
@@ -1,31 +1,27 @@
-# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
-# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tls/tls-1.4.1.ebuild,v 1.2 2003/03/02 03:30:38 agenkin Exp $
+# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tls/tls-1.4.1.ebuild,v 1.3 2003/08/07 03:26:51 vapier Exp $
DESCRIPTION="TLS OpenSSL extension to Tcl."
HOMEPAGE="http://tls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tls/${PN}${PV}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
DEPEND=">=dev-lang/tcl-8.3.3
>=dev-lang/tk-8.3.3
dev-libs/openssl"
-LICENSE="BSD"
-KEYWORDS="x86"
-
-SLOT="0"
-SRC_URI="mirror://sourceforge/tls/${PN}${PV}-src.tar.gz"
S=${WORKDIR}/tls1.4
src_compile() {
-
econf --with-ssl-dir=/usr || die
make || die
-
}
src_install() {
-
einstall || die
dodoc ChangeLog README.txt license.terms
-
}