summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/astng/ChangeLog8
-rw-r--r--dev-python/astng/astng-0.16.3.ebuild57
-rw-r--r--dev-python/astng/files/digest-astng-0.16.33
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/astng/ChangeLog b/dev-python/astng/ChangeLog
index 2b9f2d8af394..4a490f4b4f42 100644
--- a/dev-python/astng/ChangeLog
+++ b/dev-python/astng/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/astng
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.13 2006/09/26 23:56:29 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.14 2006/11/29 23:58:18 marienz Exp $
+
+*astng-0.16.3 (29 Nov 2006)
+
+ 29 Nov 2006; Marien Zwart <marienz@gentoo.org> -astng-0.14.0.ebuild,
+ -astng-0.15.0.ebuild, -astng-0.15.1.ebuild, +astng-0.16.3.ebuild:
+ Version bump, remove old versions.
*astng-0.16.1 (26 Sep 2006)
diff --git a/dev-python/astng/astng-0.16.3.ebuild b/dev-python/astng/astng-0.16.3.ebuild
new file mode 100644
index 000000000000..2db6b9417dd3
--- /dev/null
+++ b/dev-python/astng/astng-0.16.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.16.3.ebuild,v 1.1 2006/11/29 23:58:18 marienz Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
+SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz"
+HOMEPAGE="http://www.logilab.org/projects/astng/"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="GPL-2"
+DEPEND=">=dev-lang/python-2.1
+ >=dev-python/logilab-common-0.13-r1"
+
+S="${WORKDIR}/logilab-${P}"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Skip a failing test.
+ epatch "${FILESDIR}/${PN}-0.16.1-skip-gobject-test.patch"
+}
+
+src_install() {
+ distutils_src_install
+ python_version
+ # we need to remove this file because it collides with the one
+ # from logilab-common (which we depend on).
+ rm "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/logilab/__init__.py"
+}
+
+src_test() {
+ # The tests will not work properly from the source dir, so do a
+ # temporary install.
+
+ python_version
+ local spath="usr/$(get_libdir)/python${PYVER}/site-packages/"
+ # This is a hack to make tests work without installing to the live
+ # filesystem. We copy part of the logilab site-packages to a temporary
+ # dir, install there, and run from there.
+ mkdir -p "${T}/test/${spath}/logilab"
+ cp -r "${ROOT}${spath}/logilab/common" "${T}/test/${spath}/logilab" \
+ || die "copying logilab-common failed!"
+
+ "${python}" setup.py install --root="${T}/test" || die "test copy failed"
+ # dir needs to be this or the tests fail
+ cd "${T}/test/${spath}/logilab/astng/test"
+ PYTHONPATH="${T}/test/${spath}" "${python}" runtests.py \
+ || die "tests failed"
+ cd "${S}"
+ rm -rf "${T}/test"
+}
diff --git a/dev-python/astng/files/digest-astng-0.16.3 b/dev-python/astng/files/digest-astng-0.16.3
new file mode 100644
index 000000000000..44b550ed8690
--- /dev/null
+++ b/dev-python/astng/files/digest-astng-0.16.3
@@ -0,0 +1,3 @@
+MD5 12061e3f8accd115ba101c6af15e5eef logilab-astng-0.16.3.tar.gz 58548
+RMD160 7fb40a0c2d1264f788c9bc903b58c88cfc32c3fd logilab-astng-0.16.3.tar.gz 58548
+SHA256 e1f418eeed96c2831215bbf76c7df395b23b699c08a13350974147dfb67acb43 logilab-astng-0.16.3.tar.gz 58548