summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/bash-completion/ChangeLog7
-rw-r--r--app-shells/bash-completion/bash-completion-20020619.ebuild43
-rw-r--r--app-shells/bash-completion/files/bash-completion13
3 files changed, 42 insertions, 21 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 77733e404ab2..98a5c551d94b 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.5 2002/06/19 15:31:44 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.6 2002/06/20 18:57:59 bangert Exp $
+
+ 20 Jun 2002; Thilo Bangert <bangert@gentoo.org> bash-completion-20020619.ebuild :
+
+ added support for /etc/profile.d/bash-completion
+
*bash-completion-20020619 (19 Jun 2002)
diff --git a/app-shells/bash-completion/bash-completion-20020619.ebuild b/app-shells/bash-completion/bash-completion-20020619.ebuild
index 8c7eba8b52ec..7a9b2a82fa2a 100644
--- a/app-shells/bash-completion/bash-completion-20020619.ebuild
+++ b/app-shells/bash-completion/bash-completion-20020619.ebuild
@@ -1,44 +1,47 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2
# Author: Thilo Bangert <bangert@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020619.ebuild,v 1.1 2002/06/19 15:34:05 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020619.ebuild,v 1.2 2002/06/20 18:57:59 bangert Exp $
S=${WORKDIR}/bash_completion
DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
SRC_URI="http://www.caliban.org/files/bash/${P}.tar.gz"
HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+LICENSE="GPL-2"
RDEPEND=">=sys-apps/bash-2.05a"
-LICENSE="GPL-2"
-
src_install () {
- insinto /etc
- doins bash_completion
+ insinto /etc
+ doins bash_completion
+
+ insinto /etc/bash_completion.d
+
+ doins contrib/dict
+ doins contrib/harbour
+ doins contrib/isql
+ doins contrib/larch
+ doins contrib/lilypond
+ doins contrib/p4
+ doins contrib/ri
- insinto /etc/bash_completion.d
+ doins ${FILESDIR}/gentoo.completion
- doins contrib/dict
- doins contrib/harbour
- doins contrib/isql
- doins contrib/larch
- doins contrib/lilypond
- doins contrib/p4
- doins contrib/ri
-
- doins ${FILESDIR}/gentoo.completion
+ insinto /etc/profile.d
+ doins ${FILESDIR}/bash-completion
- dodoc COPYING Changelog README
+ dodoc COPYING Changelog README
}
pkg_postinst() {
- echo
- einfo "See /usr/share/doc/${P}/README.gz on how to "
- einfo "add completion support to your bash"
- echo
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+ echo
}
diff --git a/app-shells/bash-completion/files/bash-completion b/app-shells/bash-completion/files/bash-completion
new file mode 100644
index 000000000000..ba91d940f4f2
--- /dev/null
+++ b/app-shells/bash-completion/files/bash-completion
@@ -0,0 +1,13 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/files/bash-completion,v 1.1 2002/06/20 18:57:59 bangert Exp $
+#
+# START bash completion -- do not remove this line
+bash=${BASH_VERSION%.*}; bmajor=${bash%.*}; bminor=${bash#*.}
+if [ "$PS1" ] && [ $bmajor -eq 2 ] && [ $bminor '>' 04 ] \
+ && [ -f /etc/bash_completion ]; then # interactive shell
+ # Source completion code
+ . /etc/bash_completion
+fi
+unset bash bmajor bminor
+# END bash completion -- do not remove this line