summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/libselinux/ChangeLog10
-rw-r--r--sys-libs/libselinux/files/libselinux-2.1.12-mountsys.patch22
-rw-r--r--sys-libs/libselinux/files/libselinux-2.1.9-support_ruby19.patch12
-rw-r--r--sys-libs/libselinux/libselinux-2.1.12.ebuild93
-rw-r--r--sys-libs/libselinux/libselinux-2.1.9-r3.ebuild92
-rw-r--r--sys-libs/libsemanage/ChangeLog7
-rw-r--r--sys-libs/libsemanage/libsemanage-2.1.9.ebuild125
-rw-r--r--sys-libs/libsepol/ChangeLog7
-rw-r--r--sys-libs/libsepol/libsepol-2.1.8.ebuild40
9 files changed, 405 insertions, 3 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index 3750aa8b961c..efc17d946d4b 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-libs/libselinux
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.86 2012/10/06 16:36:49 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.87 2012/10/09 20:00:12 swift Exp $
+
+*libselinux-2.1.12 (09 Oct 2012)
+*libselinux-2.1.9-r3 (09 Oct 2012)
+
+ 09 Oct 2012; <swift@gentoo.org> +libselinux-2.1.9-r3.ebuild,
+ +files/libselinux-2.1.9-support_ruby19.patch, +libselinux-2.1.12.ebuild,
+ +files/libselinux-2.1.12-mountsys.patch:
+ Introducing upstream version and fix for ruby19
06 Oct 2012; <swift@gentoo.org> libselinux-2.1.9-r2.ebuild:
Stabilize
diff --git a/sys-libs/libselinux/files/libselinux-2.1.12-mountsys.patch b/sys-libs/libselinux/files/libselinux-2.1.12-mountsys.patch
new file mode 100644
index 000000000000..625ccfb60804
--- /dev/null
+++ b/sys-libs/libselinux/files/libselinux-2.1.12-mountsys.patch
@@ -0,0 +1,22 @@
+diff -ur libselinux-2.1.12.orig/src/load_policy.c libselinux-2.1.12/src/load_policy.c
+--- libselinux-2.1.12.orig/src/load_policy.c 2012-09-29 09:32:18.374170451 +0200
++++ libselinux-2.1.12/src/load_policy.c 2012-09-29 09:34:05.130172917 +0200
+@@ -370,8 +370,16 @@
+ * mount it if present for use in the calls below.
+ */
+ const char *mntpoint = NULL;
+- if (mount(SELINUXFS, SELINUXMNT, SELINUXFS, 0, 0) == 0 || errno == EBUSY) {
+- mntpoint = SELINUXMNT;
++ /* First make sure /sys is mounted */
++ if (mount("sysfs", "/sys", "sysfs", 0, 0) == 0 || errno == EBUSY) {
++ if (mount(SELINUXFS, SELINUXMNT, SELINUXFS, 0, 0) == 0 || errno == EBUSY) {
++ mntpoint = SELINUXMNT;
++ } else {
++ /* check old mountpoint */
++ if (mount(SELINUXFS, OLDSELINUXMNT, SELINUXFS, 0, 0) == 0 || errno == EBUSY) {
++ mntpoint = OLDSELINUXMNT;
++ }
++ }
+ } else {
+ /* check old mountpoint */
+ if (mount(SELINUXFS, OLDSELINUXMNT, SELINUXFS, 0, 0) == 0 || errno == EBUSY) {
diff --git a/sys-libs/libselinux/files/libselinux-2.1.9-support_ruby19.patch b/sys-libs/libselinux/files/libselinux-2.1.9-support_ruby19.patch
new file mode 100644
index 000000000000..02ee2b39bc7f
--- /dev/null
+++ b/sys-libs/libselinux/files/libselinux-2.1.9-support_ruby19.patch
@@ -0,0 +1,12 @@
+diff -ur libselinux-2.1.9.orig/src/Makefile libselinux-2.1.9/src/Makefile
+--- libselinux-2.1.9.orig/src/Makefile 2012-10-06 21:11:43.140757973 +0200
++++ libselinux-2.1.9/src/Makefile 2012-10-06 21:12:54.896758126 +0200
+@@ -15,7 +15,7 @@
+ PYLIBDIR ?= $(LIBDIR)/$(PYLIBVER)
+ RUBYLIBVER ?= $(shell ruby -e 'print RUBY_VERSION.split(".")[0..1].join(".")')
+ RUBYPLATFORM ?= $(shell ruby -e 'print RUBY_PLATFORM')
+-RUBYINC ?= $(LIBDIR)/ruby/$(RUBYLIBVER)/$(RUBYPLATFORM)
++RUBYINC ?= $(shell pkg-config --cflags ruby-$(RUBYLIBVER))
+ RUBYINSTALL ?= $(LIBDIR)/ruby/site_ruby/$(RUBYLIBVER)/$(RUBYPLATFORM)
+ LIBBASE=$(shell basename $(LIBDIR))
+
diff --git a/sys-libs/libselinux/libselinux-2.1.12.ebuild b/sys-libs/libselinux/libselinux-2.1.12.ebuild
new file mode 100644
index 000000000000..144eb08e51f7
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-2.1.12.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.1.12.ebuild,v 1.1 2012/10/09 20:00:12 swift Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 *-jython *-pypy-*"
+
+inherit multilib python toolchain-funcs eutils
+
+SEPOL_VER="2.1.8"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120924/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python ruby"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=dev-libs/libpcre-8.30-r2
+ ruby? ( dev-lang/ruby )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ ruby? ( dev-lang/swig )
+ python? ( dev-lang/swig )"
+
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i \
+ -e "/^LIBDIR/s/lib/$(get_libdir)/" \
+ -e "/^SHLIBDIR/s/lib/$(get_libdir)/" \
+ src/Makefile utils/Makefile || die
+ epatch "${FILESDIR}/${P}-mountsys.patch"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LDFLAGS="-fPIC $(pkg-config --libs libpcre) ${LDFLAGS}" all || die
+
+ if use python; then
+ python_copy_sources src
+ building() {
+ emake CC="$(tc-getCC)" PYINC="-I$(python_get_includedir)" PYTHONLIBDIR="$(python_get_library -l)" PYPREFIX="python-$(python_get_version)" LDFLAGS="-fPIC $(pkg-config --libs libpcre) ${LDFLAGS}" pywrap
+ }
+ python_execute_function -s --source-dir src building
+ fi
+
+ if use ruby; then
+ emake CC="$(tc-getCC)" rubywrap || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" install-pywrap
+ }
+ python_execute_function -s --source-dir src installation
+ fi
+
+ if use ruby; then
+ emake DESTDIR="${D}" install-rubywrap || die
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize selinux
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup selinux
+ fi
+}
diff --git a/sys-libs/libselinux/libselinux-2.1.9-r3.ebuild b/sys-libs/libselinux/libselinux-2.1.9-r3.ebuild
new file mode 100644
index 000000000000..f456ac1951df
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-2.1.9-r3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.1.9-r3.ebuild,v 1.1 2012/10/09 20:00:12 swift Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 *-jython *-pypy-*"
+
+inherit multilib python toolchain-funcs eutils
+
+SEPOL_VER="2.1.4"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120216/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python ruby"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ ruby? ( dev-lang/ruby )"
+DEPEND="${RDEPEND}
+ ruby? ( dev-lang/swig )
+ python? ( dev-lang/swig )"
+
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i \
+ -e "/^LIBDIR/s/lib/$(get_libdir)/" \
+ -e "/^SHLIBDIR/s/lib/$(get_libdir)/" \
+ src/Makefile utils/Makefile || die
+ epatch "${FILESDIR}/${P}-mountsys.patch"
+ epatch "${FILESDIR}/${P}-support_ruby19.patch"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LDFLAGS="-fPIC ${LDFLAGS}" all || die
+
+ if use python; then
+ python_copy_sources src
+ building() {
+ emake CC="$(tc-getCC)" PYINC="-I$(python_get_includedir)" PYTHONLIBDIR="$(python_get_library -l)" PYPREFIX="python-$(python_get_version)" LDFLAGS="-fPIC ${LDFLAGS}" pywrap
+ }
+ python_execute_function -s --source-dir src building
+ fi
+
+ if use ruby; then
+ emake CC="$(tc-getCC)" rubywrap || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" install-pywrap
+ }
+ python_execute_function -s --source-dir src installation
+ fi
+
+ if use ruby; then
+ emake DESTDIR="${D}" install-rubywrap || die
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize selinux
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup selinux
+ fi
+}
diff --git a/sys-libs/libsemanage/ChangeLog b/sys-libs/libsemanage/ChangeLog
index fd40213b12b3..aaefea434536 100644
--- a/sys-libs/libsemanage/ChangeLog
+++ b/sys-libs/libsemanage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsemanage
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.50 2012/06/26 05:04:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.51 2012/10/09 19:59:31 swift Exp $
+
+*libsemanage-2.1.9 (09 Oct 2012)
+
+ 09 Oct 2012; <swift@gentoo.org> +libsemanage-2.1.9.ebuild:
+ Introduce new upstream version
26 Jun 2012; Mike Gilbert <floppym@gentoo.org> libsemanage-2.1.6-r2.ebuild,
libsemanage-2.1.6.ebuild:
diff --git a/sys-libs/libsemanage/libsemanage-2.1.9.ebuild b/sys-libs/libsemanage/libsemanage-2.1.9.ebuild
new file mode 100644
index 000000000000..2ee1d1e8a420
--- /dev/null
+++ b/sys-libs/libsemanage/libsemanage-2.1.9.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/libsemanage-2.1.9.ebuild,v 1.1 2012/10/09 19:59:31 swift Exp $
+
+EAPI="3"
+# Support for 4 depends on python.eclass
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
+
+inherit multilib python toolchain-funcs eutils
+
+SEPOL_VER="2.1.8"
+SELNX_VER="2.1.12"
+
+DESCRIPTION="SELinux kernel and policy management library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120924/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python ruby"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=sys-libs/libselinux-${SELNX_VER}
+ dev-libs/ustr
+ ruby? ( dev-lang/ruby )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ ruby? ( >=dev-lang/swig-2.0.4-r1 )
+ python? ( >=dev-lang/swig-2.0.4-r1 )"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ echo "# Set this to true to save the linked policy." >> "${S}/src/semanage.conf"
+ echo "# This is normally only useful for analysis" >> "${S}/src/semanage.conf"
+ echo "# or debugging of policy." >> "${S}/src/semanage.conf"
+ echo "save-linked=false" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Set this to 0 to disable assertion checking." >> "${S}/src/semanage.conf"
+ echo "# This should speed up building the kernel policy" >> "${S}/src/semanage.conf"
+ echo "# from policy modules, but may leave you open to" >> "${S}/src/semanage.conf"
+ echo "# dangerous rules which assertion checking" >> "${S}/src/semanage.conf"
+ echo "# would catch." >> "${S}/src/semanage.conf"
+ echo "expand-check=1" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Modules in the module store can be compressed" >> "${S}/src/semanage.conf"
+ echo "# with bzip2. Set this to the bzip2 blocksize" >> "${S}/src/semanage.conf"
+ echo "# 1-9 when compressing. The higher the number," >> "${S}/src/semanage.conf"
+ echo "# the more memory is traded off for disk space." >> "${S}/src/semanage.conf"
+ echo "# Set to 0 to disable bzip2 compression." >> "${S}/src/semanage.conf"
+ echo "bzip-blocksize=0" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Reduce memory usage for bzip2 compression and" >> "${S}/src/semanage.conf"
+ echo "# decompression of modules in the module store." >> "${S}/src/semanage.conf"
+ echo "bzip-small=true" >> "${S}/src/semanage.conf"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" all || die
+
+ if use python; then
+ python_copy_sources src
+ building() {
+ emake CC="$(tc-getCC)" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" "$@"
+ }
+ python_execute_function -s --source-dir src building -- swigify
+ python_execute_function -s --source-dir src building -- pywrap
+ fi
+
+ if use ruby; then
+ emake -C src CC="$(tc-getCC)" rubywrap || die
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ LIBDIR="${D}usr/$(get_libdir)" \
+ SHLIBDIR="${D}$(get_libdir)" \
+ install || die
+ dosym "../../$(get_libdir)/libsemanage.so.1" "/usr/$(get_libdir)/libsemanage.so" || die
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYLIBVER="python$(python_get_version)" \
+ PYPREFIX="python-$(python_get_version)" \
+ LIBDIR="${D}usr/$(get_libdir)" \
+ install-pywrap
+ }
+ python_execute_function -s --source-dir src installation
+ fi
+
+ if use ruby; then
+ emake -C src \
+ DESTDIR="${D}" \
+ LIBDIR="${D}usr/$(get_libdir)" \
+ install-rubywrap || die
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize semanage.py
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup semanage.py
+ fi
+}
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index 23ae07a21fd8..ca8a04ee3471 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.49 2012/10/03 20:34:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.50 2012/10/09 19:58:45 swift Exp $
+
+*libsepol-2.1.8 (09 Oct 2012)
+
+ 09 Oct 2012; <swift@gentoo.org> +libsepol-2.1.8.ebuild:
+ Introducing upstream release
03 Oct 2012; Mike Frysinger <vapier@gentoo.org> libsepol-2.1.4-r1.ebuild:
Update to EAPI=4.
diff --git a/sys-libs/libsepol/libsepol-2.1.8.ebuild b/sys-libs/libsepol/libsepol-2.1.8.ebuild
new file mode 100644
index 000000000000..e0fd6a9c9985
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.1.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.1.8.ebuild,v 1.1 2012/10/09 19:58:45 swift Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120924/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+ epatch "${FILESDIR}/libsepol-2.1.4-fix_role_fix_callback.patch"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}