summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/SOAP-Lite/ChangeLog8
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-0.710.08.ebuild50
-rw-r--r--dev-perl/SOAP-Lite/files/SOAP-Lite-0.710.08.patch12
-rw-r--r--dev-perl/Test-Differences/ChangeLog10
-rw-r--r--dev-perl/Test-Differences/Test-Differences-0.48.01.ebuild19
5 files changed, 96 insertions, 3 deletions
diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
index 3d5540da0c4b..c23348da5c46 100644
--- a/dev-perl/SOAP-Lite/ChangeLog
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/SOAP-Lite
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.46 2008/11/18 15:28:18 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.47 2008/12/08 07:43:29 robbat2 Exp $
+
+*SOAP-Lite-0.710.08 (08 Dec 2008)
+
+ 08 Dec 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/SOAP-Lite-0.710.08.patch, +SOAP-Lite-0.710.08.ebuild:
+ Version bump.
18 Nov 2008; Torsten Veller <tove@gentoo.org> SOAP-Lite-0.69.ebuild:
New virtuals: Compress-Zlib
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.710.08.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.710.08.ebuild
new file mode 100644
index 000000000000..910be1ecfb17
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.710.08.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.710.08.ebuild,v 1.1 2008/12/08 07:43:29 robbat2 Exp $
+
+MODULE_AUTHOR="MKUTTER"
+inherit perl-module eutils
+
+DESCRIPTION="Provides a simple and lightweight interface to the SOAP protocol (sic) both on client and server side."
+
+IUSE="jabber ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+myconf="${myconf} --noprompt"
+
+# TESTS ARE DISABLED ON PURPOSE
+# This module attempts to access an external website for validation
+# of the MIME::Parser - not only is that bad practice in general,
+# but in this particular case the external site isn't even valid anymore# -mpc
+# 24/10/04
+SRC_TEST="do"
+
+DEPEND="dev-perl/XML-Parser
+ dev-perl/libwww-perl
+ virtual/perl-libnet
+ dev-perl/MIME-Lite
+ virtual/perl-MIME-Base64
+ ssl? ( dev-perl/Crypt-SSLeay )
+ jabber? ( dev-perl/Net-Jabber )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ virtual/perl-Compress-Zlib
+ >=dev-perl/MIME-tools-5.413
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # The author of this module put a dep for MIME::Parser 6.X - but the6.X
+ # release of MIME::Parser was a mistake during a change in maintainers on
+ # cpan. This patch alters the dependancy to the "real" stable version of
+ # MIME::Parser.
+ epatch "${FILESDIR}"/SOAP-Lite-0.710.08.patch
+}
+
+src_test() {
+ blah
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}
diff --git a/dev-perl/SOAP-Lite/files/SOAP-Lite-0.710.08.patch b/dev-perl/SOAP-Lite/files/SOAP-Lite-0.710.08.patch
new file mode 100644
index 000000000000..0b1e6e8470bd
--- /dev/null
+++ b/dev-perl/SOAP-Lite/files/SOAP-Lite-0.710.08.patch
@@ -0,0 +1,12 @@
+diff -Nuar SOAP-Lite-0.710.08.orig/Makefile.PL SOAP-Lite-0.710.08/Makefile.PL
+--- SOAP-Lite-0.710.08.orig/Makefile.PL 2008-06-28 11:37:20.000000000 -0700
++++ SOAP-Lite-0.710.08/Makefile.PL 2008-12-07 23:42:03.341939336 -0800
+@@ -43,7 +43,7 @@
+ ["DIME messages","SOAP::Packager::DIME",{"IO::Scalar" => "2.105", "DIME::Tools" => 0.03, "Data::UUID" => "0.11"},0],
+ ["SSL Support for TCP Transport","SOAP::Transport::TCP",{"IO::Socket::SSL" => 0},0],
+ ["Compression support for HTTP","SOAP::Transport::HTTP",{"Compress::Zlib" => 0},0],
+- ["MIME interoperability w/ Axis","SOAP::Lite",{"MIME::Parser" => "6.106"},0],
++ ["MIME interoperability w/ Axis","SOAP::Lite",{"MIME::Parser" => "5.413"},0],
+ );
+
+ use Getopt::Long;
diff --git a/dev-perl/Test-Differences/ChangeLog b/dev-perl/Test-Differences/ChangeLog
index 0c9610c81449..f18169a49a0d 100644
--- a/dev-perl/Test-Differences/ChangeLog
+++ b/dev-perl/Test-Differences/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Test-Differences
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Test-Differences/ChangeLog,v 1.11 2007/01/19 16:45:47 mcummings Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Test-Differences/ChangeLog,v 1.12 2008/12/08 07:45:48 robbat2 Exp $
+
+*Test-Differences-0.48.01 (08 Dec 2008)
+
+ 08 Dec 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +Test-Differences-0.48.01.ebuild:
+ Version bump.
19 Jan 2007; Michael Cummings <mcummings@gentoo.org>
Test-Differences-0.47.ebuild:
diff --git a/dev-perl/Test-Differences/Test-Differences-0.48.01.ebuild b/dev-perl/Test-Differences/Test-Differences-0.48.01.ebuild
new file mode 100644
index 000000000000..315bab5ddb67
--- /dev/null
+++ b/dev-perl/Test-Differences/Test-Differences-0.48.01.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Test-Differences/Test-Differences-0.48.01.ebuild,v 1.1 2008/12/08 07:45:48 robbat2 Exp $
+
+inherit versionator
+MY_P=${PN}-$(delete_version_separator 2)
+S=${WORKDIR}/${MY_P}
+MODULE_AUTHOR=OVID
+inherit perl-module
+
+DESCRIPTION="Test strings and data structures and show differences if not ok"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-perl/Text-Diff
+ dev-lang/perl"