summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/at-spi2-core/at-spi2-core-2.2.1-r1.ebuild')
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.2.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.2.1-r1.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..e89e705bc5af
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.2.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.2.1-r1.ebuild,v 1.1 2011/11/05 04:50:26 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=sys-apps/dbus-1
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ doc? ( >=dev-util/gtk-doc-1.9 )
+"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ G2CONF="${G2CONF} --disable-xevie"
+}
+
+src_prepare() {
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+ # Upstream patch to fix org.a11y.Bus.IsEnabled, will be in next release
+ epatch "${FILESDIR}/${P}-org.a11y.Bus.IsEnabled-property.patch"
+
+ gnome2_src_prepare
+}