summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/eselect-python/eselect-python-20140115.ebuild')
-rw-r--r--app-admin/eselect-python/eselect-python-20140115.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-admin/eselect-python/eselect-python-20140115.ebuild b/app-admin/eselect-python/eselect-python-20140115.ebuild
deleted file mode 100644
index f0b43b42bffd..000000000000
--- a/app-admin/eselect-python/eselect-python-20140115.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20140115.ebuild,v 1.3 2014/01/19 15:59:11 floppym Exp $
-
-# Keep the EAPI low here because everything else depends on it.
-# We want to make upgrading simpler.
-
-if [[ ${PV} == "99999999" ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/${PN}.git"
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="Eselect module for management of multiple Python versions"
-HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND=">=app-admin/eselect-1.2.3"
-
-src_unpack() {
- if [[ ${PV} == "99999999" ]] ; then
- git-r3_src_unpack
- cd "${S}"
- eautoreconf
- else
- unpack ${A}
- fi
-}
-
-src_install() {
- keepdir /etc/env.d/python
- emake DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- if has_version 'dev-lang/python'; then
- eselect python update --if-unset
- fi
- if has_version '=dev-lang/python-2*'; then
- eselect python update --python2 --if-unset
- fi
- if has_version '=dev-lang/python-3*'; then
- eselect python update --python3 --if-unset
- fi
-}