summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-antivirus/clamav/clamav-0.85-r1.ebuild')
-rw-r--r--app-antivirus/clamav/clamav-0.85-r1.ebuild104
1 files changed, 0 insertions, 104 deletions
diff --git a/app-antivirus/clamav/clamav-0.85-r1.ebuild b/app-antivirus/clamav/clamav-0.85-r1.ebuild
deleted file mode 100644
index 5e1b58e67dfb..000000000000
--- a/app-antivirus/clamav/clamav-0.85-r1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.85-r1.ebuild,v 1.3 2005/07/09 18:53:12 swegener Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Clam Anti-Virus Scanner"
-HOMEPAGE="http://www.clamav.net/"
-SRC_URI="mirror://sourceforge/clamav/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~hppa ~alpha ~ppc64 ~ia64"
-IUSE="crypt milter selinux"
-
-DEPEND="virtual/libc
- crypt? ( >=dev-libs/gmp-4.1.2 )
- milter? ( mail-mta/sendmail )
- >=sys-libs/zlib-1.2.1-r3
- >=net-misc/curl-7.10.0
- net-dns/libidn
- >=sys-apps/sed-4"
-RDEPEND="${DEPEND}
- selinux? ( sec-policy/selinux-clamav )
- sys-apps/grep"
-PROVIDE="virtual/antivirus"
-
-pkg_setup() {
- if use milter; then
- if ! built_with_use mail-mta/sendmail milter; then
- ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
- ewarn "USE flag. Either recompile sendmail with milter USE flag enabled, or disable"
- ewarn "this flag for clamav as well to disable milter support."
- die "need milter-enabled sendmail"
- fi
- fi
- enewgroup clamav
- enewuser clamav -1 /bin/false /dev/null clamav
- pwconv || die
-}
-
-src_compile() {
- has_version =sys-libs/glibc-2.2* && filter-lfs-flags
-
- local myconf
-
- # we depend on fixed zlib, so we can disable this check to prevent redundant
- # warning (bug #61749)
- myconf="${myconf} --disable-zlib-vcheck"
- # use id utility instead of /etc/passwd parsing (bug #72540)
- myconf="${myconf} --enable-id-check"
- use milter && myconf="${myconf} --enable-milter"
-
- econf ${myconf} --with-dbdir=/var/lib/clamav || die
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS BUGS NEWS README ChangeLog FAQ INSTALL
- newinitd ${FILESDIR}/clamd.rc.new clamd
- dodoc ${FILESDIR}/clamav-milter.README.gentoo
-
- dodir /var/run/clamav
- keepdir /var/run/clamav
- fowners clamav:clamav /var/run/clamav
- dodir /var/log/clamav
- keepdir /var/log/clamav
- fowners clamav:clamav /var/log/clamav
-
- # Change /etc/clamd.conf to be usable out of the box
- sed -i -e "s:^\(Example\):\# \1:" \
- -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \
- -e "s:.*\(LocalSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
- -e "s:.*\(User\) .*:\1 clamav:" \
- -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
- -e "s:^\#\(LogTime\).*:\1:" \
- ${D}/etc/clamd.conf
-
- # Do the same for /etc/freshclam.conf
- sed -i -e "s:^\(Example\):\# \1:" \
- -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
- -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
- -e "s:^\#\(LogFile\) .*:\1 /var/log/freshclam.log:" \
- -e "s:^\#\(LogTime\).*:\1:" \
- ${D}/etc/freshclam.conf
-}
-
-pkg_postinst() {
- echo
- ewarn "As of 0.85-r1, all settings from /etc/conf.d/clamd are ignored, except for"
- ewarn "START_CLAMD and START_FRESHCLAM. All settings are read from /etc/clamd.conf"
- ewarn "and /etc/freshclam.conf, so double-check these two files."
- echo
- ewarn "Warning: clamd and/or freshclam have not been restarted."
- ewarn "You should restart them with: /etc/init.d/clamd restart"
- echo
- if use milter ; then
- einfo "For simple instructions howto setup the clamav-milter..."
- einfo
- einfo "less /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
- echo
- fi
-}