summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/tar/files')
-rw-r--r--app-arch/tar/files/tar-1.23-revert-pipe.patch125
-rw-r--r--app-arch/tar/files/tar-1.23-strncpy.patch32
-rw-r--r--app-arch/tar/files/tar-1.23-symlink-k-hang.patch177
-rw-r--r--app-arch/tar/files/tar-1.23-tests.patch27
-rw-r--r--app-arch/tar/files/tar-1.25-incremental-fix.patch133
-rw-r--r--app-arch/tar/files/tar-1.25-verify-check.patch74
-rw-r--r--app-arch/tar/files/tar-1.25-verify-fix.patch43
7 files changed, 0 insertions, 611 deletions
diff --git a/app-arch/tar/files/tar-1.23-revert-pipe.patch b/app-arch/tar/files/tar-1.23-revert-pipe.patch
deleted file mode 100644
index f10719626f6c..000000000000
--- a/app-arch/tar/files/tar-1.23-revert-pipe.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-http://bugs.gentoo.org/252680
-http://bugs.gentoo.org/309001
-http://lists.gnu.org/archive/html/bug-tar/2008-12/msg00028.html
-
-revert this change:
-
-2008-11-25 Sergey Poznyakoff <gray@gnu.org.ua>
-
- Do not try to drain the input pipe before closing the
- archive.
-
- * src/buffer.c (close_archive): Remove call to
- sys_drain_input_pipe. Pass hit_eof as the second
- argument to sys_wait_for_child.
- * src/common.h (sys_drain_input_pipe): Remove
- (sys_wait_for_child): Declare second argument.
- * src/system.c (sys_drain_input_pipe): Remove.
- (sys_wait_for_child): Take two arguments. The second one helps to
- decide whether to tolerate child termination on SIGPIPE.
-
-diff --git a/src/buffer.c b/src/buffer.c
-index 5f5457a..02a3e4c 100644
---- a/src/buffer.c
-+++ b/src/buffer.c
-@@ -848,6 +848,8 @@ close_archive (void)
- flush_archive ();
- }
-
-+ sys_drain_input_pipe ();
-+
- compute_duration ();
- if (verify_option)
- verify_volume ();
-@@ -855,7 +857,7 @@ close_archive (void)
- if (rmtclose (archive) != 0)
- close_error (*archive_name_cursor);
-
-- sys_wait_for_child (child_pid, hit_eof);
-+ sys_wait_for_child (child_pid);
-
- tar_stat_destroy (&current_stat_info);
- if (save_name)
-diff --git a/src/common.h b/src/common.h
-index 9897b46..cc3483e 100644
---- a/src/common.h
-+++ b/src/common.h
-@@ -699,7 +699,8 @@ char *xheader_format_name (struct tar_stat_info *st, const char *fmt,
-
- void sys_detect_dev_null_output (void);
- void sys_save_archive_dev_ino (void);
--void sys_wait_for_child (pid_t, bool);
-+void sys_drain_input_pipe (void);
-+void sys_wait_for_child (pid_t);
- void sys_spawn_shell (void);
- bool sys_compare_uid (struct stat *a, struct stat *b);
- bool sys_compare_gid (struct stat *a, struct stat *b);
-diff --git a/src/system.c b/src/system.c
-index c90a40d..e57e6da 100644
---- a/src/system.c
-+++ b/src/system.c
-@@ -1,7 +1,6 @@
- /* System-dependent calls for tar.
-
-- Copyright (C) 2003, 2004, 2005, 2006, 2007,
-- 2008 Free Software Foundation, Inc.
-+ Copyright (C) 2003, 2004, 2005, 2006, 2007 Free Software Foundation, Inc.
-
- This program is free software; you can redistribute it and/or modify it
- under the terms of the GNU General Public License as published by the
-@@ -52,7 +51,12 @@ sys_detect_dev_null_output (void)
- }
-
- void
--sys_wait_for_child (pid_t child_pid, bool eof)
-+sys_drain_input_pipe (void)
-+{
-+}
-+
-+void
-+sys_wait_for_child (pid_t child_pid)
- {
- }
-
-@@ -156,8 +160,26 @@ sys_detect_dev_null_output (void)
- && archive_stat.st_ino == dev_null_stat.st_ino));
- }
-
-+/* Manage to fully drain a pipe we might be reading, so to not break it on
-+ the producer after the EOF block. FIXME: one of these days, GNU tar
-+ might become clever enough to just stop working, once there is no more
-+ work to do, we might have to revise this area in such time. */
-+
-+void
-+sys_drain_input_pipe (void)
-+{
-+ size_t r;
-+
-+ if (access_mode == ACCESS_READ
-+ && ! _isrmt (archive)
-+ && (S_ISFIFO (archive_stat.st_mode) || S_ISSOCK (archive_stat.st_mode)))
-+ while ((r = rmtread (archive, record_start->buffer, record_size)) != 0
-+ && r != SAFE_READ_ERROR)
-+ continue;
-+}
-+
- void
--sys_wait_for_child (pid_t child_pid, bool eof)
-+sys_wait_for_child (pid_t child_pid)
- {
- if (child_pid)
- {
-@@ -171,11 +193,8 @@ sys_wait_for_child (pid_t child_pid, bool eof)
- }
-
- if (WIFSIGNALED (wait_status))
-- {
-- int sig = WTERMSIG (wait_status);
-- if (!(!eof && sig == SIGPIPE))
-- FATAL_ERROR ((0, 0, _("Child died with signal %d"), sig));
-- }
-+ FATAL_ERROR ((0, 0, _("Child died with signal %d"),
-+ WTERMSIG (wait_status)));
- else if (WEXITSTATUS (wait_status) != 0)
- ERROR ((0, 0, _("Child returned status %d"),
- WEXITSTATUS (wait_status)));
diff --git a/app-arch/tar/files/tar-1.23-strncpy.patch b/app-arch/tar/files/tar-1.23-strncpy.patch
deleted file mode 100644
index c4939268c219..000000000000
--- a/app-arch/tar/files/tar-1.23-strncpy.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -uNr tar-1.23.ORIG//src/create.c tar-1.23/src/create.c
---- tar-1.23.ORIG//src/create.c 2010-04-25 17:36:03.553606076 +0100
-+++ tar-1.23/src/create.c 2010-04-25 17:36:16.294605862 +0100
-@@ -575,7 +575,10 @@
- GNAME_TO_CHARS (tmpname, header->header.gname);
- free (tmpname);
-
-- strcpy (header->header.magic, OLDGNU_MAGIC);
-+ /* OLDGNU_MAGIC is string with 7 chars + NULL */
-+ strncpy (header->header.magic, OLDGNU_MAGIC, sizeof(header->header.magic));
-+ strncpy (header->header.version, OLDGNU_MAGIC+sizeof(header->header.magic),
-+ sizeof(header->header.version));
- header->header.typeflag = type;
- finish_header (st, header, -1);
-
-@@ -910,9 +913,13 @@
- break;
-
- case OLDGNU_FORMAT:
-- case GNU_FORMAT: /*FIXME?*/
-- /* Overwrite header->header.magic and header.version in one blow. */
-- strcpy (header->header.magic, OLDGNU_MAGIC);
-+ case GNU_FORMAT:
-+ /* OLDGNU_MAGIC is string with 7 chars + NULL */
-+ strncpy (header->header.magic, OLDGNU_MAGIC,
-+ sizeof(header->header.magic));
-+ strncpy (header->header.version,
-+ OLDGNU_MAGIC+sizeof(header->header.magic),
-+ sizeof(header->header.version));
- break;
-
- case POSIX_FORMAT:
diff --git a/app-arch/tar/files/tar-1.23-symlink-k-hang.patch b/app-arch/tar/files/tar-1.23-symlink-k-hang.patch
deleted file mode 100644
index 61838bb913bc..000000000000
--- a/app-arch/tar/files/tar-1.23-symlink-k-hang.patch
+++ /dev/null
@@ -1,177 +0,0 @@
-http://bugs.gentoo.org/327641
-
-From b60e56fdb6fd8d82a1f92a4fa7781d9a3184dce1 Mon Sep 17 00:00:00 2001
-From: Sergey Poznyakoff <gray@gnu.org.ua>
-Date: Sat, 27 Mar 2010 22:02:28 +0200
-Subject: [PATCH] Fix dead loop on extracting existing symlinks with the -k option.
-
-* src/extract.c (create_placeholder_file)
-(extract_link, extract_symlink)
-(extract_node, extract_fifo): Handle all possible
-return values from maybe_recoverable. This complements
-8f390db92fc. Reported by Ico Doornekamp <bug-tar@zevv.nl>.
----
- src/extract.c | 101 +++++++++++++++++++++++++++++++++++++-------------------
- 2 files changed, 70 insertions(+), 35 deletions(-)
-
-diff --git a/src/extract.c b/src/extract.c
-index 32a883f..531654a 100644
---- a/src/extract.c
-+++ b/src/extract.c
-@@ -888,12 +888,22 @@ create_placeholder_file (char *file_name, bool is_symlink, int *interdir_made)
- struct stat st;
-
- while ((fd = open (file_name, O_WRONLY | O_CREAT | O_EXCL, 0)) < 0)
-- if (! maybe_recoverable (file_name, interdir_made))
-- break;
-+ {
-+ switch (maybe_recoverable (file_name, interdir_made))
-+ {
-+ case RECOVER_OK:
-+ continue;
-+
-+ case RECOVER_SKIP:
-+ return 0;
-+
-+ case RECOVER_NO:
-+ open_error (file_name);
-+ return -1;
-+ }
-+ }
-
-- if (fd < 0)
-- open_error (file_name);
-- else if (fstat (fd, &st) != 0)
-+ if (fstat (fd, &st) != 0)
- {
- stat_error (file_name);
- close (fd);
-@@ -956,7 +966,8 @@ extract_link (char *file_name, int typeflag)
- {
- int interdir_made = 0;
- char const *link_name;
--
-+ int rc;
-+
- link_name = current_stat_info.link_name;
-
- if (! absolute_names_option && contains_dot_dot (link_name))
-@@ -996,8 +1007,10 @@ extract_link (char *file_name, int typeflag)
-
- errno = e;
- }
-- while (maybe_recoverable (file_name, &interdir_made));
-+ while ((rc = maybe_recoverable (file_name, &interdir_made)) == RECOVER_OK);
-
-+ if (rc == RECOVER_SKIP)
-+ return 0;
- if (!(incremental_option && errno == EEXIST))
- {
- link_error (link_name, file_name);
-@@ -1010,7 +1023,6 @@ static int
- extract_symlink (char *file_name, int typeflag)
- {
- #ifdef HAVE_SYMLINK
-- int status;
- int interdir_made = 0;
-
- if (! absolute_names_option
-@@ -1018,15 +1030,22 @@ extract_symlink (char *file_name, int typeflag)
- || contains_dot_dot (current_stat_info.link_name)))
- return create_placeholder_file (file_name, true, &interdir_made);
-
-- while ((status = symlink (current_stat_info.link_name, file_name)))
-- if (!maybe_recoverable (file_name, &interdir_made))
-- break;
--
-- if (status == 0)
-- set_stat (file_name, &current_stat_info, NULL, 0, 0, SYMTYPE);
-- else
-- symlink_error (current_stat_info.link_name, file_name);
-- return status;
-+ while (symlink (current_stat_info.link_name, file_name))
-+ switch (maybe_recoverable (file_name, &interdir_made))
-+ {
-+ case RECOVER_OK:
-+ continue;
-+
-+ case RECOVER_SKIP:
-+ return 0;
-+
-+ case RECOVER_NO:
-+ symlink_error (current_stat_info.link_name, file_name);
-+ return -1;
-+ }
-+
-+ set_stat (file_name, &current_stat_info, NULL, 0, 0, SYMTYPE);
-+ return 0;
-
- #else
- static int warned_once;
-@@ -1052,16 +1071,23 @@ extract_node (char *file_name, int typeflag)
- mode_t invert_permissions =
- 0 < same_owner_option ? mode & (S_IRWXG | S_IRWXO) : 0;
-
-- do
-- status = mknod (file_name, mode ^ invert_permissions,
-- current_stat_info.stat.st_rdev);
-- while (status && maybe_recoverable (file_name, &interdir_made));
-+ while (mknod (file_name, mode ^ invert_permissions,
-+ current_stat_info.stat.st_rdev))
-+ switch (maybe_recoverable (file_name, &interdir_made))
-+ {
-+ case RECOVER_OK:
-+ continue;
-+
-+ case RECOVER_SKIP:
-+ return 0;
-+
-+ case RECOVER_NO:
-+ mknod_error (file_name);
-+ return -1;
-+ }
-
-- if (status != 0)
-- mknod_error (file_name);
-- else
-- set_stat (file_name, &current_stat_info, NULL, invert_permissions,
-- ARCHIVED_PERMSTATUS, typeflag);
-+ set_stat (file_name, &current_stat_info, NULL, invert_permissions,
-+ ARCHIVED_PERMSTATUS, typeflag);
- return status;
- }
- #endif
-@@ -1077,15 +1103,22 @@ extract_fifo (char *file_name, int typeflag)
- 0 < same_owner_option ? mode & (S_IRWXG | S_IRWXO) : 0;
-
- while ((status = mkfifo (file_name, mode)) != 0)
-- if (!maybe_recoverable (file_name, &interdir_made))
-- break;
-+ switch (maybe_recoverable (file_name, &interdir_made))
-+ {
-+ case RECOVER_OK:
-+ continue;
-+
-+ case RECOVER_SKIP:
-+ return 0;
-+
-+ case RECOVER_NO:
-+ mkfifo_error (file_name);
-+ return -1;
-+ }
-
-- if (status == 0)
-- set_stat (file_name, &current_stat_info, NULL, invert_permissions,
-- ARCHIVED_PERMSTATUS, typeflag);
-- else
-- mkfifo_error (file_name);
-- return status;
-+ set_stat (file_name, &current_stat_info, NULL, invert_permissions,
-+ ARCHIVED_PERMSTATUS, typeflag);
-+ return 0;
- }
- #endif
-
---
-1.7.1.1
-
diff --git a/app-arch/tar/files/tar-1.23-tests.patch b/app-arch/tar/files/tar-1.23-tests.patch
deleted file mode 100644
index 72eeadc249c9..000000000000
--- a/app-arch/tar/files/tar-1.23-tests.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-http://bugs.gentoo.org/326785
-
-From 67b4f3519d838c6f16f5b6b63c0b9b8669fb3dd9 Mon Sep 17 00:00:00 2001
-From: Sergey Poznyakoff <gray@gnu.org.ua>
-Date: Fri, 12 Mar 2010 09:48:46 +0200
-Subject: [PATCH] Bugfixes.
-
-* tests/remfiles01.at: Skip if run with root privileges.
----
- tests/remfiles01.at | 1 +
- 2 files changed, 2 insertions(+), 1 deletions(-)
-
-diff --git a/tests/remfiles01.at b/tests/remfiles01.at
-index 940fd95..73752b4 100644
---- a/tests/remfiles01.at
-+++ b/tests/remfiles01.at
-@@ -30,6 +30,7 @@ AT_KEYWORDS([create remove-files remfiles01 gzip])
-
- unset TAR_OPTIONS
- AT_CHECK([
-+AT_UNPRIVILEGED_PREREQ
- AT_GZIP_PREREQ
- AT_SORT_PREREQ
-
---
-1.7.1.1
-
diff --git a/app-arch/tar/files/tar-1.25-incremental-fix.patch b/app-arch/tar/files/tar-1.25-incremental-fix.patch
deleted file mode 100644
index 0281580c3679..000000000000
--- a/app-arch/tar/files/tar-1.25-incremental-fix.patch
+++ /dev/null
@@ -1,133 +0,0 @@
-http://lists.gnu.org/archive/html/bug-tar/2010-11/msg00071.html
-http://bugs.gentoo.org/349164
-
-From 065cf0958c39600f2062cbeeb5b76929d03c207b Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Mon, 22 Nov 2010 22:50:58 -0800
-Subject: [PATCH] * src/names.c: tar: fix bug with --one-file-system --listed-incremental
-
-Problem (and idea for fix) reported by Martin Weigel
-<http://lists.gnu.org/archive/html/bug-tar/2010-11/msg00071.html>.
-* src/common.h (is_individual_file): Remove decl.
-* src/create.c (dump_file0): Replace "is_individual_file (p)"
-with "top_level".
-* src/incremen.c (procdir): Replace "!is_individual_file
-(name_buffer)" with "st->parent". Fix bug with --one-file-system
-and --listed-incremental.
-* src/names.c (individual_file_table, register_individual_file):
-(is_individual_file): Remove. All uses removed.
----
- src/common.h | 1 -
- src/create.c | 4 ++--
- src/incremen.c | 8 ++------
- src/names.c | 26 --------------------------
- 4 files changed, 4 insertions(+), 35 deletions(-)
-
-diff --git a/src/common.h b/src/common.h
-index 35e056e..9444fd7 100644
---- a/src/common.h
-+++ b/src/common.h
-@@ -680,7 +680,6 @@ bool excluded_name (char const *name);
-
- void add_avoided_name (char const *name);
- bool is_avoided_name (char const *name);
--bool is_individual_file (char const *name);
-
- bool contains_dot_dot (char const *name);
-
-diff --git a/src/create.c b/src/create.c
-index a1e90a3..e8de6b9 100644
---- a/src/create.c
-+++ b/src/create.c
-@@ -1678,9 +1678,9 @@ dump_file0 (struct tar_stat_info *st, char const *name, char const *p)
- put in the archive.
-
- This check is omitted if incremental_option is set *and* the
-- requested file is not explicitely listed in the command line. */
-+ requested file is not explicitly listed in the command line. */
-
-- if (!(incremental_option && !is_individual_file (p))
-+ if (! (incremental_option && ! top_level)
- && !S_ISDIR (st->stat.st_mode)
- && OLDER_TAR_STAT_TIME (*st, m)
- && (!after_date_option || OLDER_TAR_STAT_TIME (*st, c)))
-diff --git a/src/incremen.c b/src/incremen.c
-index 628ff29..2b33c5d 100644
---- a/src/incremen.c
-+++ b/src/incremen.c
-@@ -426,7 +426,6 @@ procdir (const char *name_buffer, struct tar_stat_info *st,
- {
- struct directory *directory;
- struct stat *stat_data = &st->stat;
-- dev_t device = st->parent ? st->parent->stat.st_dev : 0;
- bool nfs = NFS_FILE_STAT (*stat_data);
-
- if ((directory = find_directory (name_buffer)) != NULL)
-@@ -540,11 +539,8 @@ procdir (const char *name_buffer, struct tar_stat_info *st,
- }
- }
-
-- /* If the directory is on another device and --one-file-system was given,
-- omit it... */
-- if (one_file_system_option && device != stat_data->st_dev
-- /* ... except if it was explicitely given in the command line */
-- && !is_individual_file (name_buffer))
-+ if (one_file_system_option && st->parent
-+ && stat_data->st_dev != st->parent->stat.st_dev)
- /* FIXME:
- WARNOPT (WARN_XDEV,
- (0, 0,
-diff --git a/src/names.c b/src/names.c
-index 6e214bf..ba4d509 100644
---- a/src/names.c
-+++ b/src/names.c
-@@ -47,8 +47,6 @@ static char *cached_no_such_gname;
- static uid_t cached_no_such_uid;
- static gid_t cached_no_such_gid;
-
--static void register_individual_file (char const *name);
--
- /* Given UID, find the corresponding UNAME. */
- void
- uid_to_uname (uid_t uid, char **uname)
-@@ -360,8 +358,6 @@ name_next_elt (int change_dirs)
- {
- if (unquote_option)
- unquote_string (name_buffer);
-- if (incremental_option)
-- register_individual_file (name_buffer);
- entry.type = ep->type;
- entry.v.name = name_buffer;
- return &entry;
-@@ -1152,28 +1148,6 @@ excluded_name (char const *name)
- return excluded_file_name (excluded, name + FILE_SYSTEM_PREFIX_LEN (name));
- }
-
--static Hash_table *individual_file_table;
--
--static void
--register_individual_file (char const *name)
--{
-- struct stat st;
--
-- if (deref_stat (name, &st) != 0)
-- return; /* Will be complained about later */
-- if (S_ISDIR (st.st_mode))
-- return;
--
-- hash_string_insert (&individual_file_table, name);
--}
--
--bool
--is_individual_file (char const *name)
--{
-- return hash_string_lookup (individual_file_table, name);
--}
--
--
-
- /* Return the size of the prefix of FILE_NAME that is removed after
- stripping NUM leading file name components. NUM must be
---
-1.7.3.1
-
diff --git a/app-arch/tar/files/tar-1.25-verify-check.patch b/app-arch/tar/files/tar-1.25-verify-check.patch
deleted file mode 100644
index 31f0f7769dec..000000000000
--- a/app-arch/tar/files/tar-1.25-verify-check.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 73d0d1a0f883be5f67534362c99382f1eae8d178 Mon Sep 17 00:00:00 2001
-From: Sergey Poznyakoff <gray@gnu.org.ua>
-Date: Mon, 15 Nov 2010 11:22:27 +0200
-Subject: [PATCH] Issue a warning if the archive being compared contais transformed file names.
-
-* src/common.h (transform_program_p): New proto.
-* src/transform.c (transform_program_p): New function.
-* src/compare.c (verify_volume): Warn if the archive contains
-transformed file names.
----
- src/common.h | 1 +
- src/compare.c | 13 +++++++++++--
- src/transform.c | 6 ++++++
- 3 files changed, 18 insertions(+), 2 deletions(-)
-
-diff --git a/src/common.h b/src/common.h
-index 69097b3..35e056e 100644
---- a/src/common.h
-+++ b/src/common.h
-@@ -779,6 +779,7 @@ void set_transform_expr (const char *expr);
- bool transform_name (char **pinput, int type);
- bool transform_name_fp (char **pinput, int type,
- char *(*fun)(char *, void *), void *);
-+bool transform_program_p (void);
-
- /* Module suffix.c */
- void set_compression_program_by_suffix (const char *name, const char *defprog);
-diff --git a/src/compare.c b/src/compare.c
-index f3112c6..91ced57 100644
---- a/src/compare.c
-+++ b/src/compare.c
-@@ -512,14 +512,23 @@ diff_archive (void)
- void
- verify_volume (void)
- {
-+ int may_fail = 0;
- if (removed_prefixes_p ())
- {
- WARN((0, 0,
- _("Archive contains file names with leading prefixes removed.")));
-+ may_fail = 1;
-+ }
-+ if (transform_program_p ())
-+ {
- WARN((0, 0,
-- _("Verification may fail to locate original files.")));
-+ _("Archive contains transformed file names.")));
-+ may_fail = 1;
- }
--
-+ if (may_fail)
-+ WARN((0, 0,
-+ _("Verification may fail to locate original files.")));
-+
- if (!diff_buffer)
- diff_init ();
-
-diff --git a/src/transform.c b/src/transform.c
-index c35133f..77aa0a2 100644
---- a/src/transform.c
-+++ b/src/transform.c
-@@ -628,3 +628,9 @@ transform_name (char **pinput, int type)
- {
- return transform_name_fp (pinput, type, NULL, NULL);
- }
-+
-+bool
-+transform_program_p (void)
-+{
-+ return transform_head != NULL;
-+}
---
-1.7.3.1
-
diff --git a/app-arch/tar/files/tar-1.25-verify-fix.patch b/app-arch/tar/files/tar-1.25-verify-fix.patch
deleted file mode 100644
index 5f5a81c1a7b9..000000000000
--- a/app-arch/tar/files/tar-1.25-verify-fix.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-http://lists.gnu.org/archive/html/bug-tar/2010-11/msg00065.html
-http://bugs.gentoo.org/349155
-
-From 24214ca5d506f56dc0cb2a2e1312256472039475 Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Mon, 15 Nov 2010 00:07:53 -0800
-Subject: [PATCH] tar: fix --verify option, which broke in 1.24
-
-* NEWS: Document this.
-* src/compare.c (verify_volume): Decode the header before invoking
-diff_archive, as diff_archive no longer does this as of the
-2010-06-28 commit. Also, don't try to invoke diff_archive on a
-zero block.
-* tests/Makefile.am (TESTSUITE_AT): Add verify.at.
-* tests/testsuite.at: Include verify.at.
-* tests/verify.at: New file.
----
- NEWS | 10 ++++++++--
- src/compare.c | 2 ++
- tests/Makefile.am | 1 +
- tests/testsuite.at | 2 ++
- tests/verify.at | 37 +++++++++++++++++++++++++++++++++++++
- 5 files changed, 50 insertions(+), 2 deletions(-)
- create mode 100644 tests/verify.at
-
-diff --git a/src/compare.c b/src/compare.c
-index 6b7e6d8..f3112c6 100644
---- a/src/compare.c
-+++ b/src/compare.c
-@@ -611,8 +611,10 @@ verify_volume (void)
- (0, 0, _("A lone zero block at %s"),
- STRINGIFY_BIGINT (current_block_ordinal (), buf)));
- }
-+ continue;
- }
-
-+ decode_header (current_header, &current_stat_info, &current_format, 1);
- diff_archive ();
- tar_stat_destroy (&current_stat_info);
- }
---
-1.7.3.1
-